The csh profile.d had a bug preventing it from working for root. Teaches you not...
authorPetteri Räty <betelgeuse@gentoo.org>
Sat, 13 Jan 2007 16:36:54 +0000 (16:36 +0000)
committerPetteri Räty <betelgeuse@gentoo.org>
Sat, 13 Jan 2007 16:36:54 +0000 (16:36 +0000)
Package-Manager: portage-2.1.2_rc4-r7

dev-java/java-config/ChangeLog
dev-java/java-config/files/digest-java-config-2.0.31-r2 [new file with mode: 0644]
dev-java/java-config/files/java-config-2.profiled.csh
dev-java/java-config/java-config-2.0.31-r2.ebuild [new file with mode: 0644]

index b2b12d091c50f60c9b3ac8e75543e4f0a9f4d290..ef5538d6381547c93c55d6e6f0c4ab9b04f24092 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for dev-java/java-config
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/ChangeLog,v 1.136 2007/01/13 12:35:42 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/ChangeLog,v 1.137 2007/01/13 16:36:54 betelgeuse Exp $
+
+*java-config-2.0.31-r2 (13 Jan 2007)
+
+  13 Jan 2007; Petteri Räty <betelgeuse@gentoo.org>
+  files/java-config-2.profiled.csh, -java-config-2.0.31-r1.ebuild,
+  +java-config-2.0.31-r2.ebuild:
+  The csh profile.d had a bug preventing it from working for root. Teaches you
+  not to blindly trust stuff from users again.
 
   13 Jan 2007; Vlastimil Babka <caster@gentoo.org>
   java-config-2.0.30.ebuild:
diff --git a/dev-java/java-config/files/digest-java-config-2.0.31-r2 b/dev-java/java-config/files/digest-java-config-2.0.31-r2
new file mode 100644 (file)
index 0000000..393d9db
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 36b7893b20b9f4b6f0af6dd632703745 java-config-2.0.31.tar.bz2 17001
+RMD160 4b3d8362538b435a642312ee7289824d6662e309 java-config-2.0.31.tar.bz2 17001
+SHA256 314ec1783da8190d60e757aaef2af8eae7281c3c9754024e3e59643ce7a30752 java-config-2.0.31.tar.bz2 17001
index ee9b65f7d4ac0c6f92eaa340322fed33008edf1d..f2957d1a622d5f692af1fc4b628b3eb4a8177a0b 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/files/java-config-2.profiled.csh,v 1.1 2007/01/12 17:57:48 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/files/java-config-2.profiled.csh,v 1.2 2007/01/13 16:36:54 betelgeuse Exp $
 
 set gentoo_user_vm="${HOME}/.gentoo/java-config-2/current-user-vm"
 set gentoo_system_vm="/etc/java-config-2/current-system-vm"
@@ -9,7 +9,7 @@ set gentoo_system_vm="/etc/java-config-2/current-system-vm"
 ## Otherwise set to the current system vm
 if (($uid != "0") && (-l $gentoo_user_vm)) then
     setenv JAVA_HOME $gentoo_user_vm
-else if (-L $gentoo_system_vm) then
+else if (-l $gentoo_system_vm) then
     setenv JAVA_HOME $gentoo_system_vm
 endif
 
diff --git a/dev-java/java-config/java-config-2.0.31-r2.ebuild b/dev-java/java-config/java-config-2.0.31-r2.ebuild
new file mode 100644 (file)
index 0000000..7156b8d
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/java-config-2.0.31-r2.ebuild,v 1.1 2007/01/13 16:36:54 betelgeuse Exp $
+
+inherit base distutils eutils
+
+DESCRIPTION="Java environment configuration tool"
+HOMEPAGE="http://www.gentoo.org/proj/en/java/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-lang/python"
+RDEPEND="${DEPEND}
+       dev-java/java-config-wrapper"
+
+src_install() {
+       distutils_src_install
+
+       insinto /usr/share/java-config-2/config/
+       for i in alpha amd64 hppa ia64 ppc ppc64 sparc x86 x86-fbsd; do
+               if use ${i}; then
+                       newins config/jdk-defaults-${i}.conf jdk-defaults.conf || die "arch     config not found"
+               fi
+       done
+
+       for tool in $(< config/symlink-tools); do
+               dosym /usr/bin/run-java-tool /usr/bin/${tool}
+       done
+
+       # Install profile.d for setting JAVA_HOME
+       dodir /etc/profile.d
+       exeinto /etc/profile.d
+       newexe ${FILESDIR}/${PN}-${SLOT}.profiled.sh ${PN}-${SLOT}.sh || die "newexe failed"
+       newexe ${FILESDIR}/${PN}-${SLOT}.profiled.csh ${PN}-${SLOT}.csh || die "newexe failed"
+}
+
+
+pkg_postrm() {
+       python_mod_cleanup /usr/share/java-config-2/pym/java_config
+}
+
+pkg_postinst() {
+       python_mod_optimize /usr/share/java-config-2/pym/java_config
+
+       elog "The way Java is handled on Gentoo has been recently updated."
+       elog "If you have not done so already, you should follow the"
+       elog "instructions available at:"
+       elog "\thttp://www.gentoo.org/proj/en/java/java-upgrade.xml"
+       elog
+       elog "While we are moving towards the new Java system, we only allow"
+       elog "1.3 or 1.4 JDKs to be used with java-config-1 to ensure"
+       elog "backwards compatibility with the old system."
+       elog "For more details about this, please see:"
+       elog "\thttps://overlays.gentoo.org/proj/java/wiki/Why_We_Need_Java14"
+}