sys-apps/pkgcore: version bump
authorTim Harder <radhermit@gentoo.org>
Mon, 24 Aug 2015 00:17:37 +0000 (20:17 -0400)
committerTim Harder <radhermit@gentoo.org>
Mon, 24 Aug 2015 00:17:37 +0000 (20:17 -0400)
sys-apps/pkgcore/Manifest
sys-apps/pkgcore/pkgcore-0.9.2.ebuild [new file with mode: 0644]

index 9fee77687204fff0b4a092757257e2817c33f1a0..8b1b67eee11ad248fb4f93ded8cad3e94f820f45 100644 (file)
@@ -1 +1,2 @@
 DIST pkgcore-0.9.1.tar.gz 570633 SHA256 d5f556c7dcf69aa45f8bc80c95cc5273de389d21ab7932a1cd8babcd5aa2fc10 SHA512 3cd221070369af07729afa2af5bba20a544d2d58913a6e8d7da90b7a59d043fec906b7276032194cc5c86d84417793ba732f326a342b5ac439f1f2bf6b14a262 WHIRLPOOL f39f927f0334be9ab95ed6bf6b8074f707fcee57eb124dc25b48bdc40c4743959fa9826e7cec593f082233624335d753f09990ce3faf7a798abf442c8879bbda
+DIST pkgcore-0.9.2.tar.bz2 464923 SHA256 99c554588b7d75b8d4a8e5ee333dd70861cda21d15a4754afd8c2adefffa0835 SHA512 33620d7c7a3fd2b8334dacf7bb925dcfe293a206c04125a738e3728a2c70e5491c3659b6aacc5427eb099ebbcd675424712751ecbfd20f2d55a7247ccf273064 WHIRLPOOL badd2bb5d5b2dc5752a11a60f938001212e24605ad030e37c00d3cc98a9daa2b08fb486777a218cf22fe30eb82e9f8e342838640adf967a75e197e8926cd7535
diff --git a/sys-apps/pkgcore/pkgcore-0.9.2.ebuild b/sys-apps/pkgcore/pkgcore-0.9.2.ebuild
new file mode 100644 (file)
index 0000000..eb1f724
--- /dev/null
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/pkgcore/pkgcore.git"
+       inherit git-r3
+else
+       KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+fi
+
+DESCRIPTION="pkgcore package manager"
+HOMEPAGE="https://github.com/pkgcore/pkgcore"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+IUSE="doc test"
+
+if [[ ${PV} == *9999 ]] ; then
+       SPHINX="dev-python/sphinx[${PYTHON_USEDEP}]"
+else
+       SPHINX="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+fi
+RDEPEND=">=dev-python/snakeoil-0.6.5[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       ${SPHINX}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/pyparsing[${PYTHON_USEDEP}]
+       test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )
+"
+
+pkg_setup() {
+       # disable snakeoil 2to3 caching...
+       unset PY2TO3_CACHEDIR
+}
+
+python_compile_all() {
+       if [[ ${PV} == *9999 ]]; then
+               esetup.py build_man
+               ln -s "${BUILD_DIR}/sphinx/man" man || die
+       fi
+
+       if use doc; then
+               esetup.py build_docs
+               ln -s "${BUILD_DIR}/sphinx/html" html || die
+       fi
+}
+
+python_test() {
+       esetup.py test
+}
+
+python_install_all() {
+       local cmds=(
+               install_man
+       )
+       use doc && cmds+=(
+               install_docs --path="${ED%/}"/usr/share/doc/${PF}/html
+       )
+
+       distutils-r1_python_install "${cmds[@]}"
+       distutils-r1_python_install_all
+
+       insinto /usr/share/zsh/site-functions
+       doins completion/zsh/*
+}
+
+pkg_postinst() {
+       python_foreach_impl pplugincache
+}