dev-python/clint: EAPI=7
authorCraig Andrews <candrews@gentoo.org>
Sun, 13 Oct 2019 20:21:44 +0000 (16:21 -0400)
committerCraig Andrews <candrews@gentoo.org>
Sun, 13 Oct 2019 20:23:14 +0000 (16:23 -0400)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Craig Andrews <candrews@gentoo.org>
dev-python/clint/clint-0.5.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/clint/clint-0.5.1-r1.ebuild b/dev-python/clint/clint-0.5.1-r1.ebuild
new file mode 100644 (file)
index 0000000..f416abd
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python Command-line Application Tools"
+HOMEPAGE="https://github.com/kennethreitz/clint"
+SRC_URI="https://github.com/kennethreitz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND="dev-python/args[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+       use doc && emake -C docs html
+}
+
+python_test() {
+       py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/_build/html/. )
+       if use examples; then
+               insinto /usr/share/doc/${PF}
+               doins -r examples
+       fi
+
+       distutils-r1_python_install_all
+}