app-editors/emacs-vcs: emacs-26.2.90 snapshot from upstream.
authorUlrich Müller <ulm@gentoo.org>
Sat, 15 Jun 2019 15:19:06 +0000 (17:19 +0200)
committerUlrich Müller <ulm@gentoo.org>
Sat, 15 Jun 2019 15:19:06 +0000 (17:19 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-editors/emacs-vcs/Manifest
app-editors/emacs-vcs/emacs-vcs-26.2.90.ebuild [new file with mode: 0644]

index 93af8da7a5ef055d17782111607016ba77ac807b..f66409fa88bc5e2df1d78ae3ca66f4862ceb291f 100644 (file)
@@ -1 +1,2 @@
+DIST emacs-26.2.90.tar.xz 44412120 BLAKE2B 72eab92b3144e3807a612a1a4c87da23181ab9b42b12692401f666eae7fbdb3e832d4f5d9dbc6473df8de9af6046ad94bbb0874a57747b594dbae62435fe5357 SHA512 66e53ae2a6d89505111e7bc9b7a6e6324a9a5577d1ad8905244dbc8619b21ea410b20bd8bab0442ec226f7a0d5f2292e01171189517736e4fa5e0e15eba51074
 DIST emacs-27.0.50_pre20180831.tar.xz 28668124 BLAKE2B fae74d9885889b042142f580e971c73c193306dca26b42dd87ac3d3d765312ce6695511d7d31a047d79803982f6345c4c319a3d83cea1313080170da97482fa2 SHA512 43b32d8943dc897dfc0c1fddb4261a196d3a604add5bcf87a93748125f15db2cac762d3550d6593b80e961ae35d543adc4d5937bac77970c658f93dba26f17e4
diff --git a/app-editors/emacs-vcs/emacs-vcs-26.2.90.ebuild b/app-editors/emacs-vcs/emacs-vcs-26.2.90.ebuild
new file mode 100644 (file)
index 0000000..25c6c33
--- /dev/null
@@ -0,0 +1,408 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools elisp-common flag-o-matic multilib readme.gentoo-r1
+
+if [[ ${PV##*.} = 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://git.savannah.gnu.org/git/emacs.git"
+       EGIT_BRANCH="emacs-26"
+       EGIT_CHECKOUT_DIR="${WORKDIR}/emacs"
+       S="${EGIT_CHECKOUT_DIR}"
+else
+       SRC_URI="https://dev.gentoo.org/~ulm/distfiles/emacs-${PV}.tar.xz
+               mirror://gnu-alpha/emacs/pretest/emacs-${PV}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+       # FULL_VERSION keeps the full version number, which is needed in
+       # order to determine some path information correctly for copy/move
+       # operations later on
+       FULL_VERSION="${PV%%_*}"
+       S="${WORKDIR}/emacs-${FULL_VERSION}"
+       [[ ${FULL_VERSION} != ${PV} ]] && S="${WORKDIR}/emacs"
+fi
+
+DESCRIPTION="The extensible, customizable, self-documenting real-time display editor"
+HOMEPAGE="https://www.gnu.org/software/emacs/"
+
+LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
+SLOT="26"
+IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gconf gfile gif gpm gsettings gtk gtk2 gzip-el imagemagick +inotify jpeg kerberos lcms libxml2 livecd m17n-lib mailutils motif png selinux sound source ssl svg systemd +threads tiff toolkit-scroll-bars wide-int X Xaw3d xft +xpm xwidgets zlib"
+REQUIRED_USE="?? ( aqua X )"
+
+RDEPEND="sys-libs/ncurses:0=
+       >=app-eselect/eselect-emacs-1.16
+       >=app-emacs/emacs-common-gentoo-1.5[games?,X?]
+       acl? ( virtual/acl )
+       alsa? ( media-libs/alsa-lib )
+       dbus? ( sys-apps/dbus )
+       gpm? ( sys-libs/gpm )
+       !inotify? ( gfile? ( >=dev-libs/glib-2.28.6 ) )
+       kerberos? ( virtual/krb5 )
+       lcms? ( media-libs/lcms:2 )
+       libxml2? ( >=dev-libs/libxml2-2.2.0 )
+       mailutils? ( net-mail/mailutils[clients] )
+       !mailutils? ( net-libs/liblockfile )
+       selinux? ( sys-libs/libselinux )
+       ssl? ( net-libs/gnutls:0= )
+       systemd? ( sys-apps/systemd )
+       zlib? ( sys-libs/zlib )
+       X? (
+               x11-libs/libICE
+               x11-libs/libSM
+               x11-libs/libX11
+               x11-libs/libXext
+               x11-libs/libXfixes
+               x11-libs/libXinerama
+               x11-libs/libXrandr
+               x11-libs/libxcb
+               x11-misc/xbitmaps
+               gconf? ( >=gnome-base/gconf-2.26.2 )
+               gsettings? ( >=dev-libs/glib-2.28.6 )
+               gif? ( media-libs/giflib:0= )
+               jpeg? ( virtual/jpeg:0= )
+               png? ( >=media-libs/libpng-1.4:0= )
+               svg? ( >=gnome-base/librsvg-2.0 )
+               tiff? ( media-libs/tiff:0 )
+               xpm? ( x11-libs/libXpm )
+               imagemagick? ( >=media-gfx/imagemagick-6.6.2:0=
+                       <media-gfx/imagemagick-7:0= )
+               xft? (
+                       media-libs/fontconfig
+                       media-libs/freetype
+                       x11-libs/libXft
+                       x11-libs/libXrender
+                       cairo? ( >=x11-libs/cairo-1.12.18 )
+                       m17n-lib? (
+                               >=dev-libs/libotf-0.9.4
+                               >=dev-libs/m17n-lib-1.5.1
+                       )
+               )
+               gtk? (
+                       gtk2? ( x11-libs/gtk+:2 )
+                       !gtk2? (
+                               x11-libs/gtk+:3
+                               xwidgets? (
+                                       net-libs/webkit-gtk:4=
+                                       x11-libs/libXcomposite
+                               )
+                       )
+               )
+               !gtk? (
+                       motif? (
+                               >=x11-libs/motif-2.3:0
+                               x11-libs/libXpm
+                               x11-libs/libXmu
+                               x11-libs/libXt
+                       )
+                       !motif? (
+                               Xaw3d? (
+                                       x11-libs/libXaw3d
+                                       x11-libs/libXmu
+                                       x11-libs/libXt
+                               )
+                               !Xaw3d? ( athena? (
+                                       x11-libs/libXaw
+                                       x11-libs/libXmu
+                                       x11-libs/libXt
+                               ) )
+                       )
+               )
+       )"
+
+DEPEND="${RDEPEND}
+       X? ( x11-base/xorg-proto )"
+
+BDEPEND="virtual/pkgconfig
+       gzip-el? ( app-arch/gzip )"
+#      pax_kernel? ( sys-apps/attr )
+
+if [[ ${PV##*.} = 9999 ]]; then
+       BDEPEND="${BDEPEND}
+       sys-apps/texinfo"
+fi
+
+EMACS_SUFFIX="${PN/emacs/emacs-${SLOT}}"
+SITEFILE="20${PN}-${SLOT}-gentoo.el"
+
+src_prepare() {
+       if [[ ${PV##*.} = 9999 ]]; then
+               FULL_VERSION=$(sed -n 's/^AC_INIT([^,]*,[ \t]*\([^ \t,)]*\).*/\1/p' \
+                       configure.ac)
+               [[ ${FULL_VERSION} ]] || die "Cannot determine current Emacs version"
+               einfo "Emacs branch: ${EGIT_BRANCH}"
+               einfo "Commit: ${EGIT_VERSION}"
+               einfo "Emacs version number: ${FULL_VERSION}"
+               [[ ${FULL_VERSION} =~ ^${PV%.*}(\..*)?$ ]] \
+                       || die "Upstream version number changed to ${FULL_VERSION}"
+       fi
+
+       eapply_user
+
+       # Fix filename reference in redirected man page
+       sed -i -e "/^\\.so/s/etags/&-${EMACS_SUFFIX}/" doc/man/ctags.1 || die
+
+       AT_M4DIR=m4 eautoreconf
+}
+
+src_configure() {
+       strip-flags
+       filter-flags -pie                                       #526948
+
+       if use sh; then
+               replace-flags "-O[1-9]" -O0             #262359
+       elif use ia64; then
+               replace-flags "-O[2-9]" -O1             #325373
+       else
+               replace-flags "-O[3-9]" -O2
+       fi
+
+       local myconf
+
+       if use alsa; then
+               use sound || ewarn \
+                       "USE flag \"alsa\" overrides \"-sound\"; enabling sound support."
+               myconf+=" --with-sound=alsa"
+       else
+               myconf+=" --with-sound=$(usex sound oss)"
+       fi
+
+       if use X; then
+               myconf+=" --with-x --without-ns"
+               myconf+=" $(use_with gconf)"
+               myconf+=" $(use_with gsettings)"
+               myconf+=" $(use_with toolkit-scroll-bars)"
+               myconf+=" $(use_with gif)"
+               myconf+=" $(use_with jpeg)"
+               myconf+=" $(use_with png)"
+               myconf+=" $(use_with svg rsvg)"
+               myconf+=" $(use_with tiff)"
+               myconf+=" $(use_with xpm)"
+               myconf+=" $(use_with imagemagick)"
+
+               if use xft; then
+                       myconf+=" --with-xft"
+                       myconf+=" $(use_with cairo)"
+                       myconf+=" $(use_with m17n-lib libotf)"
+                       myconf+=" $(use_with m17n-lib m17n-flt)"
+               else
+                       myconf+=" --without-xft"
+                       myconf+=" --without-cairo"
+                       myconf+=" --without-libotf --without-m17n-flt"
+                       use cairo && ewarn \
+                               "USE flag \"cairo\" has no effect if \"xft\" is not set."
+                       use m17n-lib && ewarn \
+                               "USE flag \"m17n-lib\" has no effect if \"xft\" is not set."
+               fi
+
+               local f line
+               if use gtk; then
+                       einfo "Configuring to build with GIMP Toolkit (GTK+)"
+                       while read line; do ewarn "${line}"; done <<-EOF
+                               Your version of GTK+ will have problems with closing open
+                               displays. This is no problem if you just use one display, but
+                               if you use more than one and close one of them Emacs may crash.
+                               See <https://bugzilla.gnome.org/show_bug.cgi?id=85715>.
+                               If you intend to use more than one display, then it is strongly
+                               recommended that you compile Emacs with the Athena/Lucid or the
+                               Motif toolkit instead.
+                       EOF
+                       if use gtk2; then
+                               myconf+=" --with-x-toolkit=gtk2 --without-xwidgets"
+                               use xwidgets && ewarn \
+                                       "USE flag \"xwidgets\" has no effect if \"gtk2\" is set."
+                       else
+                               myconf+=" --with-x-toolkit=gtk3 $(use_with xwidgets)"
+                       fi
+                       for f in motif Xaw3d athena; do
+                               use ${f} && ewarn \
+                                       "USE flag \"${f}\" has no effect if \"gtk\" is set."
+                       done
+               elif use motif; then
+                       einfo "Configuring to build with Motif toolkit"
+                       myconf+=" --with-x-toolkit=motif"
+                       for f in Xaw3d athena; do
+                               use ${f} && ewarn \
+                                       "USE flag \"${f}\" has no effect if \"motif\" is set."
+                       done
+               elif use athena || use Xaw3d; then
+                       einfo "Configuring to build with Athena/Lucid toolkit"
+                       myconf+=" --with-x-toolkit=lucid $(use_with Xaw3d xaw3d)"
+               else
+                       einfo "Configuring to build with no toolkit"
+                       myconf+=" --with-x-toolkit=no"
+               fi
+               if ! use gtk; then
+                       use gtk2 && ewarn \
+                               "USE flag \"gtk2\" has no effect if \"gtk\" is not set."
+                       use xwidgets && ewarn \
+                               "USE flag \"xwidgets\" has no effect if \"gtk\" is not set."
+               fi
+       elif use aqua; then
+               einfo "Configuring to build with Nextstep (Cocoa) support"
+               myconf+=" --with-ns --disable-ns-self-contained"
+               myconf+=" --without-x"
+       else
+               myconf+=" --without-x --without-ns"
+       fi
+
+       econf \
+               --program-suffix="-${EMACS_SUFFIX}" \
+               --includedir="${EPREFIX}"/usr/include/${EMACS_SUFFIX} \
+               --infodir="${EPREFIX}"/usr/share/info/${EMACS_SUFFIX} \
+               --localstatedir="${EPREFIX}"/var \
+               --enable-locallisppath="${EPREFIX}/etc/emacs:${EPREFIX}${SITELISP}" \
+               --without-compress-install \
+               --without-hesiod \
+               --without-pop \
+               --with-file-notification=$(usev inotify || usev gfile || echo no) \
+               $(use_enable acl) \
+               $(use_with dbus) \
+               $(use_with dynamic-loading modules) \
+               $(use_with games gameuser ":gamestat") \
+               $(use_with gpm) \
+               $(use_with kerberos) $(use_with kerberos kerberos5) \
+               $(use_with lcms lcms2) \
+               $(use_with libxml2 xml2) \
+               $(use_with mailutils) \
+               $(use_with selinux) \
+               $(use_with ssl gnutls) \
+               $(use_with systemd libsystemd) \
+               $(use_with threads) \
+               $(use_with wide-int) \
+               $(use_with zlib) \
+               ${myconf}
+}
+
+src_compile() {
+       # Disable sandbox when dumping. For the unbelievers, see bug #131505
+       emake RUN_TEMACS="SANDBOX_ON=0 LD_PRELOAD= env ./temacs"
+}
+
+src_install () {
+       emake DESTDIR="${D}" NO_BIN_LINK=t install
+
+       mv "${ED}"/usr/bin/{emacs-${FULL_VERSION}-,}${EMACS_SUFFIX} || die
+       mv "${ED}"/usr/share/man/man1/{emacs-,}${EMACS_SUFFIX}.1 || die
+       mv "${ED}"/usr/share/metainfo/{emacs-,}${EMACS_SUFFIX}.appdata.xml || die
+
+       # move info dir to avoid collisions with the dir file generated by portage
+       mv "${ED}"/usr/share/info/${EMACS_SUFFIX}/dir{,.orig} || die
+       touch "${ED}"/usr/share/info/${EMACS_SUFFIX}/.keepinfodir
+       docompress -x /usr/share/info/${EMACS_SUFFIX}/dir.orig
+
+       # avoid collision between slots, see bug #169033 e.g.
+       rm "${ED}"/usr/share/emacs/site-lisp/subdirs.el
+       rm -rf "${ED}"/usr/share/{appdata,applications,icons}
+       rm -rf "${ED}/usr/$(get_libdir)"
+       rm -rf "${ED}"/var
+
+       # remove unused <version>/site-lisp dir
+       rm -rf "${ED}"/usr/share/emacs/${FULL_VERSION}/site-lisp
+
+       # remove COPYING file (except for etc/COPYING used by describe-copying)
+       rm "${ED}"/usr/share/emacs/${FULL_VERSION}/lisp/COPYING
+
+       if use gzip-el; then
+               # compress .el files when a corresponding .elc exists
+               find "${ED}"/usr/share/emacs/${FULL_VERSION}/lisp -type f \
+                       -name "*.elc" -print | sed 's/\.elc$/.el/' | xargs gzip -9n
+               assert "gzip .el failed"
+       fi
+
+       local cdir
+       if use source; then
+               cdir="/usr/share/emacs/${FULL_VERSION}/src"
+               insinto "${cdir}"
+               # This is not meant to install all the source -- just the
+               # C source you might find via find-function
+               doins src/*.{c,h,m}
+       elif has installsources ${FEATURES}; then
+               cdir="/usr/src/debug/${CATEGORY}/${PF}/${S#"${WORKDIR}/"}/src"
+       fi
+
+       sed -e "${cdir:+#}/^Y/d" -e "s/^[XY]//" >"${T}/${SITEFILE}" <<-EOF || die
+       X
+       ;;; ${PN}-${SLOT} site-lisp configuration
+       X
+       (when (string-match "\\\\\`${FULL_VERSION//./\\\\.}\\\\>" emacs-version)
+       Y  (setq find-function-C-source-directory
+       Y       "${EPREFIX}${cdir}")
+       X  (let ((path (getenv "INFOPATH"))
+       X       (dir "${EPREFIX}/usr/share/info/${EMACS_SUFFIX}")
+       X       (re "\\\\\`${EPREFIX}/usr/share/info\\\\>"))
+       X    (and path
+       X        ;; move Emacs Info dir before anything else in /usr/share/info
+       X        (let* ((p (cons nil (split-string path ":" t))) (q p))
+       X          (while (and (cdr q) (not (string-match re (cadr q))))
+       X            (setq q (cdr q)))
+       X          (setcdr q (cons dir (delete dir (cdr q))))
+       X          (setq Info-directory-list (prune-directory-list (cdr p)))))))
+       EOF
+       elisp-site-file-install "${T}/${SITEFILE}" || die
+
+       dodoc README BUGS CONTRIBUTE
+
+       if use aqua; then
+               dodir /Applications/Gentoo
+               rm -rf "${ED}"/Applications/Gentoo/Emacs${EMACS_SUFFIX#emacs}.app
+               mv nextstep/Emacs.app \
+                       "${ED}"/Applications/Gentoo/Emacs${EMACS_SUFFIX#emacs}.app || die
+       fi
+
+       DOC_CONTENTS="You can set the version to be started by /usr/bin/emacs
+               through the Emacs eselect module, which also redirects man and info
+               pages. Therefore, several Emacs versions can be installed at the
+               same time. \"man emacs.eselect\" for details.
+               \\n\\nIf you upgrade from Emacs version 24.2 or earlier, then it is
+               strongly recommended that you use app-admin/emacs-updater to rebuild
+               all byte-compiled elisp files of the installed Emacs packages."
+       use X && DOC_CONTENTS+="\\n\\nYou need to install some fonts for Emacs.
+               Installing media-fonts/font-adobe-{75,100}dpi on the X server's
+               machine would satisfy basic Emacs requirements under X11.
+               See also https://wiki.gentoo.org/wiki/Xft_support_for_GNU_Emacs
+               for how to enable anti-aliased fonts."
+       use aqua && DOC_CONTENTS+="\\n\\nEmacs${EMACS_SUFFIX#emacs}.app is in
+               \"${EPREFIX}/Applications/Gentoo\". You may want to copy or symlink
+               it into /Applications by yourself."
+       readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+       # move Info dir file to correct name
+       local infodir=/usr/share/info/${EMACS_SUFFIX} f
+       if [[ -f ${ED}${infodir}/dir.orig ]]; then
+               mv "${ED}"${infodir}/dir{.orig,} || die
+       elif [[ -d "${ED}"${infodir} ]]; then
+               # this should not happen in EAPI 4
+               ewarn "Regenerating Info directory index in ${infodir} ..."
+               rm -f "${ED}"${infodir}/dir{,.*}
+               for f in "${ED}"${infodir}/*; do
+                       if [[ ${f##*/} != *-[0-9]* && -e ${f} ]]; then
+                               install-info --info-dir="${ED}"${infodir} "${f}" || die
+                       fi
+               done
+       fi
+}
+
+pkg_postinst() {
+       elisp-site-regen
+       readme.gentoo_print_elog
+
+       if use livecd; then
+               # force an update of the emacs symlink for the livecd/dvd,
+               # because some microemacs packages set it with USE=livecd
+               eselect emacs update
+       elif [[ $(readlink "${EROOT}"/usr/bin/emacs) = ${EMACS_SUFFIX} ]]; then
+               # refresh symlinks in case any installed files have changed
+               eselect emacs set ${EMACS_SUFFIX}
+       else
+               eselect emacs update ifunset
+       fi
+}
+
+pkg_postrm() {
+       elisp-site-regen
+       eselect emacs update ifunset
+}