kde-base/plasma-workspace: Drop Nepomuk support
authorJohannes Huber <johu@gentoo.org>
Wed, 12 Aug 2015 21:51:32 +0000 (23:51 +0200)
committerJohannes Huber <johu@gentoo.org>
Wed, 12 Aug 2015 22:03:31 +0000 (00:03 +0200)
Package-Manager: portage-2.2.20.1

kde-base/plasma-workspace/metadata.xml
kde-base/plasma-workspace/plasma-workspace-4.11.14.ebuild
kde-base/plasma-workspace/plasma-workspace-4.11.19.ebuild
kde-base/plasma-workspace/plasma-workspace-4.11.21.ebuild

index efbee2830268b21b88746adb1c99fb7f99510564..9be2aba709881c56e99c861f8fe6bfeee6acc01b 100644 (file)
@@ -4,7 +4,6 @@
        <herd>kde</herd>
        <use>
                <flag name="kdepim">KDE PIM integration via <pkg>kde-base/kdepimlibs</pkg></flag>
-               <flag name="nepomuk">Enable Nepomuk based semantic desktop support (deprecated)</flag>
                <flag name="json">Enable JSON support via <pkg>dev-libs/qjson</pkg></flag>
                <flag name="qalculate">Enable Qalculate runner using <pkg>sci-libs/libqalculate</pkg></flag>
        </use>
index 37bff32e0c78bc5453b3ebf343f9da8ff973c5b2..883850afacff7803af5f94ca64a7e6fd675b836a 100644 (file)
@@ -14,7 +14,7 @@ inherit python-single-r1 kde4-meta
 
 DESCRIPTION="Plasma: KDE desktop framework"
 KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="debug gps json +kdepim nepomuk python qalculate"
+IUSE="debug gps json +kdepim python qalculate"
 
 REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
 
@@ -23,7 +23,7 @@ COMMONDEPEND="
        >=dev-qt/qtcore-4.8.4-r3:4
        !kde-misc/ktouchpadenabler
        $(add_kdebase_dep kactivities)
-       $(add_kdebase_dep kdelibs 'crypt,nepomuk?')
+       $(add_kdebase_dep kdelibs 'crypt')
        $(add_kdebase_dep kephal)
        $(add_kdebase_dep ksysguard)
        $(add_kdebase_dep libkworkspace)
@@ -40,10 +40,6 @@ COMMONDEPEND="
        gps? ( >=sci-geosciences/gpsd-2.37 )
        json? ( dev-libs/qjson )
        kdepim? ( $(add_kdebase_dep kdepimlibs) )
-       nepomuk? (
-               dev-libs/soprano
-               $(add_kdebase_dep nepomuk-core)
-       )
        python? (
                ${PYTHON_DEPS}
                >=dev-python/PyQt4-4.4.0[X,${PYTHON_USEDEP}]
@@ -99,15 +95,15 @@ src_unpack() {
 
 src_configure() {
        local mycmakeargs=(
+               -DWITH_NepomukCore=OFF
+               -DWITH_Soprano=OFF
+               -DWITH_Xmms=OFF
                $(cmake-utils_use_with gps libgps)
                $(cmake-utils_use_with json QJSON)
                $(cmake-utils_use_with kdepim Akonadi)
                $(cmake-utils_use_with kdepim KdepimLibs)
-               $(cmake-utils_use_with nepomuk NepomukCore)
-               $(cmake-utils_use_with nepomuk Soprano)
                $(cmake-utils_use_with python PythonLibrary)
                $(cmake-utils_use_with qalculate)
-               -DWITH_Xmms=OFF
        )
 
        kde4-meta_src_configure
index 13967cda0c767ef562d9e4f12e31db0a9b9539b7..898922819cb013ac0619646f620ff9be871ba78a 100644 (file)
@@ -14,7 +14,7 @@ inherit python-single-r1 kde4-meta
 
 DESCRIPTION="Plasma: KDE desktop framework"
 KEYWORDS="amd64 ~arm ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="debug gps json +kdepim nepomuk python qalculate"
+IUSE="debug gps json +kdepim python qalculate"
 
 REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
 
@@ -23,7 +23,6 @@ COMMONDEPEND="
        >=dev-qt/qtcore-4.8.4-r3:4
        !kde-misc/ktouchpadenabler
        $(add_kdebase_dep kactivities)
-       $(add_kdebase_dep kdelibs 'nepomuk?')
        $(add_kdebase_dep kephal)
        $(add_kdebase_dep ksysguard)
        $(add_kdebase_dep libkworkspace)
@@ -40,10 +39,6 @@ COMMONDEPEND="
        gps? ( >=sci-geosciences/gpsd-2.37 )
        json? ( dev-libs/qjson )
        kdepim? ( $(add_kdebase_dep kdepimlibs) )
-       nepomuk? (
-               dev-libs/soprano
-               $(add_kdebase_dep nepomuk-core)
-       )
        python? (
                ${PYTHON_DEPS}
                >=dev-python/PyQt4-4.4.0[X,${PYTHON_USEDEP}]
@@ -99,15 +94,15 @@ src_unpack() {
 
 src_configure() {
        local mycmakeargs=(
+               -DWITH_NepomukCore=OFF
+               -DWITH_Soprano=OFF
+               -DWITH_Xmms=OFF
                $(cmake-utils_use_with gps libgps)
                $(cmake-utils_use_with json QJSON)
                $(cmake-utils_use_with kdepim Akonadi)
                $(cmake-utils_use_with kdepim KdepimLibs)
-               $(cmake-utils_use_with nepomuk NepomukCore)
-               $(cmake-utils_use_with nepomuk Soprano)
                $(cmake-utils_use_with python PythonLibrary)
                $(cmake-utils_use_with qalculate)
-               -DWITH_Xmms=OFF
        )
 
        kde4-meta_src_configure
index b9e949ff0c376f97820fe4a692e0a1abfc59bf87..3b9c8d6e9c3b8ee1bbfdc3265a81858032929fdc 100644 (file)
@@ -14,7 +14,7 @@ inherit python-single-r1 kde4-meta
 
 DESCRIPTION="Plasma: KDE desktop framework"
 KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug gps json +kdepim nepomuk python qalculate"
+IUSE="debug gps json +kdepim python qalculate"
 
 REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
 
@@ -23,7 +23,6 @@ COMMONDEPEND="
        >=dev-qt/qtcore-4.8.4-r3:4
        !kde-misc/ktouchpadenabler
        $(add_kdebase_dep kactivities)
-       $(add_kdebase_dep kdelibs 'nepomuk?')
        $(add_kdebase_dep kephal)
        $(add_kdebase_dep ksysguard)
        $(add_kdebase_dep libkworkspace)
@@ -40,10 +39,6 @@ COMMONDEPEND="
        gps? ( >=sci-geosciences/gpsd-2.37 )
        json? ( dev-libs/qjson )
        kdepim? ( $(add_kdebase_dep kdepimlibs) )
-       nepomuk? (
-               dev-libs/soprano
-               $(add_kdebase_dep nepomuk-core)
-       )
        python? (
                ${PYTHON_DEPS}
                >=dev-python/PyQt4-4.4.0[X,${PYTHON_USEDEP}]
@@ -99,15 +94,15 @@ src_unpack() {
 
 src_configure() {
        local mycmakeargs=(
+               -DWITH_NepomukCore=OFF
+               -DWITH_Soprano=OFF
+               -DWITH_Xmms=OFF
                $(cmake-utils_use_with gps libgps)
                $(cmake-utils_use_with json QJSON)
                $(cmake-utils_use_with kdepim Akonadi)
                $(cmake-utils_use_with kdepim KdepimLibs)
-               $(cmake-utils_use_with nepomuk NepomukCore)
-               $(cmake-utils_use_with nepomuk Soprano)
                $(cmake-utils_use_with python PythonLibrary)
                $(cmake-utils_use_with qalculate)
-               -DWITH_Xmms=OFF
        )
 
        kde4-meta_src_configure