dev-python/waitress: Set DISTUTILS_USE_SETUPTOOLS
authorMichał Górny <mgorny@gentoo.org>
Mon, 27 Jan 2020 06:39:46 +0000 (07:39 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 27 Jan 2020 07:22:09 +0000 (08:22 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/waitress/waitress-1.3.1.ebuild

index 6544ea25f7cb79710e399eefd6058992363e1fe7..205a98c4b1a02a0622b50cf174a2d9c93c730f7b 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=7
 
+DISTUTILS_USE_SETUPTOOLS=rdepend
 PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
 
 inherit distutils-r1
@@ -17,7 +18,4 @@ LICENSE="ZPL"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
 
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}"
-
 distutils_enable_tests nose