sphinxcontrib-github-alt: add python3_8
authorAndrey Grozin <grozin@gentoo.org>
Sun, 1 Mar 2020 04:30:56 +0000 (11:30 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Sun, 1 Mar 2020 04:30:56 +0000 (11:30 +0700)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.1-r2.ebuild [new file with mode: 0644]

diff --git a/dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.1-r2.ebuild b/dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.1-r2.ebuild
new file mode 100644 (file)
index 0000000..a6dd4f9
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_PN="sphinxcontrib_github_alt"
+
+DESCRIPTION="Link to GitHub issues, pull requests, commits and users from Sphinx docs"
+HOMEPAGE="https://github.com/jupyter/sphinxcontrib_github_alt"
+SRC_URI="https://github.com/jupyter/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+BDEPEND=${RDEPEND}
+
+S="${WORKDIR}/${MY_PN}-${PV}"