dev-python/python-xmlsec-1.3.7: Version bump
authorPatrick McLean <patrick.mclean@sony.com>
Thu, 21 May 2020 02:07:01 +0000 (19:07 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 21 May 2020 02:07:01 +0000 (19:07 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/python-xmlsec/Manifest
dev-python/python-xmlsec/python-xmlsec-1.3.7.ebuild [new file with mode: 0644]

index 5a850473bfe6c39830ef329676f554065f61a0fa..c6c1ef8f7e6e303150fdad9a07619f516e8506ce 100644 (file)
@@ -1 +1,2 @@
 DIST python-xmlsec-1.3.6.tar.gz 51174 BLAKE2B e6571d16268450c5e144aae8da5be42a6aa20f239859c0a5a85f5e20f361d5d85b85772cd5cdd296f2fb9da5f3dffbb869d537bd96fe68b7d4495bb378471d07 SHA512 ccfbe4c8266a5340f67331eac35174ae2cc175ce32ea8482c8b9757275466f058a5977ce62f39bce3c3abeda28988455c93302362c7f219d7b88b44ef245e972
+DIST python-xmlsec-1.3.7.tar.gz 71412 BLAKE2B 56bfe2a1ffff7fc2bbef96ccc8b3fe5434589a11371a87538f819f7ae8ddb8db5fbb1d0790b9e03d7039fbfd62c9f8d6e90ad2ef0bee66ac97ff1a239718e4db SHA512 87949b445ac962e68467c9466275cb72cb17cedd7736046997e1b2f70d80c6159f5740577b7762f9f4518a1bb9c0e1553061010118d6eb688c276335532fa6d5
diff --git a/dev-python/python-xmlsec/python-xmlsec-1.3.7.ebuild b/dev-python/python-xmlsec/python-xmlsec-1.3.7.ebuild
new file mode 100644 (file)
index 0000000..f846953
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the XML Security Library"
+HOMEPAGE="https://github.com/mehcode/python-xmlsec"
+SRC_URI="https://github.com/mehcode/python-xmlsec/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="
+       dev-libs/xmlsec:=
+"
+RDEPEND="${DEPEND}
+       dev-python/lxml[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+       dev-python/pkgconfig[${PYTHON_USEDEP}]
+       dev-python/wheel[${PYTHON_USEDEP}]
+"
+
+# tests fail, has been reported upstream
+# https://github.com/mehcode/python-xmlsec/issues/84
+RESTRICT=test
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+       sed -e "s:use_scm_version=.*:version='${PN}',:" \
+               -e "/setup_requires/ d" \
+               -i setup.py || die
+
+       distutils-r1_python_prepare_all
+}