dev-python/python-debian: Drop old
authorMichał Górny <mgorny@gentoo.org>
Wed, 18 Mar 2020 18:19:15 +0000 (19:19 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 18 Mar 2020 18:19:15 +0000 (19:19 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/python-debian/Manifest
dev-python/python-debian/python-debian-0.1.31.ebuild [deleted file]

index deee55f71ddec2d7e8fbed2309b543b255d6f7ac..753a3e4818524f57f80c10013d44d4b3acab8203 100644 (file)
@@ -1,2 +1 @@
-DIST python-debian_0.1.31.tar.xz 295720 BLAKE2B 3b3a68ab5604571355a15afac181e488c278ca78ab4c8a6cba4c392a0a89fd778bfd37e69a369d50fbc72f5080cf37fdbd31771f5d973c386795c436112ea347 SHA512 d2bf071b088e53ac132f91e5983c092bddb9736b3fd1394dfd2654fb8b6af7f89982af8debba8c4af21086d4f8a3ef86393fdef25ef18bcf71dcb00a60a8ae5b
 DIST python-debian_0.1.36.tar.xz 308364 BLAKE2B 1cc7e2844db8143a3a4cc4f59c4bbb90bb90ab024b2524335d8ab69947ffe8c64b2b41a54a5d199cd287a3d6b6a0173c75be708af9aedfeb871e354ac1873528 SHA512 3f2ca6d86f6b6d383a1628021a77d19b562b0c409d204dba4de6968d2cdd2c8fb4aa882429fa1ce6af5361352f7a51b339c481dd47937cb103a08132379d77c5
diff --git a/dev-python/python-debian/python-debian-0.1.31.ebuild b/dev-python/python-debian/python-debian-0.1.31.ebuild
deleted file mode 100644 (file)
index 3f63806..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python modules to work with Debian-related data formats"
-HOMEPAGE="https://packages.debian.org/sid/python-debian"
-SRC_URI="mirror://debian/pool/main/${P:0:1}/${PN}/${PN}_${PV}.tar.xz"
-
-LICENSE="GPL-2 GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-
-RDEPEND="
-       dev-python/chardet[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( app-arch/dpkg )"
-
-RESTRICT="test"
-
-python_prepare_all() {
-       sed -i -e '/import apt_pkg/d' \
-               -e 's/test_iter_paragraphs_comments_use_apt_pkg/_&/' \
-               lib/debian/tests/test_deb822.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       "${PYTHON}" lib/debian/doc-debtags > README.debtags || die
-}
-
-python_test() {
-       "${PYTHON}" -m unittest discover lib || die "Testing failed with ${EPYTHON}"
-}