sci-libs/umfpack: fix build with USE=doc
authorBernd Waibel <waebbl@gmail.com>
Fri, 3 Apr 2020 15:59:05 +0000 (17:59 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 10 Apr 2020 16:43:31 +0000 (18:43 +0200)
Add a src_compile() function needed to build pkfonts, if USE=doc
is enabled.

Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Bernd Waibel <waebbl@gmail.com>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sci-libs/umfpack/umfpack-5.7.9.ebuild

index d4c065afcadfbb185c2e4f7810f7fe68f0bbc5b0..3c62f3d82bb41f7a1644de7250238adbad37de0c 100644 (file)
@@ -29,3 +29,8 @@ src_configure() {
                $(use_enable static-libs static) \
                $(use_with cholmod)
 }
+
+src_compile() {
+       use doc && export VARTEXFONTS="${T}/fonts"
+       default
+}