dev-python/numpy: force MAKEOPTS=-j1
authorThomas Deutschmann <whissi@gentoo.org>
Thu, 20 Sep 2018 12:50:41 +0000 (14:50 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Thu, 20 Sep 2018 12:58:48 +0000 (14:58 +0200)
Looks like nobody cares. To allow users to build that package in
the meanwhile, let's force MAKEOPTS=-j1.

Bug: https://bugs.gentoo.org/660754
Package-Manager: Portage-2.3.49, Repoman-2.3.10

dev-python/numpy/numpy-1.10.4.ebuild
dev-python/numpy/numpy-1.13.3.ebuild
dev-python/numpy/numpy-1.14.5.ebuild
dev-python/numpy/numpy-9999.ebuild

index 73fc16097f880659fe3d19e874a47fb28a674de4..19b3f9751ad3445f3ee89bc8e79f259328f99693 100644 (file)
@@ -117,6 +117,8 @@ python_prepare_all() {
 }
 
 python_compile() {
+       export MAKEOPTS=-j1 # bug #660754
+
        distutils-r1_python_compile \
                $(usex python_targets_python3_5 "" "-j $(makeopts_jobs)") \
                ${NUMPY_FCONFIG}
index c618235d2a4301a5fe5dcec3be416d47b0c23d84..7242f6777759d16d576a1fb6f79f64fb39e1a6fb 100644 (file)
@@ -127,6 +127,8 @@ python_prepare_all() {
 }
 
 python_compile() {
+       export MAKEOPTS=-j1 # bug #660754
+
        local python_makeopts_jobs=""
        python_is_python3 || python_makeopts_jobs="-j $(makeopts_jobs)"
        distutils-r1_python_compile \
index cbedba5f96fa2de5b73a64b1df11341e71050bc6..1b047af16592d37912b245f8b02bb94f5ac10ec8 100644 (file)
@@ -114,6 +114,8 @@ python_prepare_all() {
 }
 
 python_compile() {
+       export MAKEOPTS=-j1 # bug #660754
+
        local python_makeopts_jobs=""
        python_is_python3 || python_makeopts_jobs="-j $(makeopts_jobs)"
        distutils-r1_python_compile \
index aa2a3abfa0ef73a18a14fb648b77cfde7909a06a..dd08eecdb0207beef5e2835aa5fbd4dc49d5e265 100644 (file)
@@ -104,6 +104,8 @@ python_prepare_all() {
 }
 
 python_compile() {
+       export MAKEOPTS=-j1 # bug #660754
+
        distutils-r1_python_compile -j $(makeopts_jobs) ${NUMPY_FCONFIG}
 }