dev-libs/libinput: Inform users about dev-python/python-libevdev
authorMatt Turner <mattst88@gentoo.org>
Mon, 9 Mar 2020 02:03:34 +0000 (19:03 -0700)
committerMatt Turner <mattst88@gentoo.org>
Mon, 9 Mar 2020 02:05:41 +0000 (19:05 -0700)
I don't think a runtime dependency is warranted for these two tools, so
let's just inform users about the dependency.

Closes: https://bugs.gentoo.org/703800
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-libs/libinput/libinput-1.15.3.ebuild

index 43de3f8241a4ddf02b97708302993591397adfdd..7ae9b0b065594ed5b348def4bdee643968c6af20 100644 (file)
@@ -73,5 +73,11 @@ src_install() {
 }
 
 pkg_postinst() {
+       pkgname="dev-python/python-libevdev"
+       if [[ -z "${REPLACING_VERSIONS}" ]] && ! has_version "${pkgname}"; then
+               einfo "${pkgname} must be installed to use the"
+               einfo "libinput measure and libinput replay tools."
+       fi
+
        udevadm hwdb --update --root="${ROOT}"
 }