dev-java/tomcat-native-1.2.19: removed obsolete
authorMiroslav Šulc <fordfrog@gentoo.org>
Thu, 4 Jul 2019 12:51:27 +0000 (14:51 +0200)
committerMiroslav Šulc <fordfrog@gentoo.org>
Thu, 4 Jul 2019 12:51:27 +0000 (14:51 +0200)
Package-Manager: Portage-2.3.68, Repoman-2.3.16
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
dev-java/tomcat-native/Manifest
dev-java/tomcat-native/tomcat-native-1.2.19.ebuild [deleted file]

index ed38305843e4867e0570b00b12ffd0fc08569fdd..777ee90f5a5dcc005a9b46832210077e53180002 100644 (file)
@@ -1,2 +1 @@
-DIST tomcat-native-1.2.19-src.tar.gz 418183 BLAKE2B cab8621bca4dc41e87ebf6418337da8a86d56a0717aacd62c6e4fb2d039e413cb29e8f169abbd353719ce083d302613d3e0f64cd54f1bc8e57f26a523a828025 SHA512 7d69acd5dd684eee9a85c08357b7288a9f083c15a12a9524ba6344f1b9dcdc6ccc512a37b64b9f15b0e697609833e6c68591a60976dcfecce124ec29eb532dba
 DIST tomcat-native-1.2.21-src.tar.gz 418909 BLAKE2B f7559f204941cd8f8383bda7591e167c247062b4f79c507a5a449715a5554194197c4d34197f30622cbcbd81952597ae757623c903f11959dc8b4fa81234e127 SHA512 7f43f815785e5bc3e43f5b2e9ad1c90576a3c1528d57230328b7175bf475eb5f4e1f91b66fae74ad32cd76f044d7705f98a79109f6f84e5af75dc32bc8830b29
diff --git a/dev-java/tomcat-native/tomcat-native-1.2.19.ebuild b/dev-java/tomcat-native/tomcat-native-1.2.19.ebuild
deleted file mode 100644 (file)
index fb46a0b..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Allows Tomcat to use certain native resources for better performance"
-HOMEPAGE="https://tomcat.apache.org/"
-SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${PV}/source/${P}-src.tar.gz"
-
-KEYWORDS="amd64 ~x86"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="static-libs test"
-
-RDEPEND="dev-libs/apr:1=
-       dev-libs/openssl:0=
-       >=virtual/jre-1.8"
-
-DEPEND=">=virtual/jdk-1.8
-       test? ( dev-java/ant-junit:0 )"
-
-S=${WORKDIR}/${P}-src
-
-JAVA_ANT_REWRITE_CLASSPATH="yes"
-
-src_configure() {
-       local myeconfargs=(
-               --with-apr="${EPREFIX}"/usr/bin/apr-1-config
-               --with-ssl="${EPREFIX}"/usr
-       )
-
-       cd native || die
-       econf "${myeconfargs[@]}"
-}
-
-src_compile() {
-       eant jar
-
-       cd native || die
-       default
-}
-
-src_install() {
-       java-pkg_newjar "dist/${P}.jar" "${PN}.jar"
-
-       cd native || die
-       default
-
-       ! use static-libs && find "${D}" -name '*.la' -delete || die
-}
-
-src_test() {
-       java-pkg-2_src_test
-}
-
-pkg_postinst() {
-       elog "For more information, please visit"
-       elog "https://tomcat.apache.org/tomcat-9.0-doc/apr.html"
-}