dev-ros/pr2_description: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 10:45:40 +0000 (12:45 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 10:45:40 +0000 (12:45 +0200)
Package-Manager: portage-2.2.21

dev-ros/pr2_description/Manifest [new file with mode: 0644]
dev-ros/pr2_description/files/pr2_description.patch [new file with mode: 0644]
dev-ros/pr2_description/metadata.xml [new file with mode: 0644]
dev-ros/pr2_description/pr2_description-1.11.9.ebuild [new file with mode: 0644]
dev-ros/pr2_description/pr2_description-9999.ebuild [new file with mode: 0644]

diff --git a/dev-ros/pr2_description/Manifest b/dev-ros/pr2_description/Manifest
new file mode 100644 (file)
index 0000000..81a1f40
--- /dev/null
@@ -0,0 +1 @@
+DIST pr2_common-1.11.9.tar.gz 33337556 SHA256 c6134939602c8a81d006bf4a4bfc48bf8746f5eb0c5b12baa1da8c946d1b4ce1 SHA512 44eb4f802a7b6983b621ca5b2c1c0e2516f16992f35902c2fb4afbdc9ffc8e63c1ed647f4ef09fd4cbeef747aba133a55172cec64c3cf9d759d2c83f7ec8a213 WHIRLPOOL ad5d6c543b1faca2ed48a66405eb8d6c17b9ef6352fa16b6fc55f9b093a6b1b7da3e0571ade5a6013c84d3695c16e910549ea2673c36a4179043ea4f085c1e05
diff --git a/dev-ros/pr2_description/files/pr2_description.patch b/dev-ros/pr2_description/files/pr2_description.patch
new file mode 100644 (file)
index 0000000..5296a67
--- /dev/null
@@ -0,0 +1,17 @@
+diff --git a/pr2_description/CMakeLists.txt b/pr2_description/CMakeLists.txt
+index 1b75223..6c83182 100644
+--- a/pr2_description/CMakeLists.txt
++++ b/pr2_description/CMakeLists.txt
+@@ -91,8 +91,10 @@ add_custom_target(media_files ALL DEPENDS ${pr2urdf} ${pr2robot_expanded} ${prfr
+ ## DEPENDS: system dependencies of this project that dependent projects also need
+ catkin_package(CATKIN_DEPENDS xacro)
+-catkin_add_gtest(test_urdf test/test_urdf.cpp WORKING_DIRECTORY ${PROJECT_SOURCE_DIR})
+-target_link_libraries(test_urdf urdfdom_model)
++if(CATKIN_ENABLE_TESTING)
++      catkin_add_gtest(test_urdf test/test_urdf.cpp WORKING_DIRECTORY ${PROJECT_SOURCE_DIR})
++      target_link_libraries(test_urdf urdfdom_model)
++endif()
+ foreach(dir meshes gazebo materials robots documents urdf)
+    install(DIRECTORY ${dir}/ 
diff --git a/dev-ros/pr2_description/metadata.xml b/dev-ros/pr2_description/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/pr2_description/pr2_description-1.11.9.ebuild b/dev-ros/pr2_description/pr2_description-1.11.9.ebuild
new file mode 100644 (file)
index 0000000..3c99ffb
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/pr2/pr2_common"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Description (mechanical, kinematic, visual,  etc.) of the PR2 robot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/xacro"
+DEPEND="${RDEPEND}
+       dev-ros/convex_decomposition
+       dev-ros/ivcon
+       test? ( dev-libs/urdfdom dev-cpp/gtest )"
+
+PATCHES=( "${FILESDIR}/pr2_description.patch" )
diff --git a/dev-ros/pr2_description/pr2_description-9999.ebuild b/dev-ros/pr2_description/pr2_description-9999.ebuild
new file mode 100644 (file)
index 0000000..3c99ffb
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/pr2/pr2_common"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Description (mechanical, kinematic, visual,  etc.) of the PR2 robot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/xacro"
+DEPEND="${RDEPEND}
+       dev-ros/convex_decomposition
+       dev-ros/ivcon
+       test? ( dev-libs/urdfdom dev-cpp/gtest )"
+
+PATCHES=( "${FILESDIR}/pr2_description.patch" )