dev-python/tabulate: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 09:54:44 +0000 (11:54 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 10:12:51 +0000 (12:12 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/tabulate/Manifest
dev-python/tabulate/tabulate-0.8.1.ebuild [deleted file]
dev-python/tabulate/tabulate-0.8.3.ebuild [deleted file]

index f7f0bd116c8d71e9d92a7cd868c7323094a9c3b6..aff256b1942122ce4ed073f604ace744f32c8331 100644 (file)
@@ -1,3 +1 @@
-DIST tabulate-0.8.1.tar.gz 45666 BLAKE2B f46a0c8bed50e37a2d536d28fe822fb92fbc124c7ac4c29260b6a7ab9828588f49b7e94ec8925505ef9724b1fb4647e5e9207d29b2f3a2f526641ac7ac229ce0 SHA512 f724fbabee53c738c846a5cf645470f5f97074e2b33eb030b4859478931661dac53e5446d77a656553e2dec323230bb116d350997e1407d794382f537e6dfdf5
-DIST tabulate-0.8.3.tar.gz 46234 BLAKE2B 1310de381265bf150cdef72b653175b1ab95a8339bf1934cece830ce9e644ed9d3d441eb3c3721509368334d11160054aa4d75a17751e493c47dbeee22c466e2 SHA512 7f0205a4d80ed0b426a45622a3b8ec0a9b77cf6d67c1207db7fbc20a12e83a15748e63d5f8e5e65fa348b6265fd0cac93be4d04f9c1c182476b93507e1131cbf
 DIST tabulate-0.8.6.tar.gz 39420 BLAKE2B 28cd8c175b258b56a406a78d7891919a49c867d848843365605ccdcb8ba0b307f1448967a124d57b0f6264169104c9cccc84982fea666a035a265a3c9f10cc43 SHA512 ec4d7a7f20db306be1a460276e0b1b1e63fd1ca14b208a45a297508bddbc07b034e03fcb5ff67fe5e2b9419f308900675994a6dccef755c975ad0b1e9124072f
diff --git a/dev-python/tabulate/tabulate-0.8.1.ebuild b/dev-python/tabulate/tabulate-0.8.1.ebuild
deleted file mode 100644 (file)
index fd80469..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Pretty-print tabular data"
-HOMEPAGE="https://pypi.org/project/tabulate/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-# Missing something in tarball
-#
-# from common import assert_equal
-RESTRICT=test
-
-python_test() {
-       local testcase
-       for testcase in test/*py; do
-               ${PYTHON} ${testcase} || die
-       done
-}
diff --git a/dev-python/tabulate/tabulate-0.8.3.ebuild b/dev-python/tabulate/tabulate-0.8.3.ebuild
deleted file mode 100644 (file)
index 1904db9..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Pretty-print tabular data"
-HOMEPAGE="https://pypi.org/project/tabulate/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/wcwidth[${PYTHON_USEDEP}]"
-# TODO: optional test-dep on colorclass
-DEPEND="
-       test? (
-               ${RDEPEND}
-               $(python_gen_impl_dep 'sqlite')
-               dev-python/colorclass[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/numpy[${PYTHON_USEDEP}]
-               dev-python/pandas[${PYTHON_USEDEP}]
-       )
-"
-
-python_test() {
-       esetup.py test
-}