Fix building with mysql
authorEray Aslan <eras@gentoo.org>
Tue, 25 Aug 2015 06:54:51 +0000 (06:54 +0000)
committerEray Aslan <eras@gentoo.org>
Tue, 25 Aug 2015 07:00:56 +0000 (07:00 +0000)
Bug: 557582

net-mail/mailutils/mailutils-2.99.98.ebuild

index 329dbdfb3ba47c24886e8256652166cea737a017..29d3c7ab5308b89e59990079e797be67d5cd52b9 100644 (file)
@@ -5,7 +5,7 @@
 EAPI=5
 PYTHON_DEPEND="python? 2"
 
-inherit eutils flag-o-matic python toolchain-funcs
+inherit autotools eutils flag-o-matic python toolchain-funcs
 
 DESCRIPTION="A useful collection of mail servers, clients, and filters"
 HOMEPAGE="https://www.gnu.org/software/mailutils/mailutils.html"
@@ -57,6 +57,11 @@ src_prepare() {
        echo "#!/bin/sh" > build-aux/py-compile
        epatch "${FILESDIR}/${P}-array_bounds.patch"
        epatch "${FILESDIR}/${P}-readline-6.3.patch" #503954
+       if use mysql; then
+               sed -i -e /^INCLUDES/s:$:$(mysql_config --include): \
+                       sql/Makefile.am || die
+               eautoreconf
+       fi
 }
 
 src_configure() {