net-libs/libsoup: version bump 2.56.1 → 2.58.2
authorGilles Dartiguelongue <eva@gentoo.org>
Tue, 15 Aug 2017 21:09:25 +0000 (23:09 +0200)
committerGilles Dartiguelongue <eva@gentoo.org>
Tue, 15 Aug 2017 22:43:17 +0000 (00:43 +0200)
Package-Manager: Portage-2.3.7, Repoman-2.3.3

net-libs/libsoup/Manifest
net-libs/libsoup/libsoup-2.58.2.ebuild [new file with mode: 0644]

index 01a5b26915104271737f81fd84ac0c49c769ad4b..bb6632626c81f6f98de26e2dedcbca5cde7d8843 100644 (file)
@@ -1,2 +1,3 @@
 DIST libsoup-2.56.0.tar.xz 1821412 SHA256 d8216b71de8247bc6f274ec054c08547b2e04369c1f8add713e9350c8ef81fe5 SHA512 09207ea41a4f251318f99f748275ea8c1c203d3b55d7a0adaf64721198b5858f6d5bbc46215cdc723b22250c36615f0d1f9cea4e1e3ab9b489e5548a934f3b31 WHIRLPOOL d57f8784471d97d3aad82e02253510ba59d1165f68d0642d5d0a098880f8c7dc949d0d1ccb6407a74752c05b2011fa3ac6bdb73cde8e52e74d22963b30e74376
 DIST libsoup-2.56.1.tar.xz 1806416 SHA256 c32a46d77b4da433b51d8fd09a57a44b198e03bdc93e5219afcc687c7948eac3 SHA512 5ac087eeba346c27e884a2053a4f8afdb2fc6e432527f4494024a7edc4eccdf145188a3faa64e3f4bdd98af2fcb98914e494b4ed24f92cffc2ff1485dce7d693 WHIRLPOOL a821342a2e592b12e901761ceb68281f68022c269977b322ea21ed7cda8f524db48ae93400eb8b59b7dd26cdbb5ec1913f9b63701d4303a6f62123cd6d2f0094
+DIST libsoup-2.58.2.tar.xz 1815256 SHA256 442300ca1b1bf8a3bbf2f788203287ff862542d4fc048f19a92a068a27d17b72 SHA512 85af6fac87343bdd22312518402144d33916225f60d6fa158efdd84f7ee7ed1f9895989b3558f711c9aedc93cff35a4114ad79d6d2aa19c54cb326f162a4c7de WHIRLPOOL 3b7b880c3f1374d00aef01ccc568c488efd672443da42bf6838d2a46b7cc1d4fe64f39b43205a3932767f28ef36f1552050afb45aa72d331150663d3c458ade6
diff --git a/net-libs/libsoup/libsoup-2.58.2.ebuild b/net-libs/libsoup/libsoup-2.58.2.ebuild
new file mode 100644 (file)
index 0000000..05364a4
--- /dev/null
@@ -0,0 +1,92 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 multilib-minimal python-any-r1 vala
+
+DESCRIPTION="An HTTP library implementation in C"
+HOMEPAGE="https://wiki.gnome.org/Projects/libsoup"
+
+LICENSE="LGPL-2+"
+SLOT="2.4"
+
+IUSE="debug gssapi +introspection samba ssl test vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+RDEPEND="
+       >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+       >=dev-libs/libxml2-2.9.1-r4:2[${MULTILIB_USEDEP}]
+       >=dev-db/sqlite-3.8.2:3[${MULTILIB_USEDEP}]
+       >=net-libs/glib-networking-2.38.2[ssl?,${MULTILIB_USEDEP}]
+       gssapi? ( virtual/krb5[${MULTILIB_USEDEP}] )
+       introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+       samba? ( net-fs/samba )
+"
+DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
+       >=dev-util/intltool-0.35
+       >=dev-util/gtk-doc-am-1.20
+       sys-devel/gettext
+       >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+       test? ( >=dev-libs/glib-2.40:2[${MULTILIB_USEDEP}] )
+       vala? ( $(vala_depend) )
+"
+#      test? ( www-servers/apache[ssl,apache2_modules_auth_digest,apache2_modules_alias,apache2_modules_auth_basic,
+#              apache2_modules_authn_file,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_dir,
+#              apache2_modules_mime,apache2_modules_proxy,apache2_modules_proxy_http,apache2_modules_proxy_connect]
+#              dev-lang/php[apache2,xmlrpc]
+#              net-misc/curl
+#              net-libs/glib-networking[ssl])"
+
+src_prepare() {
+       if ! use test; then
+               # don't waste time building tests (bug #226271)
+               sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+                       || die "sed failed"
+       fi
+
+       # FIXME: workaround upstream not respecting --without-apache-httpd
+       sed -e '/check: start-httpd/d' \
+               -i tests/Makefile.am tests/Makefile.in || die
+
+       use vala && vala_src_prepare
+       gnome2_src_prepare
+}
+
+src_configure() {
+       # FIXME: we need addpredict to workaround bug #324779 until
+       # root cause (bug #249496) is solved
+       addpredict /usr/share/snmp/mibs/.index
+
+       multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+       # Disable apache tests until they are usable on Gentoo, bug #326957
+       ECONF_SOURCE=${S} \
+       gnome2_src_configure \
+               --disable-static \
+               --disable-tls-check \
+               --without-gnome \
+               --without-apache-httpd \
+               $(usex debug --enable-debug=yes ' ') \
+               $(multilib_native_use_with gssapi) \
+               $(multilib_native_use_enable introspection) \
+               $(multilib_native_use_enable vala) \
+               $(use_with samba ntlm-auth '${EPREFIX}'/usr/bin/ntlm_auth)
+
+       if multilib_is_native_abi; then
+               # fix gtk-doc
+               ln -s "${S}"/docs/reference/html docs/reference/html || die
+       fi
+}
+
+multilib_src_install() {
+       gnome2_src_install
+}