sys-apps/help2man: Bump to version 1.47.9
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 18 Mar 2019 20:01:04 +0000 (21:01 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 18 Mar 2019 20:01:04 +0000 (21:01 +0100)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-apps/help2man/Manifest
sys-apps/help2man/help2man-1.47.9.ebuild [new file with mode: 0644]

index 678efaf46d72125b825f8aeaec921cd938df8194..a3a77f6fefbf6d0bfa9ff7ea34683a6379e64fc2 100644 (file)
@@ -1,3 +1,4 @@
 DIST help2man-1.47.6.tar.xz 192980 BLAKE2B ddf2b899e4479a45505aefaf3dabfceb1595128da35c000b81be79046aabceff58e1d605b2797880c5c652947d0fe59673eaf087de911152e79768c571037a73 SHA512 d24849b93de58b20f518c071687e7bfa653a96600382f36c4cf7fc1047656458f75f093b911b786b18b6931b2453cb60868ecbe07cc7d2984e5981a874b34942
 DIST help2man-1.47.7.tar.xz 200128 BLAKE2B bdac9d1db29b03bbb8e41caecfdf3a7273b69d9b9fa2e206b2e6c28d1144c3104b8d4b7d4a43aab1b405bffd6e097db63a2f4e97a76dfcd980ee5d8a9ffc2114 SHA512 e6ec25d973df68edde87d3314b1bef2e679d57d4c9e024bca17362b9da058c80314050e1ae61d73179b8c2662c8692caa1f223fc48b8d02f2d4f040d16e51d14
 DIST help2man-1.47.8.tar.xz 200264 BLAKE2B 2650909986649a471cfa13db96fda34e864312aab96ffa2692c2d38cbb9b36149d90a398b3ea9568992b9da01ab7aeeab8022ee74edebf2e7c83cac48c951e7c SHA512 05e420560b143042418db2e992beaef45cc5a568cdbf640c7b285ba2dc322290d14e0df978ff4c412a99f4346e38f6fb9796ebda695ddc002a3d0e74e85725d6
+DIST help2man-1.47.9.tar.xz 202012 BLAKE2B 08d0a906e61978b12fd00b9d807b8cdb6b2436165223aff539957f217786442bc31fb5d437833d6dae3bd6a4b83e1df28d7bd434d0c753f38fea96b8cf751b76 SHA512 91cddd5ebc8eb2a89bc27fab4298ee18c18fa73363378be8c220258bf415634a0147b8502970c5fea48ddaccddda63753cbd215bf6894798452c2b4b89c4309a
diff --git a/sys-apps/help2man/help2man-1.47.9.ebuild b/sys-apps/help2man/help2man-1.47.9.ebuild
new file mode 100644 (file)
index 0000000..c638677
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="GNU utility to convert program --help output to a man page"
+HOMEPAGE="https://www.gnu.org/software/help2man/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="dev-lang/perl
+       nls? ( dev-perl/Locale-gettext )"
+DEPEND=${RDEPEND}
+
+DOCS=( debian/changelog NEWS README THANKS ) #385753
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.46.1-linguas.patch
+)
+
+src_prepare() {
+       if [[ ${CHOST} == *-darwin* ]] ; then
+               sed -i \
+                       -e 's/-shared/-bundle/' \
+                       Makefile.in || die
+       fi
+       default
+}
+
+src_configure() {
+       # Disable gettext requirement as the release includes the gmo files #555018
+       econf \
+               ac_cv_path_MSGFMT=$(type -P false) \
+               $(use_enable nls)
+}