dev-python/mysql-connector-python: Revbump for python 3.6
authorBrian Evans <grknight@gentoo.org>
Fri, 1 Jun 2018 20:00:43 +0000 (16:00 -0400)
committerBrian Evans <grknight@gentoo.org>
Fri, 1 Jun 2018 20:00:43 +0000 (16:00 -0400)
Compile tests OK

Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-python/mysql-connector-python/mysql-connector-python-2.1.7-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/mysql-connector-python/mysql-connector-python-2.1.7-r1.ebuild b/dev-python/mysql-connector-python/mysql-connector-python-2.1.7-r1.ebuild
new file mode 100644 (file)
index 0000000..00b4a6a
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Python client library for MariaDB/MySQL"
+HOMEPAGE="https://dev.mysql.com/downloads/connector/python/"
+SRC_URI="https://dev.mysql.com/get/Downloads/Connector-Python/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples test"
+
+# tests/mysqld.py does not like MariaDB version strings.
+# See the regex MySQLServerBase._get_version.
+DEPEND="test? ( dev-db/mysql[server(+)] )"
+
+# Tests currently fail.
+# mysql.connector.errors.DatabaseError: 1300 (HY000): Invalid utf8 character string: ''
+RESTRICT="test"
+
+DOCS=( README.txt CHANGES.txt docs/README_DOCS.txt )
+
+python_test() {
+       "${EPYTHON}" unittests.py --with-mysql="${EPREFIX%/}/usr" --unix-socket="${T}" --mysql-topdir="${T}"
+}
+
+python_install_all(){
+       distutils-r1_python_install_all
+       if use examples ; then
+               dodoc -r examples
+       fi
+}