Remove hppa and mips from KEYWORDS, fix ebuild to add PSAD.pm, fixing bug 36750
authorBryan Stine <battousai@gentoo.org>
Wed, 14 Jan 2004 02:18:45 +0000 (02:18 +0000)
committerBryan Stine <battousai@gentoo.org>
Wed, 14 Jan 2004 02:18:45 +0000 (02:18 +0000)
app-admin/bastille/ChangeLog
app-admin/bastille/Manifest
app-admin/bastille/bastille-2.1.1-r1.ebuild
app-admin/bastille/bastille-2.1.1-r2.ebuild [new file with mode: 0644]
app-admin/bastille/files/digest-bastille-2.1.1-r2 [new file with mode: 0644]

index 96c30dc841b6f4d9f1bc148c521373d283f55c40..b8e72193a40656c59df9a6f4d69930de8ae1dc19 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for app-admin/bastille
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/ChangeLog,v 1.4 2003/12/02 22:05:01 plasmaroo Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/ChangeLog,v 1.5 2004/01/14 02:18:45 battousai Exp $
+
+*bastille-2.1.1-r2 (13 Jan 2004)
+
+  13 Jan 2004; Bryan Stine <battousai@gentoo.org> bastille-2.1.1-r1.ebuild,
+  bastille-2.1.1-r2.ebuild: Install the PSAD.pm perl interface module as well.
+  This fixes bug 36750. Also, removed hppa and mips architectures becuase some
+  runtime dependencies are not available.
 
   22 Oct 2003; Seemant Kulleen <seemant@gentoo.org> bastille-2.1.1-r1.ebuild,
   files/bastille-2.1.1-firewall.init: The 'bastille-firewall' init script has
index 0b94166e90fa2a7fce9e19abeeb009e10f39d6ce..cad762d56e4dd6530bdf9a1c195b34e8180647a3 100644 (file)
@@ -1,5 +1,7 @@
-MD5 9cda69d60df8ef6987c3494ba2c673ca ChangeLog 1504
-MD5 da8cf08d3aefc8ab6d9ed73c02a0b14d bastille-2.1.1-r1.ebuild 2469
+MD5 8091a5c2c067eab6f62ed6f88ef0276a ChangeLog 1815
+MD5 c3f34342c4f67e69781a35a45e6df074 bastille-2.1.1-r1.ebuild 2458
 MD5 624441f5e21afa19251eedc583e0c4e7 metadata.xml 433
-MD5 5952693da32f1292a5b6013e8e755799 files/digest-bastille-2.1.1-r1 146
+MD5 98f1e09262e8eeb95d0ad5935594e156 bastille-2.1.1-r2.ebuild 2578
 MD5 d67fde88483e98fc3147028dda5c01ef files/bastille-2.1.1-firewall.init 1348
+MD5 5952693da32f1292a5b6013e8e755799 files/digest-bastille-2.1.1-r1 146
+MD5 5952693da32f1292a5b6013e8e755799 files/digest-bastille-2.1.1-r2 146
index a3b1c3ce79fe2e84d25285245a2c21f87052842b..adfd8d2ff7fc1526385dd09cd665bb5393b1e206 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/bastille-2.1.1-r1.ebuild,v 1.2 2003/10/22 20:38:08 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/bastille-2.1.1-r1.ebuild,v 1.3 2004/01/14 02:18:45 battousai Exp $
 
 inherit perl-module
 
@@ -17,8 +17,7 @@ SRC_URI="mirror://sourceforge/${PN}-linux/${MY_P}.tar.bz2
 
 SLOT="0"
 LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa"
-
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
 
 RDEPEND="net-firewall/iptables
        app-admin/logrotate
diff --git a/app-admin/bastille/bastille-2.1.1-r2.ebuild b/app-admin/bastille/bastille-2.1.1-r2.ebuild
new file mode 100644 (file)
index 0000000..88c0623
--- /dev/null
@@ -0,0 +1,99 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bastille/bastille-2.1.1-r2.ebuild,v 1.1 2004/01/14 02:18:45 battousai Exp $
+
+inherit perl-module
+
+IUSE="X"
+
+PATCHVER=0.1
+MY_PN=${PN/b/B}
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_PN}
+DESCRIPTION="Bastille-Linux is a security hardening tool"
+HOMEPAGE="http://bastille-linux.org/"
+SRC_URI="mirror://sourceforge/${PN}-linux/${MY_P}.tar.bz2
+       mirror://gentoo/${P}-gentoo-${PATCHVER}.patch.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+RDEPEND="net-firewall/iptables
+       app-admin/logrotate
+       dev-perl/Curses
+       net-firewall/psad
+       X? ( dev-perl/perl-tk )"
+
+src_unpack() {
+       unpack ${A}
+       epatch ${WORKDIR}/${P}-gentoo-${PATCHVER}.patch
+}
+
+src_compile() {
+       cd ${S}
+       cp ${FILESDIR}/bastille-${PV}-firewall.init ./bastille-firewall
+
+       cd ${S}/psad/Psad.pm
+       perl-module_src_compile
+}
+
+src_install() {
+
+       keepdir /var/lock/subsys/${PN}
+       dodir /etc/Bastille
+
+       cd ${S}
+       into /usr
+       dosbin bastille AutomatedBastille InteractiveBastille \
+               BastilleBackEnd RevertBastille *.pl
+
+       dosym RevertBastille /usr/sbin/UndoBastille
+
+       insinto /usr/share/Bastille
+       doins Questions* Credits bastille-* *.xbm *.config
+
+       insinto /usr/share/Bastille
+       doins Questions.txt Credits complete.xbm incomplete.xbm \
+               ifup-local hosts.allow
+
+       exeinto /usr/share/Bastille
+       doexe bastille-firewall* bastille-tmpdir* \
+               bastille-ipchains bastille-netfilter \
+               firewall/*.sh
+
+       perlinfo
+       insinto ${SITE_LIB}
+       doins Bastille_Curses.pm
+       use X && doins Bastille_Tk.pm
+       insinto ${SITE_LIB}/Curses
+       doins Curses/Widgets.pm
+
+       doman docs/bastille.1m
+       dodoc docs/* firewall/*.txt
+
+       cd ${S}/Bastille
+
+       insinto /usr/lib/Bastille
+       doins AccountSecurity.pm Apache.pm API.pm OSX_API.pm BootSecurity.pm \
+               ConfigureMiscPAM.pm DisableUserTools.pm DNS.pm \
+               FilePermissions.pm FTP.pm Firewall.pm HP_API.pm HP_UX.pm \
+               IOLoader.pm Patches.pm Logging.pm \
+               MiscellaneousDaemons.pm PatchDownload.pm Printing.pm \
+               RemoteAccess.pm SecureInetd.pm Sendmail.pm TMPDIR.pm  \
+               test_AccountSecurity.pm test_Apache.pm test_DNS.pm \
+               test_FTP.pm test_HP_UX.pm test_MiscellaneousDaemons.pm \
+               test_SecureInetd.pm test_Sendmail.pm TestAPI.pm IPFilter.pm
+
+       # psad interface module
+       cd ${S}/psad/Psad.pm
+       newins Psad.pm PSAD.pm
+
+       # Documentation
+       cd ${S}
+       dodoc *.txt COPYING BUGS Change* README*
+}
+
+pkg_postinst() {
+       use X || einfo "When not using the Tk interface you will need to start use the -c flag when calling ${PN} from command line. example ${PN} -c --os GE1.4"
+}
diff --git a/app-admin/bastille/files/digest-bastille-2.1.1-r2 b/app-admin/bastille/files/digest-bastille-2.1.1-r2
new file mode 100644 (file)
index 0000000..bd17a91
--- /dev/null
@@ -0,0 +1,2 @@
+MD5 67b4d6a110fbe833bfc14dc46e75fa83 Bastille-2.1.1.tar.bz2 338227
+MD5 4742d81524cfe07f00c4bab66b17371f bastille-2.1.1-gentoo-0.1.patch.bz2 15312