old
authorMike Frysinger <vapier@gentoo.org>
Tue, 14 Nov 2006 03:33:17 +0000 (03:33 +0000)
committerMike Frysinger <vapier@gentoo.org>
Tue, 14 Nov 2006 03:33:17 +0000 (03:33 +0000)
sys-devel/gcc/files/digest-gcc-4.1.0_alpha20061027 [deleted file]
sys-devel/gcc/files/digest-gcc-4.2.0_alpha20061031 [deleted file]
sys-devel/gcc/gcc-4.1.0_alpha20061027.ebuild [deleted file]
sys-devel/gcc/gcc-4.2.0_alpha20061031.ebuild [deleted file]

diff --git a/sys-devel/gcc/files/digest-gcc-4.1.0_alpha20061027 b/sys-devel/gcc/files/digest-gcc-4.1.0_alpha20061027
deleted file mode 100644 (file)
index 1b64627..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 f77606b3751c8393e5d4d6473cb709c7 gcc-4.1-20061027.tar.bz2 37161688
-RMD160 0a3ee0dd264a9bb0a4a441859e7911fad41177c0 gcc-4.1-20061027.tar.bz2 37161688
-SHA256 ec36cbf428f42aa67c851a3bfedf0815082f6df991def9dc56115423ef23ac16 gcc-4.1-20061027.tar.bz2 37161688
diff --git a/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20061031 b/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20061031
deleted file mode 100644 (file)
index 63b6a46..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 e1c9738efde17462a7b38820760b1492 gcc-4.2-20061031.tar.bz2 40662795
-RMD160 4480ab75205b7db65f0ad60a8f9efaaa117f0bfc gcc-4.2-20061031.tar.bz2 40662795
-SHA256 c9f0a6538043c24e624dc6b17dcb253aa36bea251b66dd2782e739f4c394d8dd gcc-4.2-20061031.tar.bz2 40662795
diff --git a/sys-devel/gcc/gcc-4.1.0_alpha20061027.ebuild b/sys-devel/gcc/gcc-4.1.0_alpha20061027.ebuild
deleted file mode 100644 (file)
index 1ea483d..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.0_alpha20061027.ebuild,v 1.1 2006/11/02 06:41:50 vapier Exp $
-
-ETYPE="gcc-compiler"
-
-inherit toolchain
-
-DESCRIPTION="The GNU Compiler Collection.  Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="-*"
-
-RDEPEND=">=sys-libs/zlib-1.1.4
-       || ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
-       virtual/libiconv
-       fortran? (
-               >=dev-libs/gmp-4.2.1
-               >=dev-libs/mpfr-2.2.0_p10
-       )
-       !build? (
-               gcj? (
-                       gtk? (
-                               || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
-                               >=x11-libs/gtk+-2.2
-                               x11-libs/pango
-                       )
-                       >=media-libs/libart_lgpl-2.1
-               )
-               >=sys-libs/ncurses-5.2-r2
-               nls? ( sys-devel/gettext )
-       )"
-DEPEND="${RDEPEND}
-       >=sys-apps/texinfo-4.2-r4
-       >=sys-devel/bison-1.875
-       >=${CATEGORY}/binutils-2.16.1"
-PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
-if [[ ${CATEGORY} != cross-* ]] ; then
-       PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
-fi
-
-pkg_setup() {
-       if [[ -z ${I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS} ]] ; then
-               die "Please \`export I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS=1\` or define it in your make.conf if you want to use this ebuild.  This is to try and cut down on people filing bugs for a compiler we do not currently support."
-       fi
-}
-
-src_unpack() {
-       gcc_src_unpack
-
-       use vanilla && return 0
-
-       # Fix cross-compiling
-       epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
-}
-
-pkg_postinst() {
-       toolchain_pkg_postinst
-
-       einfo "This gcc-4 ebuild is provided for your convenience, and the use"
-       einfo "of this compiler is not supported by the Gentoo Developers."
-       einfo "Please file bugs related to gcc-4 with upstream developers."
-       einfo "Compiler bugs should be filed at http://gcc.gnu.org/bugzilla/"
-}
diff --git a/sys-devel/gcc/gcc-4.2.0_alpha20061031.ebuild b/sys-devel/gcc/gcc-4.2.0_alpha20061031.ebuild
deleted file mode 100644 (file)
index fb67e11..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.0_alpha20061031.ebuild,v 1.1 2006/11/02 06:41:50 vapier Exp $
-
-ETYPE="gcc-compiler"
-
-inherit toolchain
-
-DESCRIPTION="The GNU Compiler Collection.  Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="-*"
-
-RDEPEND=">=sys-libs/zlib-1.1.4
-       || ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
-       virtual/libiconv
-       fortran? (
-               >=dev-libs/gmp-4.2.1
-               >=dev-libs/mpfr-2.2.0_p10
-       )
-       !build? (
-               gcj? (
-                       gtk? (
-                               || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
-                               >=x11-libs/gtk+-2.2
-                               x11-libs/pango
-                       )
-                       >=media-libs/libart_lgpl-2.1
-               )
-               >=sys-libs/ncurses-5.2-r2
-               nls? ( sys-devel/gettext )
-       )"
-DEPEND="${RDEPEND}
-       >=sys-apps/texinfo-4.2-r4
-       >=sys-devel/bison-1.875
-       >=${CATEGORY}/binutils-2.16.1"
-PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
-if [[ ${CATEGORY} != cross-* ]] ; then
-       PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
-fi
-
-pkg_setup() {
-       if [[ -z ${I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS} ]] ; then
-               die "Please \`export I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS=1\` or define it in your make.conf if you want to use this ebuild.  This is to try and cut down on people filing bugs for a compiler we do not currently support."
-       fi
-}
-
-src_unpack() {
-       gcc_src_unpack
-
-       use vanilla && return 0
-
-       # Fix cross-compiling
-       epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
-}
-
-pkg_postinst() {
-       toolchain_pkg_postinst
-
-       einfo "This gcc-4 ebuild is provided for your convenience, and the use"
-       einfo "of this compiler is not supported by the Gentoo Developers."
-       einfo "Please file bugs related to gcc-4 with upstream developers."
-       einfo "Compiler bugs should be filed at http://gcc.gnu.org/bugzilla/"
-}