dev-lang/rust: drop 1.41.0
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Fri, 13 Mar 2020 05:51:15 +0000 (22:51 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Fri, 13 Mar 2020 06:41:34 +0000 (23:41 -0700)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-lang/rust/Manifest
dev-lang/rust/rust-1.41.0.ebuild [deleted file]

index a38ac2d2b29134f516f56e0e79c1f0a6bb9c15fa..c26da6db2c7e5b2e5bdb9d1607f6179f697d75e3 100644 (file)
@@ -72,5 +72,4 @@ DIST rustc-1.37.0-src.tar.xz 98654252 BLAKE2B ddee92c7959a0e1ee11ffe5ded6017703c
 DIST rustc-1.38.0-src.tar.xz 96163304 BLAKE2B 1e900b44db64727477ccf8e58e0ebb9ec209bbeb349816b5f7937e58c165db8befae33c5667732e5aaaa677c5a6c1e0229d9969ab8967fda9b8d7a593e6c5eb6 SHA512 b756d29a7a222bc7b5c7f42ff397346ab840f78e559f93e6e36b65e76eea525cf429899fe4de9fb8966623a2225b552feef9fa831bee50f9e25c976fa2af8c0a
 DIST rustc-1.39.0-src.tar.xz 96495140 BLAKE2B 6df6bf0c3b38c28753713acdc477ea6929740c32893171dd9b8620992439e45730ef6f9489a6fc411ff5884c661ac4c07b7b93f5a4174207ed53351d2dea09bf SHA512 8610b2ec77722087c572bd84ac562a5b7c5f1a644aea58c5d5daa07a9aed242703b7816e73e2eaa049f773d5907859e259744a0de700622df005584fd798dab0
 DIST rustc-1.40.0-src.tar.xz 92306352 BLAKE2B 762b9592414e5c816540f6fd37d07b3b0ffe97a151968cc8ae77be2fda03a6d66905192985edc65055cc7811dbd90faa2b2c056481f72161c6f7ccbcce13671a SHA512 b5ac3079acefb62d3c985b77f624d7fb68de23a59396fed9ccb292db61641c064f3146ee54d3cf59067b17ebfaadd14a6b2b466def60316bb5b13ba3aef01e1f
-DIST rustc-1.41.0-src.tar.xz 93763052 BLAKE2B a68524fb6e3abb43d52ae6676a1e9de1c5d33606eaea6e93bb518f10b196d620f2f370c631c32e39a624af71a3bf6911662a9df7eecb8dde78a20c8054a349fc SHA512 0e30fe53b77860085bea0f1f60315eb835b00dd796c5d1b98ed44fe6fc27336dfb064908c86e1669a9cbe81c9ca1495e1c259a8a268bef23b23805a719cef0dd
 DIST rustc-1.41.1-src.tar.xz 93754192 BLAKE2B 235ece650d0c75e1c8700ce73d3811997cd0d827b850a6dd435a269f3f86d85849d54755ea346c5ddcbe0d1224836fd78213f6abeab4a9a8c4c3e2d8a05ff7b4 SHA512 ef33565c9cf4e27ca279072bfed3301e0276c09407d49727640746ba78d289de285278d64b1cce8708461fd6c97c7ab2ea8d56e7a4c4a23b2e66e2d164c35fc9
diff --git a/dev-lang/rust/rust-1.41.0.ebuild b/dev-lang/rust/rust-1.41.0.ebuild
deleted file mode 100644 (file)
index c3b18cd..0000000
+++ /dev/null
@@ -1,369 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit bash-completion-r1 check-reqs estack flag-o-matic llvm multiprocessing multilib-build python-any-r1 rust-toolchain toolchain-funcs
-
-if [[ ${PV} = *beta* ]]; then
-       betaver=${PV//*beta}
-       BETA_SNAPSHOT="${betaver:0:4}-${betaver:4:2}-${betaver:6:2}"
-       MY_P="rustc-beta"
-       SLOT="beta/${PV}"
-       SRC="${BETA_SNAPSHOT}/rustc-beta-src.tar.xz"
-else
-       ABI_VER="$(ver_cut 1-2)"
-       SLOT="stable/${ABI_VER}"
-       MY_P="rustc-${PV}"
-       SRC="${MY_P}-src.tar.xz"
-       KEYWORDS="amd64 ~arm ~arm64 ppc64 x86"
-fi
-
-RUST_STAGE0_VERSION="1.$(($(ver_cut 2) - 1)).0"
-
-DESCRIPTION="Systems programming language from Mozilla"
-HOMEPAGE="https://www.rust-lang.org/"
-
-SRC_URI="
-       https://static.rust-lang.org/dist/${SRC} -> rustc-${PV}-src.tar.xz
-       !system-bootstrap? ( $(rust_all_arch_uris rust-${RUST_STAGE0_VERSION}) )
-"
-
-ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
-       NVPTX PowerPC RISCV Sparc SystemZ WebAssembly X86 XCore )
-ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
-LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/?}
-
-LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
-
-IUSE="clippy cpu_flags_x86_sse2 debug doc libressl nightly parallel-compiler rls rustfmt system-bootstrap system-llvm wasm ${ALL_LLVM_TARGETS[*]}"
-
-# Please keep the LLVM dependency block separate. Since LLVM is slotted,
-# we need to *really* make sure we're not pulling more than one slot
-# simultaneously.
-
-# How to use it:
-# 1. List all the working slots (with min versions) in ||, newest first.
-# 2. Update the := to specify *max* version, e.g. < 10.
-# 3. Specify LLVM_MAX_SLOT, e.g. 9.
-LLVM_DEPEND="
-       || (
-               sys-devel/llvm:9[llvm_targets_WebAssembly?]
-               wasm? ( =sys-devel/lld-9* )
-       )
-       <sys-devel/llvm-10:=
-"
-LLVM_MAX_SLOT=9
-
-BOOTSTRAP_DEPEND="|| ( >=dev-lang/rust-1.$(($(ver_cut 2) - 1)).0-r1 >=dev-lang/rust-bin-1.$(($(ver_cut 2) - 1)) )"
-
-COMMON_DEPEND="
-       net-libs/libssh2:=
-       net-libs/http-parser:=
-       net-misc/curl:=[ssl]
-       sys-libs/zlib:=
-       !libressl? ( dev-libs/openssl:0= )
-       libressl? ( dev-libs/libressl:0= )
-       elibc_musl? ( sys-libs/libunwind )
-       system-llvm? (
-               ${LLVM_DEPEND}
-       )
-"
-
-DEPEND="${COMMON_DEPEND}
-       ${PYTHON_DEPS}
-       || (
-               >=sys-devel/gcc-4.7
-               >=sys-devel/clang-3.5
-       )
-       system-bootstrap? ( ${BOOTSTRAP_DEPEND} )
-       system-llvm? (
-               dev-util/cmake
-               dev-util/ninja
-       )
-"
-
-RDEPEND="${COMMON_DEPEND}
-       >=app-eselect/eselect-rust-20190311
-"
-
-REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )
-       parallel-compiler? ( nightly )
-       wasm? ( llvm_targets_WebAssembly )
-       x86? ( cpu_flags_x86_sse2 )
-"
-
-QA_FLAGS_IGNORED="
-       usr/bin/*-${PV}
-       usr/lib*/lib*.so
-       usr/lib/rustlib/*/codegen-backends/librustc_codegen_llvm-llvm.so
-       usr/lib/rustlib/*/lib/lib*.so
-"
-
-QA_SONAME="usr/lib.*/librustc_macros.*.so"
-
-PATCHES=(
-       "${FILESDIR}"/1.40.0-add-soname.patch
-       "${FILESDIR}"/llvm-gcc10.patch
-)
-
-S="${WORKDIR}/${MY_P}-src"
-
-toml_usex() {
-       usex "$1" true false
-}
-
-pre_build_checks() {
-       CHECKREQS_DISK_BUILD="10G"
-       eshopts_push -s extglob
-       if is-flagq '-g?(gdb)?([1-9])'; then
-               CHECKREQS_DISK_BUILD="15G"
-       fi
-       eshopts_pop
-       check-reqs_pkg_setup
-}
-
-pkg_pretend() {
-       pre_build_checks
-}
-
-pkg_setup() {
-       pre_build_checks
-       python-any-r1_pkg_setup
-
-       # use bundled for now, #707746
-       # will need dev-libs/libgit2 slotted dep if re-enabled
-       #export LIBGIT2_SYS_USE_PKG_CONFIG=1
-       export LIBSSH2_SYS_USE_PKG_CONFIG=1
-       export PKG_CONFIG_ALLOW_CROSS=1
-
-       if use system-llvm; then
-               llvm_pkg_setup
-
-               local llvm_config="$(get_llvm_prefix "$LLVM_MAX_SLOT")/bin/llvm-config"
-
-               export LLVM_LINK_SHARED=1
-               export RUSTFLAGS="${RUSTFLAGS} -Lnative=$("${llvm_config}" --libdir)"
-       fi
-}
-
-src_prepare() {
-       if ! use system-bootstrap; then
-               local rust_stage0_root="${WORKDIR}"/rust-stage0
-               local rust_stage0="rust-${RUST_STAGE0_VERSION}-$(rust_abi)"
-
-               "${WORKDIR}/${rust_stage0}"/install.sh --disable-ldconfig \
-                       --destdir="${rust_stage0_root}" --prefix=/ || die
-       fi
-
-       default
-}
-
-src_configure() {
-       local rust_target="" rust_targets="" arch_cflags
-
-       # Collect rust target names to compile standard libs for all ABIs.
-       for v in $(multilib_get_enabled_abi_pairs); do
-               rust_targets="${rust_targets},\"$(rust_abi $(get_abi_CHOST ${v##*.}))\""
-       done
-       if use wasm; then
-               rust_targets="${rust_targets},\"wasm32-unknown-unknown\""
-       fi
-       rust_targets="${rust_targets#,}"
-
-       local extended="true" tools="\"cargo\","
-       if use clippy; then
-               tools="\"clippy\",$tools"
-       fi
-       if use rls; then
-               tools="\"rls\",\"analysis\",\"src\",$tools"
-       fi
-       if use rustfmt; then
-               tools="\"rustfmt\",$tools"
-       fi
-
-       local rust_stage0_root
-       if use system-bootstrap; then
-               rust_stage0_root="$(rustc --print sysroot)"
-       else
-               rust_stage0_root="${WORKDIR}"/rust-stage0
-       fi
-
-       rust_target="$(rust_abi)"
-
-       cat <<- EOF > "${S}"/config.toml
-               [llvm]
-               optimize = $(toml_usex !debug)
-               release-debuginfo = $(toml_usex debug)
-               assertions = $(toml_usex debug)
-               targets = "${LLVM_TARGETS// /;}"
-               experimental-targets = ""
-               link-shared = $(toml_usex system-llvm)
-               [build]
-               build = "${rust_target}"
-               host = ["${rust_target}"]
-               target = [${rust_targets}]
-               cargo = "${rust_stage0_root}/bin/cargo"
-               rustc = "${rust_stage0_root}/bin/rustc"
-               docs = $(toml_usex doc)
-               compiler-docs = $(toml_usex doc)
-               submodules = false
-               python = "${EPYTHON}"
-               locked-deps = true
-               vendor = true
-               extended = ${extended}
-               tools = [${tools}]
-               verbose = 2
-               [install]
-               prefix = "${EPREFIX}/usr"
-               libdir = "lib"
-               docdir = "share/doc/${PF}"
-               mandir = "share/man"
-               [rust]
-               optimize = $(toml_usex !debug)
-               debug = $(toml_usex debug)
-               debug-assertions = $(toml_usex debug)
-               default-linker = "$(tc-getCC)"
-               parallel-compiler = $(toml_usex parallel-compiler)
-               channel = "$(usex nightly nightly stable)"
-               rpath = false
-               lld = $(usex system-llvm false $(toml_usex wasm))
-               [dist]
-               src-tarball = false
-       EOF
-
-       for v in $(multilib_get_enabled_abi_pairs); do
-               rust_target=$(rust_abi $(get_abi_CHOST ${v##*.}))
-               arch_cflags="$(get_abi_CFLAGS ${v##*.})"
-
-               cat <<- EOF >> "${S}"/config.env
-                       CFLAGS_${rust_target}=${arch_cflags}
-               EOF
-
-               cat <<- EOF >> "${S}"/config.toml
-                       [target.${rust_target}]
-                       cc = "$(tc-getBUILD_CC)"
-                       cxx = "$(tc-getBUILD_CXX)"
-                       linker = "$(tc-getCC)"
-                       ar = "$(tc-getAR)"
-               EOF
-               # librustc_target/spec/linux_musl_base.rs sets base.crt_static_default = true;
-               if use elibc_musl; then
-                       cat <<- EOF >> "${S}"/config.toml
-                               crt-static = false
-                       EOF
-               fi
-               if use system-llvm; then
-                       cat <<- EOF >> "${S}"/config.toml
-                               llvm-config = "$(get_llvm_prefix "${LLVM_MAX_SLOT}")/bin/llvm-config"
-                       EOF
-               fi
-       done
-
-       if use wasm; then
-               cat <<- EOF >> "${S}"/config.toml
-                       [target.wasm32-unknown-unknown]
-                       linker = "$(usex system-llvm lld rust-lld)"
-               EOF
-       fi
-}
-
-src_compile() {
-       env $(cat "${S}"/config.env)\
-               "${EPYTHON}" ./x.py build -vv --config="${S}"/config.toml -j$(makeopts_jobs) \
-               --exclude src/tools/miri || die # https://github.com/rust-lang/rust/issues/52305
-}
-
-src_install() {
-       env DESTDIR="${D}" "${EPYTHON}" ./x.py install -vv --config="${S}"/config.toml \
-       --exclude src/tools/miri || die
-
-       # bug #689562, #689160
-       rm "${D}/etc/bash_completion.d/cargo" || die
-       rmdir "${D}"/etc{/bash_completion.d,} || die
-       dobashcomp build/tmp/dist/cargo-image/etc/bash_completion.d/cargo
-
-       mv "${ED}/usr/bin/rustc" "${ED}/usr/bin/rustc-${PV}" || die
-       mv "${ED}/usr/bin/rustdoc" "${ED}/usr/bin/rustdoc-${PV}" || die
-       mv "${ED}/usr/bin/rust-gdb" "${ED}/usr/bin/rust-gdb-${PV}" || die
-       mv "${ED}/usr/bin/rust-gdbgui" "${ED}/usr/bin/rust-gdbgui-${PV}" || die
-       mv "${ED}/usr/bin/rust-lldb" "${ED}/usr/bin/rust-lldb-${PV}" || die
-       mv "${ED}/usr/bin/cargo" "${ED}/usr/bin/cargo-${PV}" || die
-       if use clippy; then
-               mv "${ED}/usr/bin/clippy-driver" "${ED}/usr/bin/clippy-driver-${PV}" || die
-               mv "${ED}/usr/bin/cargo-clippy" "${ED}/usr/bin/cargo-clippy-${PV}" || die
-       fi
-       if use rls; then
-               mv "${ED}/usr/bin/rls" "${ED}/usr/bin/rls-${PV}" || die
-       fi
-       if use rustfmt; then
-               mv "${ED}/usr/bin/rustfmt" "${ED}/usr/bin/rustfmt-${PV}" || die
-               mv "${ED}/usr/bin/cargo-fmt" "${ED}/usr/bin/cargo-fmt-${PV}" || die
-       fi
-
-       # Move public shared libs to abi specific libdir
-       # Private and target specific libs MUST stay in /usr/lib/rustlib/${rust_target}/lib
-       if [[ $(get_libdir) != lib ]]; then
-               dodir /usr/$(get_libdir)
-               mv "${ED}/usr/lib"/*.so "${ED}/usr/$(get_libdir)/" || die
-       fi
-
-       dodoc COPYRIGHT
-
-       # note: eselect-rust adds EROOT to all paths below
-       cat <<-EOF > "${T}/provider-${P}"
-               /usr/bin/rustdoc
-               /usr/bin/rust-gdb
-               /usr/bin/rust-gdbgui
-               /usr/bin/rust-lldb
-       EOF
-       echo /usr/bin/cargo >> "${T}/provider-${P}"
-       if use clippy; then
-               echo /usr/bin/clippy-driver >> "${T}/provider-${P}"
-               echo /usr/bin/cargo-clippy >> "${T}/provider-${P}"
-       fi
-       if use rls; then
-               echo /usr/bin/rls >> "${T}/provider-${P}"
-       fi
-       if use rustfmt; then
-               echo /usr/bin/rustfmt >> "${T}/provider-${P}"
-               echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"
-       fi
-
-       insinto /etc/env.d/rust
-       doins "${T}/provider-${P}"
-}
-
-pkg_postinst() {
-       eselect rust update --if-unset
-
-       elog "Rust installs a helper script for calling GDB and LLDB,"
-       elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
-
-       ewarn "cargo is now installed from dev-lang/rust{,-bin} instead of dev-util/cargo."
-       ewarn "This might have resulted in a dangling symlink for /usr/bin/cargo on some"
-       ewarn "systems. This can be resolved by calling 'sudo eselect rust set ${P}'."
-
-       if has_version app-editors/emacs; then
-               elog "install app-emacs/rust-mode to get emacs support for rust."
-       fi
-
-       if has_version app-editors/gvim || has_version app-editors/vim; then
-               elog "install app-vim/rust-vim to get vim support for rust."
-       fi
-
-       if use elibc_musl; then
-               ewarn "${PN} on *-musl targets is configured with crt-static"
-               ewarn ""
-               ewarn "you will need to set RUSTFLAGS=\"-C target-feature=-crt-static\" in make.conf"
-               ewarn "to use it with portage, otherwise you may see failures like"
-               ewarn "error: cannot produce proc-macro for serde_derive v1.0.98 as the target "
-               ewarn "x86_64-unknown-linux-musl does not support these crate types"
-       fi
-}
-
-pkg_postrm() {
-       eselect rust cleanup
-}