gui-apps/swaybg: 1.0 release
authorMatthew Thode <prometheanfire@gentoo.org>
Fri, 3 May 2019 18:25:12 +0000 (13:25 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Fri, 3 May 2019 18:32:47 +0000 (13:32 -0500)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
gui-apps/swaybg/Manifest [new file with mode: 0644]
gui-apps/swaybg/swaybg-1.0.ebuild [new file with mode: 0644]
gui-apps/swaybg/swaybg-9999.ebuild

diff --git a/gui-apps/swaybg/Manifest b/gui-apps/swaybg/Manifest
new file mode 100644 (file)
index 0000000..562a59c
--- /dev/null
@@ -0,0 +1 @@
+DIST swaybg-1.0.tar.gz 15851 BLAKE2B 820edbce4161f2d109bc8e842fb2bef101a5793d1da90f4258e5771fe85ab089e184c063a0a7073adbe218c59307946f86bd02c4d62b0585aeb3f9cd5c7963f8 SHA512 67d0e0109b906ece51800729182940374cc59fa07d0866b57cf876d12191fe12e796b84350a849dc85183fa58a3b2d196191e48dcc03dcc3708a980ed4a8cff0
diff --git a/gui-apps/swaybg/swaybg-1.0.ebuild b/gui-apps/swaybg/swaybg-1.0.ebuild
new file mode 100644 (file)
index 0000000..3de0837
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A wallpaper utility for Wayland"
+HOMEPAGE="https://github.com/swaywm/swaybg"
+
+if [[ ${PV} == 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+       SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man"
+
+DEPEND="
+       dev-libs/wayland
+"
+RDEPEND="
+       ${DEPEND}
+       !<=gui-wm/sway-1.1
+"
+BDEPEND="
+       >=dev-libs/wayland-protocols-1.14
+       x11-libs/gdk-pixbuf
+       x11-libs/cairo
+       virtual/pkgconfig
+       man? ( app-text/scdoc )
+"
+
+src_configure() {
+       local emesonargs=(
+               -Dman-pages=$(usex man enabled disabled)
+               "-Dwerror=false"
+       )
+
+       meson_src_configure
+}
index 79643a572c66bba7527dc44e864abe89c10fb6fe..3de08375f038297102ed208fbe2e50e82af9f7e3 100644 (file)
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]]; then
        EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
 else
        SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64 ~x86"
+       KEYWORDS="~amd64 ~arm64 ~x86"
 fi
 
 LICENSE="MIT"