x11-terms/terminology: revbump for 1.2.1.
authorJoonas Niilola <juippis@gmail.com>
Mon, 20 Aug 2018 09:08:32 +0000 (12:08 +0300)
committerPatrice Clement <monsieurp@gentoo.org>
Tue, 21 Aug 2018 08:29:01 +0000 (10:29 +0200)
- Add patch to use system liblz4 instead of bundled one,
- More accurate dependencies on dev-libs/efl to use with wayland.

Closes: https://bugs.gentoo.org/648834
Closes: https://github.com/gentoo/gentoo/pull/9636
Package-Manager: Portage[mgorny]-2.3.43.3

x11-terms/terminology/files/terminology-1.2.1-use-system-lz4.patch [new file with mode: 0644]
x11-terms/terminology/terminology-1.2.1-r1.ebuild [new file with mode: 0644]

diff --git a/x11-terms/terminology/files/terminology-1.2.1-use-system-lz4.patch b/x11-terms/terminology/files/terminology-1.2.1-use-system-lz4.patch
new file mode 100644 (file)
index 0000000..291312d
--- /dev/null
@@ -0,0 +1,23 @@
+diff -Naur a/src/bin/meson.build b/src/bin/meson.build
+--- a/src/bin/meson.build      2018-05-14 23:20:41.000000000 +0300
++++ b/src/bin/meson.build      2018-08-14 15:45:56.349694832 +0300
+@@ -31,7 +31,6 @@
+                        'termptygfx.c', 'termptygfx.h',
+                        'termptyext.c', 'termptyext.h',
+                        'termptysave.c', 'termptysave.h',
+-                       'lz4/lz4.c', 'lz4/lz4.h',
+                        'md5/md5.c', 'md5/md5.h',
+                        'utf8.c', 'utf8.h',
+                        'win.c', 'win.h',
+diff -Naur a/src/bin/termptysave.c b/src/bin/termptysave.c
+--- a/src/bin/termptysave.c    2018-05-14 23:20:41.000000000 +0300
++++ b/src/bin/termptysave.c    2018-08-14 16:08:59.050328377 +0300
+@@ -2,7 +2,7 @@
+ #include <Elementary.h>
+ #include "termpty.h"
+ #include "termptysave.h"
+-#include "lz4/lz4.h"
++#include <lz4.h>
+ #include <sys/mman.h>
+ #if defined (__MacOSX__) || (defined (__MACH__) && defined (__APPLE__))
diff --git a/x11-terms/terminology/terminology-1.2.1-r1.ebuild b/x11-terms/terminology/terminology-1.2.1-r1.ebuild
new file mode 100644 (file)
index 0000000..5090a33
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson xdg-utils
+
+DESCRIPTION="Feature rich terminal emulator using the Enlightenment Foundation Libraries"
+HOMEPAGE="https://www.enlightenment.org/about-terminology"
+SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+       || ( dev-libs/efl[egl] dev-libs/efl[opengl] )
+       || ( dev-libs/efl[X] dev-libs/efl[wayland] )
+       app-arch/lz4
+       >=dev-libs/efl-1.20.0[eet,fontconfig]
+"
+DEPEND="
+       ${RDEPEND}
+       virtual/pkgconfig
+       nls? ( sys-devel/gettext )
+"
+
+PATCHES=(
+       "${FILESDIR}/terminology-1.2.1-use-system-lz4.patch"
+)
+
+src_prepare() {
+       default
+       xdg_environment_reset
+}
+
+src_configure() {
+       local emesonargs=(
+               -D nls=$(usex nls true false)
+       )
+
+       meson_src_configure
+}