dev-python/django-sortedm2m: Require sqlite for tests
authorMichał Górny <mgorny@gentoo.org>
Mon, 18 May 2020 11:14:16 +0000 (13:14 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 18 May 2020 11:14:16 +0000 (13:14 +0200)
Closes: https://bugs.gentoo.org/723702
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/django-sortedm2m/django-sortedm2m-2.0.0.ebuild

index f513c330485d7c5c7d4c8fe37532194dc5cc53ce..7e0513e1cb5250f359b41fa6eebf96577344a5c5 100644 (file)
@@ -21,7 +21,11 @@ IUSE="test"
 RESTRICT="!test? ( test )"
 
 RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
-BDEPEND="test? ( ${RDEPEND} )"
+BDEPEND="
+       test? (
+               $(python_gen_impl_dep sqlite)
+               ${RDEPEND}
+       )"
 
 python_test() {
        local -x PYTHONPATH=test_project:${PYTHONPATH}