app-arch/vimball: add py38 compat and fix DISTUTILS_USE_SETUPTOOLS
authorTim Harder <radhermit@gentoo.org>
Wed, 12 Feb 2020 00:24:36 +0000 (17:24 -0700)
committerTim Harder <radhermit@gentoo.org>
Wed, 12 Feb 2020 00:50:05 +0000 (17:50 -0700)
Signed-off-by: Tim Harder <radhermit@gentoo.org>
app-arch/vimball/vimball-0.5.1.ebuild
app-arch/vimball/vimball-9999.ebuild

index 38f71ad8b03df162335d1bbe85fccda1de534dc3..9bcf7f649ea8965c3236b82b2bc416aa334b4aca 100644 (file)
@@ -2,7 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
 inherit distutils-r1
 
 if [[ ${PV} == *9999 ]] ; then
@@ -21,8 +22,6 @@ SLOT="0"
 IUSE="test"
 RESTRICT="!test? ( test )"
 
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${BDEPEND}"
 DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
 
 python_test() {
index 38f71ad8b03df162335d1bbe85fccda1de534dc3..9bcf7f649ea8965c3236b82b2bc416aa334b4aca 100644 (file)
@@ -2,7 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
 inherit distutils-r1
 
 if [[ ${PV} == *9999 ]] ; then
@@ -21,8 +22,6 @@ SLOT="0"
 IUSE="test"
 RESTRICT="!test? ( test )"
 
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${BDEPEND}"
 DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
 
 python_test() {