Version bump.
authorAndrej Kacian <ticho@gentoo.org>
Tue, 27 Feb 2007 20:17:50 +0000 (20:17 +0000)
committerAndrej Kacian <ticho@gentoo.org>
Tue, 27 Feb 2007 20:17:50 +0000 (20:17 +0000)
Package-Manager: portage-2.1.2-r11

24 files changed:
mail-client/claws-mail-acpi-notifier/ChangeLog
mail-client/claws-mail-acpi-notifier/claws-mail-acpi-notifier-1.0.8.ebuild [new file with mode: 0644]
mail-client/claws-mail-acpi-notifier/files/digest-claws-mail-acpi-notifier-1.0.8 [new file with mode: 0644]
mail-client/claws-mail-attachwarner/ChangeLog
mail-client/claws-mail-attachwarner/claws-mail-attachwarner-0.2.5.ebuild [new file with mode: 0644]
mail-client/claws-mail-attachwarner/files/digest-claws-mail-attachwarner-0.2.5 [new file with mode: 0644]
mail-client/claws-mail-gtkhtml/ChangeLog
mail-client/claws-mail-gtkhtml/claws-mail-gtkhtml-0.14.2.ebuild [new file with mode: 0644]
mail-client/claws-mail-gtkhtml/files/digest-claws-mail-gtkhtml-0.14.2 [new file with mode: 0644]
mail-client/claws-mail-notification/ChangeLog
mail-client/claws-mail-notification/claws-mail-notification-0.9.ebuild [new file with mode: 0644]
mail-client/claws-mail-notification/files/digest-claws-mail-notification-0.9 [new file with mode: 0644]
mail-client/claws-mail-rssyl/ChangeLog
mail-client/claws-mail-rssyl/claws-mail-rssyl-0.11.ebuild [new file with mode: 0644]
mail-client/claws-mail-rssyl/files/digest-claws-mail-rssyl-0.11 [new file with mode: 0644]
mail-client/claws-mail-smime/ChangeLog
mail-client/claws-mail-smime/claws-mail-smime-0.7.ebuild [new file with mode: 0644]
mail-client/claws-mail-smime/files/digest-claws-mail-smime-0.7 [new file with mode: 0644]
mail-client/claws-mail-vcalendar/ChangeLog
mail-client/claws-mail-vcalendar/claws-mail-vcalendar-1.94.ebuild [new file with mode: 0644]
mail-client/claws-mail-vcalendar/files/digest-claws-mail-vcalendar-1.94 [new file with mode: 0644]
mail-client/claws-mail/ChangeLog
mail-client/claws-mail/claws-mail-2.8.0.ebuild [new file with mode: 0644]
mail-client/claws-mail/files/digest-claws-mail-2.8.0 [new file with mode: 0644]

index d3486ec436eb42e7b386ebb7ff5d8e4474d59516..8fb6c4628e2b463114e5833b496380845a1ffebb 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for mail-client/claws-mail-acpi-notifier
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-acpi-notifier/ChangeLog,v 1.5 2007/01/25 07:58:07 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-acpi-notifier/ChangeLog,v 1.6 2007/02/27 20:00:46 ticho Exp $
+
+*claws-mail-acpi-notifier-1.0.8 (27 Feb 2007)
+
+  27 Feb 2007; Andrej Kacian <ticho@gentoo.org>
+  +claws-mail-acpi-notifier-1.0.8.ebuild:
+  Version bump.
 
   25 Jan 2007; Christian Faulhammer <opfer@gentoo.org>
   claws-mail-acpi-notifier-1.0.5.ebuild:
diff --git a/mail-client/claws-mail-acpi-notifier/claws-mail-acpi-notifier-1.0.8.ebuild b/mail-client/claws-mail-acpi-notifier/claws-mail-acpi-notifier-1.0.8.ebuild
new file mode 100644 (file)
index 0000000..b5f07b5
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-acpi-notifier/claws-mail-acpi-notifier-1.0.8.ebuild,v 1.1 2007/02/27 20:00:46 ticho Exp $
+
+inherit eutils
+
+MY_P="${P#claws-mail-}"
+MY_P="${MY_P/-/_}"
+
+DESCRIPTION="This plugin enables mail notification via LEDs on some laptops."
+HOMEPAGE="http://www.claws-mail.org"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND=">=mail-client/claws-mail-2.8.0"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+       make DESTDIR="${D}" install
+       dodoc AUTHORS ChangeLog NEWS README
+
+       # kill useless files
+       rm -f ${D}usr/lib*/claws-mail/plugins/*.{a,la}
+}
+
+pkg_postinst() {
+       PROC_IFACES="$(echo /proc/acpi/{asus/mled,ibm/led,acer/mailled}) /proc/driver/acerhk/led"
+
+       local procfile
+       local message_shown=false
+
+       for procfile in ${PROC_IFACES}; do
+               if [[ -f ${procfile} ]]; then
+                       elog "Make sure ${procfile} is writable by users of this plugin."
+                       message_shown=true
+               fi
+       done
+}
diff --git a/mail-client/claws-mail-acpi-notifier/files/digest-claws-mail-acpi-notifier-1.0.8 b/mail-client/claws-mail-acpi-notifier/files/digest-claws-mail-acpi-notifier-1.0.8
new file mode 100644 (file)
index 0000000..1b4bb94
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 003376a47638b2f6eebe5c75fea5e4a6 acpi_notifier-1.0.8.tar.gz 407244
+RMD160 c5baac5e56234c8f467b4edacccdd63bd0c7604e acpi_notifier-1.0.8.tar.gz 407244
+SHA256 5a060ee974a8b81ffd8d94f32c34dffccce9842d117617a2878cb093755cd241 acpi_notifier-1.0.8.tar.gz 407244
index 1582a998d43ac1c971f93d1f6c115d3ca85a1434..267001bb56647b570b793fc2944789b6c380330d 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for mail-client/claws-mail-attachwarner
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-attachwarner/ChangeLog,v 1.4 2007/02/12 10:19:48 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-attachwarner/ChangeLog,v 1.5 2007/02/27 20:05:18 ticho Exp $
+
+*claws-mail-attachwarner-0.2.5 (27 Feb 2007)
+
+  27 Feb 2007; Andrej Kacian <ticho@gentoo.org>
+  +claws-mail-attachwarner-0.2.5.ebuild:
+  Version bump.
 
   12 Feb 2007; Matti Bickel <mabi@gentoo.org>
   claws-mail-attachwarner-0.2.4.ebuild:
diff --git a/mail-client/claws-mail-attachwarner/claws-mail-attachwarner-0.2.5.ebuild b/mail-client/claws-mail-attachwarner/claws-mail-attachwarner-0.2.5.ebuild
new file mode 100644 (file)
index 0000000..1380682
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-attachwarner/claws-mail-attachwarner-0.2.5.ebuild,v 1.1 2007/02/27 20:05:18 ticho Exp $
+
+MY_P="${P#claws-mail-}"
+
+DESCRIPTION="Warns when the user composes a message mentioning an attachment in
+the message body without attaching any files to the message."
+HOMEPAGE="http://www.claws-mail.org"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+DEPEND=">=mail-client/claws-mail-2.7.0
+               nls? ( >=sys-devel/gettext-0.12.1 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+       econf $(use_enable nls) || die "econf failed"
+       emake || die "emake failed"
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "make install failed"
+       dodoc ChangeLog README
+
+       # kill useless files
+       rm -f ${D}/usr/lib*/claws-mail/plugins/*.{a,la}
+}
diff --git a/mail-client/claws-mail-attachwarner/files/digest-claws-mail-attachwarner-0.2.5 b/mail-client/claws-mail-attachwarner/files/digest-claws-mail-attachwarner-0.2.5
new file mode 100644 (file)
index 0000000..2c3a76e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 93d50a13eb88b6aba40f672c848570f4 attachwarner-0.2.5.tar.gz 377058
+RMD160 011181bf715154837ecfb24f441225b5ae30727d attachwarner-0.2.5.tar.gz 377058
+SHA256 4b10d97a56d1ec36deb6d0d3775ff7cb4d74ab8d6edff91003262743f6979dc7 attachwarner-0.2.5.tar.gz 377058
index 2759e999a5840a56b4ea938c542aad266df336b9..d2bfd7f78d5d76355c4a8eb2326af1e1b21b39c9 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for mail-client/claws-mail-gtkhtml
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-gtkhtml/ChangeLog,v 1.6 2007/01/31 19:39:38 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-gtkhtml/ChangeLog,v 1.7 2007/02/27 20:08:18 ticho Exp $
+
+*claws-mail-gtkhtml-0.14.2 (27 Feb 2007)
+
+  27 Feb 2007; Andrej Kacian <ticho@gentoo.org>
+  +claws-mail-gtkhtml-0.14.2.ebuild:
+  Version bump.
 
   31 Jan 2007; Markus Rothe <corsair@gentoo.org>
   claws-mail-gtkhtml-0.13.ebuild:
diff --git a/mail-client/claws-mail-gtkhtml/claws-mail-gtkhtml-0.14.2.ebuild b/mail-client/claws-mail-gtkhtml/claws-mail-gtkhtml-0.14.2.ebuild
new file mode 100644 (file)
index 0000000..105cd8c
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-gtkhtml/claws-mail-gtkhtml-0.14.2.ebuild,v 1.1 2007/02/27 20:08:18 ticho Exp $
+
+inherit eutils
+
+MY_P="${PN#claws-mail-}2_viewer-${PV}"
+
+DESCRIPTION="Renders HTML mail using the gtkhtml2 rendering widget."
+HOMEPAGE="http://claws.sylpheed.org"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+DEPEND=">=mail-client/claws-mail-2.7.0
+               =gnome-extra/gtkhtml-2*
+               net-misc/curl"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+       make DESTDIR="${D}" install
+       dodoc AUTHORS ChangeLog NEWS README
+
+       # kill useless files
+       rm -f ${D}usr/lib*/claws-mail/plugins/*.{a,la}
+}
diff --git a/mail-client/claws-mail-gtkhtml/files/digest-claws-mail-gtkhtml-0.14.2 b/mail-client/claws-mail-gtkhtml/files/digest-claws-mail-gtkhtml-0.14.2
new file mode 100644 (file)
index 0000000..7c47c17
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 db501230e1a7ccb03c8d2668e19d3adb gtkhtml2_viewer-0.14.2.tar.gz 389369
+RMD160 246747381558249cb87af3191d1f582c2088519f gtkhtml2_viewer-0.14.2.tar.gz 389369
+SHA256 902d963e1698fde5502d2635fea66681fd787e205448b7e41f08929cc69aee89 gtkhtml2_viewer-0.14.2.tar.gz 389369
index e9f3a6094f9be64cadd14cf4921c2af8b4ce8182..f96cf96667c80ee3459ac8e47a5845d05f95b8fd 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for mail-client/claws-mail-notification
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-notification/ChangeLog,v 1.4 2007/01/25 08:13:10 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-notification/ChangeLog,v 1.5 2007/02/27 20:11:56 ticho Exp $
+
+*claws-mail-notification-0.9 (27 Feb 2007)
+
+  27 Feb 2007; Andrej Kacian <ticho@gentoo.org>
+  +claws-mail-notification-0.9.ebuild:
+  Version bump.
 
   25 Jan 2007; Christian Faulhammer <opfer@gentoo.org>
   claws-mail-notification-0.7.ebuild:
diff --git a/mail-client/claws-mail-notification/claws-mail-notification-0.9.ebuild b/mail-client/claws-mail-notification/claws-mail-notification-0.9.ebuild
new file mode 100644 (file)
index 0000000..559fc79
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-notification/claws-mail-notification-0.9.ebuild,v 1.1 2007/02/27 20:11:56 ticho Exp $
+
+MY_P="${PN#claws-mail-}_plugin-${PV}"
+
+DESCRIPTION="Plugin providing various ways to notify user of new and unread mail."
+HOMEPAGE="http://www.claws-mail.org"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=">=mail-client/claws-mail-2.8.0"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+       make DESTDIR="${D}" install
+       dodoc AUTHORS ChangeLog NEWS README
+
+       # kill useless files
+       rm -f ${D}/usr/lib*/claws-mail/plugins/*.{a,la}
+}
diff --git a/mail-client/claws-mail-notification/files/digest-claws-mail-notification-0.9 b/mail-client/claws-mail-notification/files/digest-claws-mail-notification-0.9
new file mode 100644 (file)
index 0000000..af561ed
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 6a9d131eb4eccccfaaee3b086ea360f9 notification_plugin-0.9.tar.gz 360826
+RMD160 1087926f191313b3090968eb6dc5749594bacaab notification_plugin-0.9.tar.gz 360826
+SHA256 280ec06e2520e14f766adc69c118817b6e763718016789ed9b2d5c28a6f9a11c notification_plugin-0.9.tar.gz 360826
index 00978ec1d23eb295f2ecf24c54a19aa1103555bb..efcf96de2c979d2a06458897af825f49e9da22c2 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for mail-client/claws-mail-rssyl
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-rssyl/ChangeLog,v 1.5 2007/01/31 19:32:29 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-rssyl/ChangeLog,v 1.6 2007/02/27 20:12:59 ticho Exp $
+
+*claws-mail-rssyl-0.11 (27 Feb 2007)
+
+  27 Feb 2007; Andrej Kacian <ticho@gentoo.org>
+  +claws-mail-rssyl-0.11.ebuild:
+  Version bump.
 
   31 Jan 2007; Markus Rothe <corsair@gentoo.org>
   claws-mail-rssyl-0.8.ebuild:
diff --git a/mail-client/claws-mail-rssyl/claws-mail-rssyl-0.11.ebuild b/mail-client/claws-mail-rssyl/claws-mail-rssyl-0.11.ebuild
new file mode 100644 (file)
index 0000000..d97940e
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-rssyl/claws-mail-rssyl-0.11.ebuild,v 1.1 2007/02/27 20:12:59 ticho Exp $
+
+MY_P="${P#claws-mail-}"
+
+DESCRIPTION="This plugin allows you to read your favorite newsfeeds in Claws. RSS 1.0, 2.0 and Atom feeds are currently supported."
+HOMEPAGE="http://www.claws-mail.org"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="nls"
+DEPEND=">=mail-client/claws-mail-2.8.0
+       net-misc/curl
+       dev-libs/libxml2
+       nls? ( >=sys-devel/gettext-0.12.1 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+       econf $(use_enable nls) || die "econf failed"
+       emake || die "emake failed"
+}
+
+src_install() {
+       make DESTDIR="${D}" install
+       dodoc ChangeLog README
+
+       # kill useless files
+       rm -f ${D}/usr/lib*/claws-mail/plugins/*.{a,la}
+}
diff --git a/mail-client/claws-mail-rssyl/files/digest-claws-mail-rssyl-0.11 b/mail-client/claws-mail-rssyl/files/digest-claws-mail-rssyl-0.11
new file mode 100644 (file)
index 0000000..85981bb
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 4593a612f7b18c5f2f9cb452c5b05974 rssyl-0.11.tar.gz 455494
+RMD160 e8b1694c91f857a2bbe5376a8d1e4b022fefb38f rssyl-0.11.tar.gz 455494
+SHA256 3be4ddb99b75fca9ea8588095f2f7635b0d55f60cd1d099ba339e81c726e6bf6 rssyl-0.11.tar.gz 455494
index 4769bf5056314e42a8570f1d63e8bc701a21dc9d..0cc02468ac6528c591f17112180fb0da526a9421 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for mail-client/claws-mail-smime
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-smime/ChangeLog,v 1.5 2007/01/25 08:16:03 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-smime/ChangeLog,v 1.6 2007/02/27 20:14:39 ticho Exp $
+
+*claws-mail-smime-0.7 (27 Feb 2007)
+
+  27 Feb 2007; Andrej Kacian <ticho@gentoo.org>
+  +claws-mail-smime-0.7.ebuild:
+  Version bump.
 
   25 Jan 2007; Christian Faulhammer <opfer@gentoo.org>
   claws-mail-smime-0.5.7.ebuild:
diff --git a/mail-client/claws-mail-smime/claws-mail-smime-0.7.ebuild b/mail-client/claws-mail-smime/claws-mail-smime-0.7.ebuild
new file mode 100644 (file)
index 0000000..b805027
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-smime/claws-mail-smime-0.7.ebuild,v 1.1 2007/02/27 20:14:39 ticho Exp $
+
+MY_P="${P#claws-mail-}"
+
+DESCRIPTION="This plugin allows you to handle S/MIME signed and/or encrypted mails."
+HOMEPAGE="http://www.claws-mail.org"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~x86-fbsd"
+IUSE=""
+DEPEND=">=mail-client/claws-mail-2.8.0
+               >=app-crypt/gpgme-1.1.1"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+       make DESTDIR="${D}" install
+       dodoc AUTHORS ChangeLog NEWS README
+
+       # kill useless files
+       rm -f ${D}/usr/lib*/claws-mail/plugins/*.{a,la}
+}
diff --git a/mail-client/claws-mail-smime/files/digest-claws-mail-smime-0.7 b/mail-client/claws-mail-smime/files/digest-claws-mail-smime-0.7
new file mode 100644 (file)
index 0000000..5d5ccd5
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 2dfe61bf0b264182413dabaf4724870c smime-0.7.tar.gz 329231
+RMD160 fa25ed526d2b0e4634c6910b5616cd6c22397696 smime-0.7.tar.gz 329231
+SHA256 fa2d4e7f57021883bb127235cc74d21151f7980baa96e54d275a5b59dee0447d smime-0.7.tar.gz 329231
index 179bdfd906ebd12af16d2a553728786cca508cc7..14aa7264ad50a2bd0f712556adde21cf0614071a 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for mail-client/claws-mail-vcalendar
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-vcalendar/ChangeLog,v 1.6 2007/01/31 19:31:32 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-vcalendar/ChangeLog,v 1.7 2007/02/27 20:17:50 ticho Exp $
+
+*claws-mail-vcalendar-1.94 (27 Feb 2007)
+
+  27 Feb 2007; Andrej Kacian <ticho@gentoo.org>
+  +claws-mail-vcalendar-1.94.ebuild:
+  Version bump.
 
   31 Jan 2007; Markus Rothe <corsair@gentoo.org>
   claws-mail-vcalendar-1.91.ebuild:
diff --git a/mail-client/claws-mail-vcalendar/claws-mail-vcalendar-1.94.ebuild b/mail-client/claws-mail-vcalendar/claws-mail-vcalendar-1.94.ebuild
new file mode 100644 (file)
index 0000000..01f0991
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-vcalendar/claws-mail-vcalendar-1.94.ebuild,v 1.1 2007/02/27 20:17:50 ticho Exp $
+
+inherit eutils
+
+MY_P="${P#claws-mail-}"
+
+DESCRIPTION="Plugin for sylpheed-claws to support the vCalendar meeting format"
+HOMEPAGE="http://www.claws-mail.org"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND=">=mail-client/claws-mail-2.8.0"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+       make DESTDIR="${D}" install
+       dodoc AUTHORS ChangeLog NEWS README
+
+       # kill useless files
+       rm -f ${D}/usr/lib*/claws-mail/plugins/*.{a,la}
+
+       # going to conflict with libical
+       rm -f ${D}/usr/include/ical.h
+}
diff --git a/mail-client/claws-mail-vcalendar/files/digest-claws-mail-vcalendar-1.94 b/mail-client/claws-mail-vcalendar/files/digest-claws-mail-vcalendar-1.94
new file mode 100644 (file)
index 0000000..82db77f
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 9986fd1c252217ecc03276edbc5e63ef vcalendar-1.94.tar.gz 736273
+RMD160 93f5f221c3d5cc7a0aabcf2084b7044beeff6df8 vcalendar-1.94.tar.gz 736273
+SHA256 43429d908463917f3bbf5f321dc922d17e520e1a6bac8459316506860c5f0a17 vcalendar-1.94.tar.gz 736273
index fd2cfaaa654d3e6a2dbb0e6331bc4b9fbe0718e2..55cc730fb7699ab06d87e8405c5fed6cc198e827 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for mail-client/claws-mail
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/ChangeLog,v 1.13 2007/02/07 20:34:14 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/ChangeLog,v 1.14 2007/02/27 19:58:40 ticho Exp $
+
+*claws-mail-2.8.0 (27 Feb 2007)
+
+  27 Feb 2007; Andrej Kacian <ticho@gentoo.org> +claws-mail-2.8.0.ebuild:
+  Version bump.
 
   07 Feb 2007; Simon Stelling <blubb@gentoo.org> claws-mail-2.6.1.ebuild:
   stable on amd64; bug 163611
diff --git a/mail-client/claws-mail/claws-mail-2.8.0.ebuild b/mail-client/claws-mail/claws-mail-2.8.0.ebuild
new file mode 100644 (file)
index 0000000..c8cb30e
--- /dev/null
@@ -0,0 +1,178 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/claws-mail-2.8.0.ebuild,v 1.1 2007/02/27 19:58:40 ticho Exp $
+
+IUSE="gnome dillo crypt spell ssl ldap ipv6 pda clamav xface kde imap spamassassin doc startup-notification bogofilter"
+
+inherit eutils
+
+DESCRIPTION="Claws-Mail is an email client (and news reader) based on GTK+"
+HOMEPAGE="http://www.claws-mail.org"
+
+if [ -n "${P/*_rc*/}" ]; then
+       SRC_URI="mirror://sourceforge/sylpheed-claws/${P}.tar.bz2"
+else
+       MY_P="${P/_/-}"
+       S="${WORKDIR}/${MY_P}"
+       SRC_URI="http://www.claws-mail.org/snapshots/${MY_P}.tar.bz2"
+fi
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+COMMONDEPEND=">=x11-libs/gtk+-2.6
+       pda? ( >=app-pda/jpilot-0.99 )
+       ssl? ( >=dev-libs/openssl-0.9.7 )
+       ldap? ( >=net-nds/openldap-2.0.7 )
+       crypt? ( >=app-crypt/gpgme-1.1.1 )
+       dillo? ( www-client/dillo )
+       spell? ( virtual/aspell-dict )
+       clamav? ( app-antivirus/clamav )
+       kde? ( kde-base/kdelibs )
+       imap? ( >=net-libs/libetpan-0.49 )
+       gnome? ( >=gnome-base/libgnomeprintui-2.2 )
+       startup-notification? ( x11-libs/startup-notification )
+       bogofilter? ( mail-filter/bogofilter )
+       !<mail-client/sylpheed-claws-2.6.1"     # old name, block as user hint and due to some file collision
+
+DEPEND="${COMMONDEPEND}
+       xface? ( >=media-libs/compface-1.4 )
+       >=sys-apps/sed-4
+       dev-util/pkgconfig"
+
+RDEPEND="${COMMONDEPEND}
+       app-misc/mime-types
+       x11-misc/shared-mime-info"
+
+PLUGIN_NAMES="acpi-notifier att-remover cachesaver etpan-privacy fetchinfo gtkhtml maildir mailmbox newmail notification pdf-viewer perl rssyl smime synce vcalendar"
+
+src_compile() {
+       local myconf
+
+       # Optional features
+       myconf="${myconf} `use_enable gnome gnomeprint`"
+       myconf="${myconf} `use_enable imap libetpan`"
+       myconf="${myconf} `use_enable ipv6`"
+       myconf="${myconf} `use_enable ldap`"
+       myconf="${myconf} `use_enable pda jpilot`"
+       myconf="${myconf} `use_enable spell aspell`"
+       myconf="${myconf} `use_enable ssl openssl`"
+       myconf="${myconf} `use_enable xface compface`"
+       myconf="${myconf} `use_enable doc manual`"
+       myconf="${myconf} `use_enable startup-notification`"
+
+       # Optional plugins
+       myconf="${myconf} `use_enable clamav clamav-plugin`"
+       myconf="${myconf} `use_enable crypt pgpmime-plugin`"
+       myconf="${myconf} `use_enable crypt pgpinline-plugin`"
+       myconf="${myconf} `use_enable crypt pgpcore-plugin`"
+       myconf="${myconf} `use_enable dillo dillo-viewer-plugin`"
+       myconf="${myconf} `use_enable spamassassin spamassassin-plugin`"
+       myconf="${myconf} `use_enable bogofilter bogofilter-plugin`"
+
+       econf \
+               --enable-trayicon-plugin \
+               ${myconf} || die "./configure failed"
+
+       emake || die
+}
+
+src_install() {
+       make DESTDIR=${D} install || die
+
+       # Makefile install claws-mail.png in /usr/share/icons/hicolor/48x48/apps
+       # => also install it in /usr/share/pixmaps for other desktop envs
+       # => also install higher resolution icons in /usr/share/icons/hicolor/...
+       insinto /usr/share/pixmaps
+       doins ${PN}.png || die
+       local res resdir
+       for res in 64x64 128x128 ; do
+               resdir="/usr/share/icons/hicolor/${res}/apps"
+               insinto ${resdir}
+               newins ${PN}-${res}.png ${PN}.png || die
+       done
+
+       dodoc AUTHORS ChangeLog* INSTALL* NEWS README* TODO*
+       docinto tools
+       dodoc tools/README*
+
+       insinto /usr/share/applications
+       doins ${PN}.desktop
+
+       einfo "Installing extra tools"
+       cd ${S}/tools
+       exeinto /usr/lib/${PN}/tools
+       doexe *.pl *.py *.rc *.conf *.sh || die
+       doexe tb2claws-mail update-po uudec uuooffice || die
+
+       if use kde; then
+               einfo "Installing kde service scripts"
+               local kdeprefix="$(kde-config --prefix)"
+               local servicescript="${PN}-kdeservicemenu.pl"
+               local desktopfile="${PN}-attach-files.desktop"
+               cd ${S}/tools/kdeservicemenu
+               sed -i -e "s:SCRIPT_PATH:${kdeprefix}/bin/${servicescript}:g" \
+                       template_${desktopfile}
+               dodir /usr/share/apps/konqueror/servicemenus
+               insopts -m 0644
+               insinto /usr/share/apps/konqueror/servicemenus
+               newins template_${desktopfile} ${desktopfile} || die
+               dodir ${kdeprefix}/bin
+               insopts -m 755
+               insinto ${kdeprefix}/bin
+               doexe ${servicescript} || die
+       fi
+
+       # kill useless plugin files
+       rm -f ${D}/usr/lib*/${PN}/plugins/*.{la,a}
+}
+
+pkg_postinst() {
+       gtk-update-icon-cache -f -t ${ROOT}/usr/share/icons/hicolor
+
+       UPDATE_PLUGINS=""
+       RENAME_PLUGINS=""
+       for x in ${PLUGIN_NAMES}; do
+               has_version mail-client/${PN}-$x && UPDATE_PLUGINS="${UPDATE_PLUGINS} $x"
+               has_version mail-client/sylpheed-claws-$x && RENAME_PLUGINS="${RENAME_PLUGINS} $x"
+       done
+       if [ -n "${RENAME_PLUGINS}" ]; then
+               ewarn
+               ewarn "The following sylpheed-claws plugins were found on your system:"
+               ewarn
+               for x in ${RENAME_PLUGINS}; do
+                       ewarn "    mail-client/sylpheed-claws-$x"
+               done
+               ewarn
+               ewarn "If you want to continue using those you need to merge their "
+               ewarn "renamed counterparts:"
+               ewarn
+               for x in ${RENAME_PLUGINS}; do
+                       ewarn "    mail-client/${PN}-$x"
+               done
+               ewarn
+       fi
+       if [ -n "${UPDATE_PLUGINS}" ]; then
+               ewarn
+               ewarn "You have to re-emerge or update the following plugins:"
+               ewarn
+               for x in ${UPDATE_PLUGINS}; do
+                       ewarn "    mail-client/${PN}-$x"
+               done
+               ewarn
+       fi
+       if [ -n "${RENAME_PLUGINS}${UPDATE_PLUGINS}" ]; then
+               elog
+               elog "You can use"
+               elog "    /bin/bash ${FILESDIR}/plugins-rebuild.sh"
+               elog "to automatically handle this."
+               elog
+               epause 5
+               ebeep 3
+       fi
+}
+
+pkg_postrm() {
+       gtk-update-icon-cache -f -t /usr/share/icons/hicolor
+}
diff --git a/mail-client/claws-mail/files/digest-claws-mail-2.8.0 b/mail-client/claws-mail/files/digest-claws-mail-2.8.0
new file mode 100644 (file)
index 0000000..419c97b
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 c3f6ed9c639dbe7a8f36ecb0d8f59797 claws-mail-2.8.0.tar.bz2 5355816
+RMD160 e4436e92ab780554433ee637e14d1f72eb85712f claws-mail-2.8.0.tar.bz2 5355816
+SHA256 016d496f2b8cf82e1c5352a3ca4428af9370f83e172d9257c13e2c407d679dcc claws-mail-2.8.0.tar.bz2 5355816