depend on >=portage-2.1.2 to make sure the assembler USE flags are unmasked on amd64
authorSimon Stelling <blubb@gentoo.org>
Fri, 16 Feb 2007 12:13:40 +0000 (12:13 +0000)
committerSimon Stelling <blubb@gentoo.org>
Fri, 16 Feb 2007 12:13:40 +0000 (12:13 +0000)
Package-Manager: portage-2.1.2-r9

media-video/mplayer/ChangeLog
media-video/mplayer/mplayer-1.0_rc1-r2.ebuild

index e128c0b610f4ee305db4db86d825da5199c7ba39..f734f09ee7ec9336fb560f91755112e35e5394b7 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for media-video/mplayer
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.459 2007/02/13 09:01:38 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.460 2007/02/16 12:13:40 blubb Exp $
+
+  16 Feb 2007; Simon Stelling <blubb@gentoo.org> mplayer-1.0_rc1-r2.ebuild:
+  depend on >=portage-2.1.2 to make sure the assembler USE flags are unmasked
+  on amd64
 
   13 Feb 2007; Markus Rothe <corsair@gentoo.org> mplayer-1.0_rc1-r2.ebuild:
   Stable on ppc64; bug #159727
index f1ed70cb3957af064424f8cf79ad151c3c027653..1fec6e61291b76a261d09c5e1d532d81b17ff826 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_rc1-r2.ebuild,v 1.10 2007/02/13 09:01:38 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_rc1-r2.ebuild,v 1.11 2007/02/16 12:13:40 blubb Exp $
 
 inherit eutils flag-o-matic
 
@@ -122,6 +122,9 @@ DEPEND="${RDEPEND}
        X? ( x11-proto/xextproto
                 x11-proto/xf86vidmodeproto )
        iconv? ( virtual/libiconv )"
+# Make sure the assembler USE flags are unmasked on amd64
+# Remove this once default-linux/amd64/2006.1 is deprecated
+DEPEND="${DEPEND} amd64? ( >=sys-apps/portage-2.1.2 )"
 
 SLOT="0"
 LICENSE="GPL-2"
@@ -379,19 +382,12 @@ src_compile() {
        # Platform specific flags, hardcoded on amd64 (see below)
        myconf="${myconf} $(use_enable 3dnow)"
        myconf="${myconf} $(use_enable 3dnowext)";
-       use x86 && myconf="${myconf} $(use_enable sse)"
-       use x86 && myconf="${myconf} $(use_enable sse2)"
-       use x86 && myconf="${myconf} $(use_enable mmx)"
+       myconf="${myconf} $(use_enable sse)"
+       myconf="${myconf} $(use_enable sse2)"
+       myconf="${myconf} $(use_enable mmx)"
        myconf="${myconf} $(use_enable mmxext)"
        use debug && myconf="${myconf} --enable-debug=3"
 
-       # mplayer now contains SIMD assembler code for amd64
-       # AMD64 Team decided to hardenable SIMD assembler for all users
-       # Danny van Dyk <kugelfang@gentoo.org> 2005/01/11
-       if use amd64; then
-               myconf="${myconf} --enable-sse --enable-sse2 --enable-mmx"
-       fi
-
        if use ppc64
        then
                myconf="${myconf} --disable-altivec"