sys-power/powertop: Version bump to 2.11
authorMatt Turner <mattst88@gentoo.org>
Sun, 23 Feb 2020 17:39:56 +0000 (09:39 -0800)
committerMatt Turner <mattst88@gentoo.org>
Sun, 23 Feb 2020 17:55:24 +0000 (09:55 -0800)
Closes: https://bugs.gentoo.org/710568
Signed-off-by: Matt Turner <mattst88@gentoo.org>
sys-power/powertop/Manifest
sys-power/powertop/powertop-2.11.ebuild [new file with mode: 0644]

index b1fe3aade121c8f38a063b6398722cf43c348abe..f033f60ac9483219c70d845e82c90b32be62e176 100644 (file)
@@ -1 +1,2 @@
+DIST powertop-2.11.tar.gz 307755 BLAKE2B 01723262922df5cc2ec63f6972b2a301f7efc4c701dfa3c08280dcdaa4b79f2d04503592f8c17e43d77df89e7f08695b0381f498671969fe4aa388578f732978 SHA512 bbe2882196f1b3ae39885d38dd86018576bfac5b5e8f16ea10c7dfd197197d0493ae4ce83c969417a4c4239c41dbcfada989063f14e2943c088a7489e43953b7
 DIST powertop-v2.10.tar.gz 722992 BLAKE2B 573f1f0ed40705d3463f6e6f76c67ae99127ab2541b851143dafa707ef1c2dab4127d27811b63ad27e6b002ea4efd39417297a0227996ad9b01141b6de733d41 SHA512 4219e7aadbeebdf6932c04f784434e4dd0f540bf4941d43c1830b1b5cad1f3928769b13897e24dd956b6bdee65fb1fbe902ee30685bca229b71e140d65367837
diff --git a/sys-power/powertop/powertop-2.11.ebuild b/sys-power/powertop/powertop-2.11.ebuild
new file mode 100644 (file)
index 0000000..200e2c0
--- /dev/null
@@ -0,0 +1,118 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/fenrus75/powertop.git"
+
+if [[ ${PV} == "9999" ]] ; then
+       GIT_ECLASS="git-r3"
+       SRC_URI=""
+else
+       SRC_URI="https://github.com/fenrus75/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+inherit autotools ${GIT_ECLASS} linux-info
+
+DESCRIPTION="tool to diagnose issues with power consumption and power management"
+HOMEPAGE="https://01.org/powertop/ https://github.com/fenrus75/powertop/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls unicode X"
+
+DEPEND="
+       dev-libs/libnl:3
+       sys-apps/pciutils
+       sys-libs/ncurses:=[unicode?]
+"
+
+BDEPEND="
+       virtual/pkgconfig
+       sys-devel/gettext
+"
+RDEPEND="
+       ${DEPEND}
+       X? ( x11-apps/xset )
+       virtual/libintl
+"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.8-ncurses_tinfo.patch
+)
+
+pkg_setup() {
+       CONFIG_CHECK="
+               ~X86_MSR
+               ~DEBUG_FS
+               ~PERF_EVENTS
+               ~TRACEPOINTS
+               ~NO_HZ_IDLE
+               ~HIGH_RES_TIMERS
+               ~HPET_TIMER
+               ~CPU_FREQ_STAT
+               ~CPU_FREQ_GOV_ONDEMAND
+               ~FTRACE
+               ~BLK_DEV_IO_TRACE
+               ~TRACING
+       "
+       ERROR_KERNEL_X86_MSR="X86_MSR is not enabled in the kernel, you almost certainly need it"
+       ERROR_KERNEL_DEBUG_FS="DEBUG_FS is not enabled in the kernel, you almost certainly need it"
+       ERROR_KERNEL_PERF_EVENTS="PERF_EVENTS should be enabled in the kernel for full powertop function"
+       ERROR_KERNEL_TRACEPOINTS="TRACEPOINTS should be enabled in the kernel for full powertop function"
+       ERROR_KERNEL_NO_HZ_IDLE="NO_HZ_IDLE should be enabled in the kernel for full powertop function"
+       ERROR_KERNEL_HIGH_RES_TIMERS="HIGH_RES_TIMERS should be enabled in the kernel for full powertop function"
+       ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
+       ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
+       ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
+       ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
+       ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable other config options"
+       ERROR_KERNEL_TRACING="TRACING should be enabled in the kernel for full powertop function"
+       linux-info_pkg_setup
+       if linux_config_exists; then
+               if kernel_is -lt 3 7 0; then
+                       if linux_chkconfig_present SND_HDA_INTEL; then
+                               CONFIG_CHECK="~SND_HDA_POWER_SAVE"
+                               ERROR_KERNEL_SND_HDA_POWER_SAVE="SND_HDA_POWER_SAVE should be enabled in the kernel for full powertop function"
+                               check_extra_config
+                       fi
+               fi
+               if kernel_is -lt 3 9 0; then
+                       CONFIG_CHECK="~EVENT_POWER_TRACING_DEPRECATED"
+                       ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
+                       check_extra_config
+               fi
+               if kernel_is -lt 3 19; then
+                       CONFIG_CHECK="~PM_RUNTIME"
+                       ERROR_KERNEL_PM_RUNTIME="PM_RUNTIME should be enabled in the kernel for full powertop function"
+                       check_extra_config
+               else
+                       CONFIG_CHECK="~PM"
+                       ERROR_KERNEL_PM="PM should be enabled in the kernel for full powertop function"
+                       check_extra_config
+               fi
+               if kernel_is -lt 4 11; then
+                       CONFIG_CHECK="~TIMER_STATS"
+                       ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
+                       check_extra_config
+               fi
+       fi
+}
+
+src_prepare() {
+       default
+
+       # Bug 599114
+       sed -i '1s|^|AX_REQUIRE_DEFINED([AX_CXX_COMPILE_STDCXX_11])|' configure.ac || die
+
+       chmod +x scripts/version || die "Failed to make 'scripts/version' executable"
+       scripts/version || die "Failed to extract version information"
+
+       eautoreconf
+}
+
+src_configure() {
+       export ac_cv_search_delwin=$(usex unicode -lncursesw -lncurses)
+       econf $(use_enable nls)
+}