net-misc/chrome-remote-desktop: version bump to 77.0.3865.32
authorMike Frysinger <vapier@gentoo.org>
Sat, 14 Sep 2019 07:08:53 +0000 (03:08 -0400)
committerMike Frysinger <vapier@gentoo.org>
Sat, 14 Sep 2019 07:10:55 +0000 (03:10 -0400)
Closes: https://bugs.gentoo.org/675352
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
net-misc/chrome-remote-desktop/Manifest
net-misc/chrome-remote-desktop/chrome-remote-desktop-77.0.3865.32.ebuild [new file with mode: 0644]

index c84053c0bfdb5d2865c7760c6aeab4a882f73fb3..ace541f20a666c52243550a378516735bddee9f6 100644 (file)
@@ -1 +1,2 @@
 DIST chrome-remote-desktop_63.0.3239.17_amd64.deb 19026074 BLAKE2B 9a62d317768d6c0ab3cf3c6e7c5dea074133cc7c5d2b04ffdc1e0f9877f5f606c044ebab7b230914eba2ade51d2805fb1267f7b1731fa36235495a8192eb3c48 SHA512 2843deb7817217c8b8e41931b1e9ef0fdfb40c6a4ceb1bc69499aed16cc729d7ed64f88200c9bb2366a768f294a164da2360ed2b9654d1626696bcf0403e347a
+DIST chrome-remote-desktop_77.0.3865.32_amd64.deb 35724698 BLAKE2B 25828e144d88072fde7a7e50cd278df1a90b94e0281038239d67e2369eaf93e82897cbda4624cffe34f045b185437a892671541eeb685b80a912733380e3afb8 SHA512 1181592536b9313ca136ce280c8349e3d7325b2bfa116714adc4fcb4d4b4f8659cb53cba134d2476b696fa73f55eefbc0a255f6cc76fb1a93eecfff42eb1d425
diff --git a/net-misc/chrome-remote-desktop/chrome-remote-desktop-77.0.3865.32.ebuild b/net-misc/chrome-remote-desktop/chrome-remote-desktop-77.0.3865.32.ebuild
new file mode 100644 (file)
index 0000000..8703e9d
--- /dev/null
@@ -0,0 +1,136 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Base URL: https://dl.google.com/linux/chrome-remote-desktop/deb/
+# Fetch the Release file:
+#  https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/Release
+# Which gives you the Packages file:
+#  https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/main/binary-i386/Packages
+#  https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/main/binary-amd64/Packages
+# And finally gives you the file name:
+#  pool/main/c/chrome-remote-desktop/chrome-remote-desktop_29.0.1547.32_amd64.deb
+#
+# Use curl to find the answer:
+#  curl -q https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/main/binary-amd64/Packages | grep ^Filename
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 )
+PLOCALES="am ar bg bn ca cs da de el en_GB en es_419 es et fa fil fi fr gu he hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt_BR pt_PT ro ru sk sl sr sv sw ta te th tr uk vi zh_CN zh_TW"
+
+inherit unpacker eutils python-single-r1 l10n
+
+DESCRIPTION="access remote computers via Chrome!"
+PLUGIN_URL="https://chrome.google.com/remotedesktop"
+HOMEPAGE="https://support.google.com/chrome/answer/1649523 ${PLUGIN_URL}"
+BASE_URI="https://dl.google.com/linux/chrome-remote-desktop/deb/pool/main/c/${PN}/${PN}_${PV}"
+SRC_URI="amd64? ( ${BASE_URI}_amd64.deb )"
+
+LICENSE="google-chrome"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="xrandr"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# All the libs this package links against.
+RDEPEND="app-admin/sudo
+       ${PYTHON_DEPS}
+       >=dev-libs/expat-2
+       dev-libs/glib:2
+       dev-libs/nspr
+       dev-libs/nss
+       dev-python/psutil
+       gnome-base/gconf:2
+       media-libs/fontconfig
+       media-libs/freetype:2
+       sys-devel/gcc
+       sys-libs/glibc
+       sys-libs/pam
+       x11-apps/xdpyinfo
+       x11-apps/setxkbmap
+       x11-libs/cairo
+       x11-libs/gtk+:2
+       x11-libs/libX11
+       x11-libs/libXdamage
+       x11-libs/libXext
+       x11-libs/libXfixes
+       x11-libs/libXi
+       x11-libs/libXrandr
+       x11-libs/libXtst
+       x11-libs/pango"
+# Settings we just need at runtime.
+# TODO: Look at switching to xf86-video-dummy & xf86-input-void instead of xvfb.
+# - The env var (CHROME_REMOTE_DESKTOP_USE_XORG) seems to be stripped before being checked.
+# - The Xorg invocation uses absolute paths with -logfile & -config which are rejected.
+# - The config takes over the active display in addition to starting up a virtual one.
+RDEPEND+="
+       xrandr? ( x11-apps/xrandr )
+       x11-base/xorg-server[xvfb]"
+DEPEND=""
+
+S=${WORKDIR}
+
+QA_PREBUILT="/opt/google/chrome-remote-desktop/*"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-44.0.2403.44-always-sudo.patch #541708
+)
+
+src_prepare() {
+       default
+
+       gunzip usr/share/doc/${PN}/*.gz || die
+
+       cd opt/google/chrome-remote-desktop
+       python_fix_shebang chrome-remote-desktop
+
+       cd remoting_locales
+       rm fake-bidi* || die
+       PLOCALES=${PLOCALES//_/-} l10n_find_plocales_changes "${PWD}" '' '.pak'
+}
+
+src_install() {
+       pushd opt/google/chrome-remote-desktop/remoting_locales >/dev/null || die
+       rm_pak() { local l=${1//_/-}; rm "${l}.pak" "${l}.pak.info"; }
+       l10n_for_each_disabled_locale_do rm_pak
+       popd >/dev/null
+
+       insinto /etc
+       doins -r etc/opt
+       dosym ../opt/chrome/native-messaging-hosts /etc/chromium/native-messaging-hosts #581754
+
+       insinto /opt
+       doins -r opt/google
+       chmod a+rx "${ED}"/opt/google/${PN}/* || die
+       fperms +s /opt/google/${PN}/user-session
+
+       dodir /etc/pam.d
+       dosym system-remote-login /etc/pam.d/${PN}
+
+       dodoc usr/share/doc/${PN}/changelog*
+
+       newinitd "${FILESDIR}"/${PN}.rc ${PN}
+       newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
+}
+
+pkg_postinst() {
+       if [[ -z ${REPLACING_VERSIONS} ]] ; then
+               elog "Two ways to launch the server:"
+               elog "(1) access an existing desktop"
+               elog "    (a) install the Chrome plugin on the server & client:"
+               elog "        ${PLUGIN_URL}"
+               elog "    (b) on the server, run the Chrome plugin & enable remote access"
+               elog "    (c) on the client, connect to the server"
+               elog "(2) headless system"
+               elog "    (a) install the Chrome plugin on the client:"
+               elog "        ${PLUGIN_URL}"
+               elog "    (b) run ${EPREFIX}opt/google/chrome-remote-desktop/start-host --help to get the auth URL"
+               elog "    (c) when it redirects you to a blank page, look at the URL for a code=XXX field"
+               elog "    (d) run start-host again, and past the code when asked for an authorization code"
+               elog "    (e) on the client, connect to the server"
+               elog
+               elog "Configuration settings you might want to be aware of:"
+               elog "  ~/.${PN}-session - shell script to start your session"
+               elog "  /etc/init.d/${PN} - script to auto-restart server"
+       fi
+}