sys-cluster/ceph-14.2.8: version bump
authorPatrick McLean <patrick.mclean@sony.com>
Thu, 5 Mar 2020 01:11:29 +0000 (17:11 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 5 Mar 2020 01:17:36 +0000 (17:17 -0800)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
sys-cluster/ceph/Manifest
sys-cluster/ceph/ceph-14.2.8.ebuild [new file with mode: 0644]
sys-cluster/ceph/files/ceph-14.2.8-boost-sonames.patch [new file with mode: 0644]

index 5bc6a05232c55a45b4ab594e84b9c839e550a4e1..f6b72a26254e50b5b7ff3e836698cef8889d71e2 100644 (file)
@@ -1,2 +1,3 @@
 DIST ceph-12.2.12.tar.gz 77467762 BLAKE2B a5224432121db9ef49c1e22771d847399df2f7881cd9c2e185eca12096efb79d21578659d248eb5bae678924983d57452d370e23ab7e78663764d7bea834a461 SHA512 e694c9a8c1f9836c08fb74b54423bdc16d4900252e34643c56cf1a615d4dacddfb13df06a6a9f68bb9d438f5f07069ed358f9fa4b5a362640a3046f9c7722dcc
 DIST ceph-14.2.7.tar.gz 116647114 BLAKE2B f6971324b0467cfdb863db553b6feacaf3607b14fb9adae2808bd6e5514fc5ce218482c412b80902c22a74b883ed697f2c126bc687c8733a83de5b970593efa2 SHA512 59f475e56053ba5e7e3a482a3a91b4d44272e6ec8051b92783de76c09c0d967a7ef76676db998968a709e48f08e90828dd8f86bd96a7c3fd111d48bfb7fd93b1
+DIST ceph-14.2.8.tar.gz 128415417 BLAKE2B bb3644938106aaefe17d29fd6adc8568a35e6aef799da048add5ecebb6fb0128a8575eba1f5ecc2f33f33caf2130619e5b6979a6291566e0971976d8da0e8387 SHA512 38b0c6df58579377528c8f8e06d0cbc40f471f6eb2fb4a05b395f6fddbd3f2117674545b2147d8730973b01967ddcd4322a769ba03f9c625417ed35cc39f195a
diff --git a/sys-cluster/ceph/ceph-14.2.8.ebuild b/sys-cluster/ceph/ceph-14.2.8.ebuild
new file mode 100644 (file)
index 0000000..287059a
--- /dev/null
@@ -0,0 +1,367 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+CMAKE_MAKEFILE_GENERATOR=emake
+
+DISTUTILS_OPTIONAL=1
+
+inherit check-reqs bash-completion-r1 cmake-utils distutils-r1 flag-o-matic \
+               multiprocessing python-r1 udev readme.gentoo-r1 toolchain-funcs \
+               systemd
+
+if [[ ${PV} == *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/ceph/ceph.git"
+       SRC_URI=""
+else
+       SRC_URI="https://download.ceph.com/tarballs/${P}.tar.gz"
+       KEYWORDS="~amd64 ~ppc64"
+fi
+
+DESCRIPTION="Ceph distributed filesystem"
+HOMEPAGE="https://ceph.com/"
+
+LICENSE="LGPL-2.1 CC-BY-SA-3.0 GPL-2 GPL-2+ LGPL-2+ BSD Boost-1.0 MIT public-domain"
+SLOT="0"
+
+CPU_FLAGS_X86=(sse{,2,3,4_1,4_2} ssse3)
+
+IUSE="babeltrace +cephfs dpdk fuse grafana jemalloc kerberos ldap libressl"
+IUSE+=" lttng +mgr numa rabbitmq +radosgw +ssl spdk static-libs system-boost"
+IUSE+=" systemd +tcmalloc test xfs zfs"
+IUSE+=" $(printf "cpu_flags_x86_%s\n" ${CPU_FLAGS_X86[@]})"
+
+COMMON_DEPEND="
+       acct-group/ceph
+       acct-user/ceph
+       virtual/libudev:=
+       app-arch/bzip2:=[static-libs?]
+       app-arch/lz4:=[static-libs?]
+       app-arch/snappy:=[static-libs(-)?]
+       app-arch/zstd:=[static-libs?]
+       app-shells/bash:0
+       app-misc/jq:=[static-libs?]
+       dev-libs/crypto++:=[static-libs?]
+       dev-libs/leveldb:=[snappy,static-libs?,tcmalloc(-)?]
+       dev-libs/libaio:=[static-libs?]
+       dev-libs/libnl:3=[static-libs?]
+       dev-libs/libxml2:=[static-libs?]
+       dev-libs/nss:=
+       sys-auth/oath-toolkit:=
+       sys-apps/coreutils
+       sys-apps/grep
+       sys-apps/keyutils:=[static-libs?]
+       sys-apps/util-linux:=[static-libs?]
+       sys-apps/sed
+       sys-apps/util-linux
+       sys-libs/libcap-ng:=[static-libs?]
+       sys-libs/ncurses:0=[static-libs?]
+       sys-libs/zlib:=[static-libs?]
+       babeltrace? ( dev-util/babeltrace )
+       ldap? ( net-nds/openldap:=[static-libs?] )
+       lttng? ( dev-util/lttng-ust:= )
+       fuse? ( sys-fs/fuse:0=[static-libs?] )
+       kerberos? ( virtual/krb5 )
+       rabbitmq? ( net-libs/rabbitmq-c:=[static-libs?] )
+       ssl? (
+               !libressl? ( dev-libs/openssl:=[static-libs?] )
+               libressl? ( dev-libs/libressl:=[static-libs?] )
+       )
+       xfs? ( sys-fs/xfsprogs:=[static-libs(+)?] )
+       zfs? ( sys-fs/zfs:=[static-libs?] )
+       radosgw? (
+               dev-libs/expat:=[static-libs?]
+               !libressl? (
+                       dev-libs/openssl:=[static-libs?]
+                       net-misc/curl:=[curl_ssl_openssl,static-libs?]
+               )
+               libressl? (
+                       dev-libs/libressl:=[static-libs?]
+                       net-misc/curl:=[curl_ssl_libressl,static-libs?]
+               )
+       )
+       system-boost? ( =dev-libs/boost-1.72*[threads,context,python,static-libs?,${PYTHON_USEDEP}] )
+       jemalloc? ( dev-libs/jemalloc:=[static-libs?] )
+       !jemalloc? ( >=dev-util/google-perftools-2.6.1:=[static-libs?] )
+       ${PYTHON_DEPS}
+"
+BDEPEND="
+       amd64? ( dev-lang/yasm )
+       x86? ( dev-lang/yasm )
+       app-arch/cpio
+       >=dev-util/cmake-3.5.0
+       dev-python/cython[${PYTHON_USEDEP}]
+       dev-python/sphinx
+       dev-util/cunit
+       dev-util/gperf
+       dev-util/valgrind
+       sys-apps/coreutils
+       sys-apps/findutils
+       sys-apps/grep
+       sys-apps/sed
+       sys-apps/which
+       sys-devel/bc
+       sys-devel/patch
+       virtual/pkgconfig
+       test? (
+               dev-python/coverage[${PYTHON_USEDEP}]
+               dev-python/virtualenv[${PYTHON_USEDEP}]
+               dev-python/requests-mock[${PYTHON_USEDEP}]
+               sys-apps/grep[pcre]
+               sys-fs/btrfs-progs
+       )
+"
+RDEPEND="${COMMON_DEPEND}
+       net-misc/socat
+       sys-apps/gptfdisk
+       sys-block/parted
+       sys-fs/cryptsetup
+       sys-fs/lvm2[-device-mapper-only(-)]
+       sys-fs/lsscsi
+       virtual/awk
+       dev-python/bcrypt[${PYTHON_USEDEP}]
+       dev-python/cherrypy[${PYTHON_USEDEP}]
+       dev-python/flask[${PYTHON_USEDEP}]
+       dev-python/jinja[${PYTHON_USEDEP}]
+       dev-python/pecan[${PYTHON_USEDEP}]
+       dev-python/prettytable[${PYTHON_USEDEP}]
+       dev-python/pyopenssl[${PYTHON_USEDEP}]
+       dev-python/requests[${PYTHON_USEDEP}]
+       dev-python/werkzeug[${PYTHON_USEDEP}]
+       mgr? (
+               dev-python/more-itertools[${PYTHON_USEDEP}]
+               dev-python/pyjwt[${PYTHON_USEDEP}]
+               dev-python/pyyaml[${PYTHON_USEDEP}]
+               dev-python/routes[${PYTHON_USEDEP}]
+               dev-python/six[${PYTHON_USEDEP}]
+       )
+"
+REQUIRED_USE="
+       ${PYTHON_REQUIRED_USE}
+       mgr? ( cephfs )
+       ?? ( jemalloc tcmalloc )
+       rabbitmq? ( radosgw )
+"
+
+# the tests need root access
+RESTRICT="test? ( userpriv )"
+
+# distribution tarball does not include everything needed for tests
+RESTRICT+=" test"
+
+# false positives unless all USE flags are on
+CMAKE_WARN_UNUSED_CLI="no"
+
+PATCHES=(
+       "${FILESDIR}/ceph-12.2.0-use-provided-cpu-flag-values.patch"
+       "${FILESDIR}/ceph-14.2.0-cflags.patch"
+       "${FILESDIR}/ceph-12.2.4-boost-build-none-options.patch"
+       "${FILESDIR}/ceph-13.2.0-cflags.patch"
+       "${FILESDIR}/ceph-14.2.0-mgr-python-version.patch"
+       "${FILESDIR}/ceph-14.2.5-no-virtualenvs.patch"
+       "${FILESDIR}/ceph-13.2.2-dont-install-sysvinit-script.patch"
+       "${FILESDIR}/ceph-14.2.0-dpdk-cflags.patch"
+       "${FILESDIR}/ceph-14.2.0-link-crc32-statically.patch"
+       "${FILESDIR}/ceph-14.2.0-cython-0.29.patch"
+       "${FILESDIR}/ceph-14.2.3-dpdk-compile-fix-1.patch"
+       "${FILESDIR}/ceph-14.2.4-python-executable.patch"
+       "${FILESDIR}/ceph-14.2.4-undefined-behaviour.patch"
+)
+
+check-reqs_export_vars() {
+       if use amd64; then
+               CHECKREQS_DISK_BUILD="12G"
+               CHECKREQS_DISK_USR="460M"
+       else
+               CHECKREQS_DISK_BUILD="1400M"
+               CHECKREQS_DISK_USR="450M"
+       fi
+
+       export CHECKREQS_DISK_BUILD CHECKREQS_DISK_USR
+}
+
+pkg_pretend() {
+       check-reqs_export_vars
+       check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+       python_setup 'python3*'
+       check-reqs_export_vars
+       check-reqs_pkg_setup
+}
+
+src_prepare() {
+       cmake-utils_src_prepare
+
+       if use system-boost; then
+               eapply "${FILESDIR}/ceph-14.2.8-boost-sonames.patch"
+
+               find "${S}" -name '*.cmake' -or -name 'CMakeLists.txt' -print0 \
+                       | xargs --null sed \
+                       -e 's|Boost::|Boost_|g' \
+                       -e 's|Boost_boost|boost_system|g' -i || die
+       fi
+
+       sed -i -r "s:DESTINATION .+\\):DESTINATION $(get_bashcompdir)\\):" \
+               src/bash_completion/CMakeLists.txt || die
+
+       # remove tests that need root access
+       rm src/test/cli/ceph-authtool/cap*.t || die
+}
+
+ceph_src_configure() {
+       local flag
+       local mycmakeargs=(
+               -DWITH_BABELTRACE=$(usex babeltrace)
+               -DWITH_CEPHFS=$(usex cephfs)
+               -DWITH_CEPHFS_SHELL=$(if python_is_python3; then usex cephfs; else echo OFF; fi)
+               -DWITH_DPDK=$(usex dpdk)
+               -DWITH_DPDK=$(usex spdk)
+               -DWITH_FUSE=$(usex fuse)
+               -DWITH_LTTNG=$(usex lttng)
+               -DWITH_GSSAPI=$(usex kerberos)
+               -DWITH_GRAFANA=$(usex grafana)
+               -DWITH_MGR=$(usex mgr)
+               -DWITH_MGR_DASHBOARD_FRONTEND=NO
+               -DWITH_NUMA=$(usex numa)
+               -DWITH_OPENLDAP=$(usex ldap)
+               -DMGR_PYTHON_VERSION=$(if python_is_python3; then echo 3; else echo 2; fi)
+               -DWITH_PYTHON3=$(if python_is_python3; then echo "ON"; else echo "OFF"; fi)
+               -DWITH_PYTHON2=$(if python_is_python3; then echo "OFF"; else echo "ON"; fi)
+               -DWITH_RADOSGW=$(usex radosgw)
+               -DWITH_RADOSGW_AMQP_ENDPOINT=$(usex rabbitmq)
+               -DWITH_SSL=$(usex ssl)
+               -DWITH_SYSTEMD=$(usex systemd)
+               -DWITH_TESTS=$(usex test)
+               -DWITH_XFS=$(usex xfs)
+               -DWITH_ZFS=$(usex zfs)
+               -DENABLE_SHARED=$(usex static-libs '' 'ON' 'OFF')
+               -DALLOCATOR=$(usex tcmalloc 'tcmalloc' "$(usex jemalloc 'jemalloc' 'libc')")
+               -DWITH_SYSTEM_BOOST=$(usex system-boost)
+               -DBOOST_J=$(makeopts_jobs)
+               -DWITH_RDMA=no
+               -DWITH_TBB=no
+               -DSYSTEMD_UNITDIR=$(systemd_get_systemunitdir)
+               -DEPYTHON_VERSION="${EPYTHON#python}"
+               -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PN}-${PVR}"
+               -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
+               #-Wno-dev
+       )
+       if use amd64 || use x86; then
+               for flag in ${CPU_FLAGS_X86[@]}; do
+                       mycmakeargs+=("$(usex cpu_flags_x86_${flag} "-DHAVE_INTEL_${flag^^}=1")")
+               done
+       fi
+
+       rm -f "${BUILD_DIR:-${S}}/CMakeCache.txt" \
+               || die "failed to remove cmake cache"
+
+       cmake-utils_src_configure
+
+       # bug #630232
+       sed -i "s:\"${T//:\\:}/${EPYTHON}/bin/python\":\"${PYTHON}\":" \
+               "${BUILD_DIR:-${S}}"/include/acconfig.h \
+               || die "sed failed"
+}
+
+src_configure() {
+       ceph_src_configure
+}
+
+python_compile() {
+       local CMAKE_USE_DIR="${S}"
+       ceph_src_configure
+
+       pushd "${BUILD_DIR}/src/pybind" >/dev/null || die
+       emake VERBOSE=1 clean
+       emake VERBOSE=1 all
+
+       # python modules are only compiled with "make install" so we need to do this to
+       # prevent doing a bunch of compilation in src_install
+       DESTDIR="${T}" emake VERBOSE=1 install
+       popd >/dev/null || die
+}
+
+src_compile() {
+       cmake-utils_src_make VERBOSE=1 all
+
+       # we have to do this here to prevent from building everything multiple times
+       python_copy_sources
+       python_foreach_impl python_compile
+}
+
+src_test() {
+       make check || die "make check failed"
+}
+
+python_install() {
+       local CMAKE_USE_DIR="${S}"
+       pushd "${BUILD_DIR}/src/pybind" >/dev/null || die
+       DESTDIR="${ED}" emake VERBOSE=1 install
+       popd >/dev/null || die
+
+       python_optimize
+}
+
+src_install() {
+       cmake-utils_src_install
+       python_foreach_impl python_install
+
+       find "${ED}" -name '*.la' -type f -delete || die
+
+       exeinto /usr/$(get_libdir)/ceph
+       newexe "${BUILD_DIR}/bin/init-ceph" init-ceph
+
+       insinto /etc/logrotate.d/
+       newins "${FILESDIR}"/ceph.logrotate-r2 ${PN}
+
+       keepdir /var/lib/${PN}{,/tmp} /var/log/${PN}/stat
+
+       fowners -R ceph:ceph /var/log/ceph
+
+       newinitd "${FILESDIR}/rbdmap.initd" rbdmap
+       newinitd "${FILESDIR}/${PN}.initd-r12" ${PN}
+       newconfd "${FILESDIR}/${PN}.confd-r5" ${PN}
+
+       insinto /etc/sysctl.d
+       newins "${FILESDIR}"/sysctld 90-${PN}.conf
+
+       use tcmalloc && newenvd "${FILESDIR}"/envd-tcmalloc 99${PN}-tcmalloc
+
+       # units aren't installed by the build system unless systemd is enabled
+       # so no point installing these with the USE flag disabled
+       if use systemd; then
+               systemd_install_serviced "${FILESDIR}/ceph-mds_at.service.conf" \
+                       "ceph-mds@.service"
+
+               systemd_install_serviced "${FILESDIR}/ceph-osd_at.service.conf" \
+                       "ceph-osd@.service"
+       fi
+
+       udev_dorules udev/*.rules
+
+       readme.gentoo_create_doc
+
+       python_setup 'python3*'
+
+       # bug #630232
+       sed -i -r "s:${T//:/\\:}/${EPYTHON}:/usr:" "${ED}"/usr/bin/ceph{,-crash} \
+               || die "sed failed"
+
+       python_fix_shebang "${ED}"/usr/{,s}bin/
+
+       # python_fix_shebang apparently is not idempotent
+       local shebang_regex='(/usr/lib/python-exec/python[0-9]\.[0-9]/python)[0-9]\.[0-9]'
+       grep -r -E -l --null "${shebang_regex}" "${ED}"/usr/{s,}bin/ \
+               | xargs --null --no-run-if-empty -- sed -i -r  "s:${shebang_regex}:\1:" || die
+
+       local -a rados_classes=( "${ED}/usr/$(get_libdir)/rados-classes"/* )
+       dostrip -x "${rados_classes[@]#${ED}}"
+}
+
+pkg_postinst() {
+       readme.gentoo_print_elog
+}
diff --git a/sys-cluster/ceph/files/ceph-14.2.8-boost-sonames.patch b/sys-cluster/ceph/files/ceph-14.2.8-boost-sonames.patch
new file mode 100644 (file)
index 0000000..07def70
--- /dev/null
@@ -0,0 +1,538 @@
+diff --git a/cmake/modules/BuildBoost.cmake b/cmake/modules/BuildBoost.cmake
+index f99d74a0bc..d1a47bc5d1 100644
+--- a/cmake/modules/BuildBoost.cmake
++++ b/cmake/modules/BuildBoost.cmake
+@@ -199,13 +199,13 @@ macro(build_boost version)
+   foreach(c ${Boost_BUILD_COMPONENTS})
+     string(TOUPPER ${c} upper_c)
+     if(Boost_USE_STATIC_LIBS)
+-      add_library(Boost::${c} STATIC IMPORTED)
++      add_library(Boost_${c} STATIC IMPORTED)
+     else()
+-      add_library(Boost::${c} SHARED IMPORTED)
++      add_library(Boost_${c} SHARED IMPORTED)
+     endif()
+-    add_dependencies(Boost::${c} Boost)
++    add_dependencies(Boost_${c} Boost)
+     if(c MATCHES "^python")
+-      set(c "python${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR}")
++      set(c "python-${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}")
+     endif()
+     if(Boost_USE_STATIC_LIBS)
+       set(Boost_${upper_c}_LIBRARY
+@@ -215,7 +215,7 @@ macro(build_boost version)
+         ${install_dir}/lib/${CMAKE_SHARED_LIBRARY_PREFIX}boost_${c}${CMAKE_SHARED_LIBRARY_SUFFIX})
+     endif()
+     unset(buildid)
+-    set_target_properties(Boost::${c} PROPERTIES
++    set_target_properties(Boost_${c} PROPERTIES
+       INTERFACE_INCLUDE_DIRECTORIES "${Boost_INCLUDE_DIRS}"
+       IMPORTED_LINK_INTERFACE_LANGUAGES "CXX"
+       IMPORTED_LOCATION "${Boost_${upper_c}_LIBRARY}")
+@@ -224,19 +224,19 @@ macro(build_boost version)
+   foreach(c ${Boost_BUILD_COMPONENTS})
+     if(Boost_${c}_DEPENDENCIES)
+       foreach(dep ${Boost_${c}_DEPENDENCIES})
+-        list(APPEND dependencies Boost::${dep})
++        list(APPEND dependencies Boost_${dep})
+       endforeach()
+-      set_target_properties(Boost::${c} PROPERTIES
++      set_target_properties(Boost_${c} PROPERTIES
+         INTERFACE_LINK_LIBRARIES "${dependencies}")
+       unset(dependencies)
+     endif()
+   endforeach()
+   # for header-only libraries
+-  add_library(Boost::boost INTERFACE IMPORTED)
+-  set_target_properties(Boost::boost PROPERTIES
++  add_library(boost INTERFACE IMPORTED)
++  set_target_properties(boost PROPERTIES
+     INTERFACE_INCLUDE_DIRECTORIES "${Boost_INCLUDE_DIRS}")
+-  add_dependencies(Boost::boost Boost)
++  add_dependencies(boost Boost)
+   find_package_handle_standard_args(Boost DEFAULT_MSG
+     Boost_INCLUDE_DIRS Boost_LIBRARIES)
+   mark_as_advanced(Boost_LIBRARIES BOOST_INCLUDE_DIRS)
+@@ -253,7 +253,7 @@ function(maybe_add_boost_dep target)
+     get_filename_component(ext ${src} EXT)
+     # assuming all cxx source files include boost header(s)
+     if(ext MATCHES ".cc|.cpp|.cxx")
+-      add_dependencies(${target} Boost::boost)
++      add_dependencies(${target} boost)
+       return()
+     endif()
+   endforeach()
+diff --git a/cmake/modules/FindBoost.cmake b/cmake/modules/FindBoost.cmake
+index bc61995b03..4419632fa4 100644
+--- a/cmake/modules/FindBoost.cmake
++++ b/cmake/modules/FindBoost.cmake
+@@ -293,9 +293,9 @@ function(_boost_get_canonical_target_name component target_var)
+   string(TOLOWER "${component}" component)
+   if(component MATCHES "^([a-z_]*)(python|numpy)([1-9])\\.?([0-9])?$")
+     # handle pythonXY and numpyXY versioned components and also python X.Y, mpi_python etc.
+-    set(${target_var} "Boost::${CMAKE_MATCH_1}${CMAKE_MATCH_2}" PARENT_SCOPE)
++    set(${target_var} "boost_${CMAKE_MATCH_1}${CMAKE_MATCH_2}" PARENT_SCOPE)
+   else()
+-    set(${target_var} "Boost::${component}" PARENT_SCOPE)
++    set(${target_var} "boost_${component}" PARENT_SCOPE)
+   endif()
+ endfunction()
+@@ -403,19 +403,19 @@ function(_boost_set_legacy_variables_from_config)
+   if(WIN32)
+     _boost_set_if_unset(Boost_LIB_DIAGNOSTIC_DEFINITIONS "-DBOOST_LIB_DIAGNOSTIC")
+   endif()
+-  if(NOT TARGET Boost::headers)
+-    add_library(Boost::headers INTERFACE IMPORTED)
+-    target_include_directories(Boost::headers INTERFACE ${Boost_INCLUDE_DIRS})
++  if(NOT TARGET boost_headers)
++    add_library(boost_headers INTERFACE IMPORTED)
++    target_include_directories(boost_headers INTERFACE ${Boost_INCLUDE_DIRS})
+   endif()
+   # Legacy targets w/o functionality as all handled by defined targets
+   foreach(lib diagnostic_definitions disable_autolinking dynamic_linking)
+-    if(NOT TARGET Boost::${lib})
+-      add_library(Boost::${lib} INTERFACE IMPORTED)
++    if(NOT TARGET boost_${lib})
++      add_library(boost_${lib} INTERFACE IMPORTED)
+     endif()
+   endforeach()
+-  if(NOT TARGET Boost::boost)
+-    add_library(Boost::boost INTERFACE IMPORTED)
+-    target_link_libraries(Boost::boost INTERFACE Boost::headers)
++  if(NOT TARGET boost_boost)
++    add_library(boost_boost INTERFACE IMPORTED)
++    target_link_libraries(boost_boost INTERFACE boost_headers)
+   endif()
+ endfunction()
+@@ -580,10 +580,6 @@ macro(_Boost_ADJUST_LIB_VARS basename)
+     if(Boost_${basename}_LIBRARY AND Boost_${basename}_HEADER)
+       set(Boost_${basename}_FOUND ON)
+-      if("x${basename}" STREQUAL "xTHREAD" AND NOT TARGET Threads::Threads)
+-        string(APPEND Boost_ERROR_REASON_THREAD " (missing dependency: Threads)")
+-        set(Boost_THREAD_FOUND OFF)
+-      endif()
+     endif()
+   endif()
+@@ -1170,7 +1166,7 @@ function(_Boost_COMPONENT_DEPENDENCIES component _ret)
+   if (NOT _boost_DEPS_STRING)
+     set(_boost_DEPS_STRING "(none)")
+   endif()
+-  # message(STATUS "Dependencies for Boost::${component}: ${_boost_DEPS_STRING}")
++  # message(STATUS "Dependencies for Boost_${component}: ${_boost_DEPS_STRING}")
+ endfunction()
+ #
+@@ -1254,7 +1250,7 @@ function(_Boost_COMPONENT_HEADERS component _hdrs)
+   if (NOT _boost_HDRS_STRING)
+     set(_boost_HDRS_STRING "(none)")
+   endif()
+-  # message(STATUS "Headers for Boost::${component}: ${_boost_HDRS_STRING}")
++  # message(STATUS "Headers for Boost_${component}: ${_boost_HDRS_STRING}")
+ endfunction()
+ #
+@@ -1302,7 +1298,7 @@ endfunction()
+ #
+ # Some boost libraries may require particular set of compler features.
+-# The very first one was `boost::fiber` introduced in Boost 1.62.
++# The very first one was `boost_fiber` introduced in Boost 1.62.
+ # One can check required compiler features of it in
+ # - `${Boost_ROOT}/libs/fiber/build/Jamfile.v2`;
+ # - `${Boost_ROOT}/libs/context/build/Jamfile.v2`.
+@@ -1472,11 +1468,11 @@ _Boost_DEBUG_PRINT_VAR("${CMAKE_CURRENT_LIST_FILE}" "${CMAKE_CURRENT_LIST_LINE}"
+ # on all platforms to keep end user code free from platform dependent
+ # code.  Also provide convenience targets to disable autolinking and
+ # enable dynamic linking.
+-if(NOT TARGET Boost::diagnostic_definitions)
+-  add_library(Boost::diagnostic_definitions INTERFACE IMPORTED)
+-  add_library(Boost::disable_autolinking INTERFACE IMPORTED)
+-  add_library(Boost::dynamic_linking INTERFACE IMPORTED)
+-  set_target_properties(Boost::dynamic_linking PROPERTIES
++if(NOT TARGET boost_diagnostic_definitions)
++  add_library(boost_diagnostic_definitions INTERFACE IMPORTED)
++  add_library(boost_disable_autolinking INTERFACE IMPORTED)
++  add_library(boost_dynamic_linking INTERFACE IMPORTED)
++  set_target_properties(boost_dynamic_linking PROPERTIES
+     INTERFACE_COMPILE_DEFINITIONS "BOOST_ALL_DYN_LINK")
+ endif()
+ if(WIN32)
+@@ -1498,9 +1494,9 @@ if(WIN32)
+   # code to emit a #pragma message each time a library is selected
+   # for linking.
+   set(Boost_LIB_DIAGNOSTIC_DEFINITIONS "-DBOOST_LIB_DIAGNOSTIC")
+-  set_target_properties(Boost::diagnostic_definitions PROPERTIES
++  set_target_properties(boost_diagnostic_definitions PROPERTIES
+     INTERFACE_COMPILE_DEFINITIONS "BOOST_LIB_DIAGNOSTIC")
+-  set_target_properties(Boost::disable_autolinking PROPERTIES
++  set_target_properties(boost_disable_autolinking PROPERTIES
+     INTERFACE_COMPILE_DEFINITIONS "BOOST_ALL_NO_LIB")
+ endif()
+@@ -1933,7 +1929,7 @@ if("thread" IN_LIST Boost_FIND_COMPONENTS)
+   else()
+     set(_Boost_find_quiet "")
+   endif()
+-  find_package(Threads ${_Boost_find_quiet})
++  find_package(boost_thread ${_Boost_find_quiet})
+   unset(_Boost_find_quiet)
+ endif()
+@@ -2234,69 +2230,69 @@ endif()
+ if(Boost_FOUND)
+   # The builtin CMake package in Boost 1.70+ introduces a new name
+   # for the header-only lib, let's provide the same UI in module mode
+-  if(NOT TARGET Boost::headers)
+-    add_library(Boost::headers INTERFACE IMPORTED)
++  if(NOT TARGET boost_headers)
++    add_library(boost_headers INTERFACE IMPORTED)
+     if(Boost_INCLUDE_DIRS)
+-      set_target_properties(Boost::headers PROPERTIES
++      set_target_properties(boost_headers PROPERTIES
+         INTERFACE_INCLUDE_DIRECTORIES "${Boost_INCLUDE_DIRS}")
+     endif()
+   endif()
+   # Define the old target name for header-only libraries for backwards
+   # compat.
+-  if(NOT TARGET Boost::boost)
+-    add_library(Boost::boost INTERFACE IMPORTED)
+-    set_target_properties(Boost::boost
+-      PROPERTIES INTERFACE_LINK_LIBRARIES Boost::headers)
++  if(NOT TARGET boost_boost)
++    add_library(boost_boost INTERFACE IMPORTED)
++    set_target_properties(boost_boost
++      PROPERTIES INTERFACE_LINK_LIBRARIES boost_headers)
+   endif()
+   foreach(COMPONENT ${Boost_FIND_COMPONENTS})
+-    if(_Boost_IMPORTED_TARGETS AND NOT TARGET Boost::${COMPONENT})
++    if(_Boost_IMPORTED_TARGETS AND NOT TARGET boost_${COMPONENT})
+       string(TOUPPER ${COMPONENT} UPPERCOMPONENT)
+       if(Boost_${UPPERCOMPONENT}_FOUND)
+         if(Boost_USE_STATIC_LIBS)
+-          add_library(Boost::${COMPONENT} STATIC IMPORTED)
++          add_library(boost_${COMPONENT} STATIC IMPORTED)
+         else()
+           # Even if Boost_USE_STATIC_LIBS is OFF, we might have static
+           # libraries as a result.
+-          add_library(Boost::${COMPONENT} UNKNOWN IMPORTED)
++          add_library(boost_${COMPONENT} UNKNOWN IMPORTED)
+         endif()
+         if(Boost_INCLUDE_DIRS)
+-          set_target_properties(Boost::${COMPONENT} PROPERTIES
++          set_target_properties(boost_${COMPONENT} PROPERTIES
+             INTERFACE_INCLUDE_DIRECTORIES "${Boost_INCLUDE_DIRS}")
+         endif()
+         if(EXISTS "${Boost_${UPPERCOMPONENT}_LIBRARY}")
+-          set_target_properties(Boost::${COMPONENT} PROPERTIES
++          set_target_properties(boost_${COMPONENT} PROPERTIES
+             IMPORTED_LINK_INTERFACE_LANGUAGES "CXX"
+             IMPORTED_LOCATION "${Boost_${UPPERCOMPONENT}_LIBRARY}")
+         endif()
+         if(EXISTS "${Boost_${UPPERCOMPONENT}_LIBRARY_RELEASE}")
+-          set_property(TARGET Boost::${COMPONENT} APPEND PROPERTY
++          set_property(TARGET boost_${COMPONENT} APPEND PROPERTY
+             IMPORTED_CONFIGURATIONS RELEASE)
+-          set_target_properties(Boost::${COMPONENT} PROPERTIES
++          set_target_properties(boost_${COMPONENT} PROPERTIES
+             IMPORTED_LINK_INTERFACE_LANGUAGES_RELEASE "CXX"
+             IMPORTED_LOCATION_RELEASE "${Boost_${UPPERCOMPONENT}_LIBRARY_RELEASE}")
+         endif()
+         if(EXISTS "${Boost_${UPPERCOMPONENT}_LIBRARY_DEBUG}")
+-          set_property(TARGET Boost::${COMPONENT} APPEND PROPERTY
++          set_property(TARGET boost_${COMPONENT} APPEND PROPERTY
+             IMPORTED_CONFIGURATIONS DEBUG)
+-          set_target_properties(Boost::${COMPONENT} PROPERTIES
++          set_target_properties(boost_${COMPONENT} PROPERTIES
+             IMPORTED_LINK_INTERFACE_LANGUAGES_DEBUG "CXX"
+             IMPORTED_LOCATION_DEBUG "${Boost_${UPPERCOMPONENT}_LIBRARY_DEBUG}")
+         endif()
+         if(_Boost_${UPPERCOMPONENT}_DEPENDENCIES)
+           unset(_Boost_${UPPERCOMPONENT}_TARGET_DEPENDENCIES)
+           foreach(dep ${_Boost_${UPPERCOMPONENT}_DEPENDENCIES})
+-            list(APPEND _Boost_${UPPERCOMPONENT}_TARGET_DEPENDENCIES Boost::${dep})
++            list(APPEND _Boost_${UPPERCOMPONENT}_TARGET_DEPENDENCIES boost_${dep})
+           endforeach()
+           if(COMPONENT STREQUAL "thread")
+             list(APPEND _Boost_${UPPERCOMPONENT}_TARGET_DEPENDENCIES Threads::Threads)
+           endif()
+-          set_target_properties(Boost::${COMPONENT} PROPERTIES
++          set_target_properties(boost_${COMPONENT} PROPERTIES
+             INTERFACE_LINK_LIBRARIES "${_Boost_${UPPERCOMPONENT}_TARGET_DEPENDENCIES}")
+         endif()
+         if(_Boost_${UPPERCOMPONENT}_COMPILER_FEATURES)
+-          set_target_properties(Boost::${COMPONENT} PROPERTIES
++          set_target_properties(boost_${COMPONENT} PROPERTIES
+             CXX_STANDARD 17)
+         endif()
+       endif()
+diff --git a/cmake/modules/Finddpdk.cmake b/cmake/modules/Finddpdk.cmake
+index 964ae5dfb0..92bf07c14e 100644
+--- a/cmake/modules/Finddpdk.cmake
++++ b/cmake/modules/Finddpdk.cmake
+@@ -102,9 +102,9 @@ if(dpdk_FOUND)
+   if(NOT TARGET dpdk::dpdk)
+     add_library(dpdk::dpdk INTERFACE IMPORTED)
+-    find_package(Threads QUIET)
++    find_package(boost_thread QUIET)
+     list(APPEND dpdk_LIBRARIES
+-      Threads::Threads
++      boost_thread
+       dpdk::cflags)
+     set_target_properties(dpdk::dpdk PROPERTIES
+       INTERFACE_LINK_LIBRARIES "${dpdk_LIBRARIES}"
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 28ec9835f8..31a1efa19f 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -356,12 +356,12 @@ set(ceph_common_objs
+ set(ceph_common_deps
+   json_spirit erasure_code arch crc32
+   ${LIB_RESOLV}
+-  Boost::thread
+-  Boost::system
+-  Boost::random
+-  Boost::program_options
+-  Boost::date_time
+-  Boost::iostreams
++  boost_thread
++  boost_system
++  boost_random
++  boost_program_options
++  boost_date_time
++  boost_iostreams
+   ${BLKID_LIBRARIES}
+   ${Backtrace_LIBRARIES}
+   ${BLKIN_LIBRARIES}
+@@ -522,7 +522,7 @@ if (WITH_CEPHFS)
+     ceph_mds.cc)
+   add_executable(ceph-mds ${ceph_mds_srcs})
+   target_link_libraries(ceph-mds mds ${CMAKE_DL_LIBS} global-static ceph-common
+-    Boost::thread)
++    boost_thread)
+   install(TARGETS ceph-mds DESTINATION bin)
+ endif()
+diff --git a/src/crimson/CMakeLists.txt b/src/crimson/CMakeLists.txt
+index d7b58521d4..e1533af33f 100644
+--- a/src/crimson/CMakeLists.txt
++++ b/src/crimson/CMakeLists.txt
+@@ -106,8 +106,8 @@ target_link_libraries(crimson-common
+   PRIVATE
+     crc32
+     crimson::cflags
+-    Boost::iostreams
+-    Boost::random
++    boost_iostreams
++    boost_random
+     ${NSS_LIBRARIES} ${NSPR_LIBRARIES} OpenSSL::Crypto)
+ set(crimson_auth_srcs
+diff --git a/src/mgr/CMakeLists.txt b/src/mgr/CMakeLists.txt
+index 180e39bc1c..8323aa29a5 100644
+--- a/src/mgr/CMakeLists.txt
++++ b/src/mgr/CMakeLists.txt
+@@ -30,7 +30,7 @@ target_include_directories(ceph-mgr SYSTEM PRIVATE "${PYTHON_INCLUDE_DIRS}")
+ target_link_libraries(ceph-mgr
+   osdc client heap_profiler
+   global-static ceph-common
+-  Boost::python${MGR_PYTHON_VERSION_MAJOR}${MGR_PYTHON_VERSION_MINOR}
++  boost_python${MGR_PYTHON_VERSION_MAJOR}${MGR_PYTHON_VERSION_MINOR}
+   ${MGR_PYTHON_LIBRARIES} ${CMAKE_DL_LIBS} ${GSSAPI_LIBRARIES})
+ set_target_properties(ceph-mgr PROPERTIES
+   POSITION_INDEPENDENT_CODE ${EXE_LINKER_USE_PIE})
+diff --git a/src/rbd_replay/CMakeLists.txt b/src/rbd_replay/CMakeLists.txt
+index e9d3804c5f..5c6eb58de1 100644
+--- a/src/rbd_replay/CMakeLists.txt
++++ b/src/rbd_replay/CMakeLists.txt
+@@ -36,7 +36,7 @@ if(HAVE_BABELTRACE)
+     global
+     babeltrace
+     babeltrace-ctf
+-    Boost::date_time
++    boost_date_time
+     )
+   install(TARGETS rbd-replay-prep DESTINATION bin)
+ endif(HAVE_BABELTRACE)
+diff --git a/src/rgw/CMakeLists.txt b/src/rgw/CMakeLists.txt
+index d184c783de..00740331e3 100644
+--- a/src/rgw/CMakeLists.txt
++++ b/src/rgw/CMakeLists.txt
+@@ -203,7 +203,7 @@ if(WITH_CURL_OPENSSL)
+ endif()
+ if(WITH_BOOST_CONTEXT)
+-  target_link_libraries(rgw_a PRIVATE Boost::coroutine Boost::context)
++  target_link_libraries(rgw_a PRIVATE boost_coroutine boost_context)
+ endif()
+ set(rgw_libs rgw_a)
+@@ -354,7 +354,7 @@ if(WITH_RADOSGW_AMQP_ENDPOINT)
+   target_link_libraries(rgw_admin_user PRIVATE RabbitMQ::RabbitMQ)
+ endif()
+ if(WITH_BOOST_CONTEXT)
+-  target_link_libraries(rgw_admin_user PRIVATE Boost::coroutine Boost::context)
++  target_link_libraries(rgw_admin_user PRIVATE boost_coroutine boost_context)
+ endif()
+ if(WITH_TESTS)
+diff --git a/src/test/CMakeLists.txt b/src/test/CMakeLists.txt
+index 5dcee1694d..60743be698 100644
+--- a/src/test/CMakeLists.txt
++++ b/src/test/CMakeLists.txt
+@@ -159,7 +159,7 @@ add_executable(ceph_omapbench
+   )
+ target_link_libraries(ceph_omapbench
+   librados
+-  Boost::program_options
++  boost_program_options
+   global
+   ${BLKID_LIBRARIES}
+   ${CMAKE_DL_LIBS}
+diff --git a/src/test/common/CMakeLists.txt b/src/test/common/CMakeLists.txt
+index 71fb77cda9..aff8fb6565 100644
+--- a/src/test/common/CMakeLists.txt
++++ b/src/test/common/CMakeLists.txt
+@@ -315,8 +315,8 @@ add_ceph_unittest(unittest_hobject)
+ add_executable(unittest_async_completion test_async_completion.cc)
+ add_ceph_unittest(unittest_async_completion)
+-target_link_libraries(unittest_async_completion Boost::system)
++target_link_libraries(unittest_async_completion boost_system)
+ add_executable(unittest_async_shared_mutex test_async_shared_mutex.cc)
+ add_ceph_unittest(unittest_async_shared_mutex)
+-target_link_libraries(unittest_async_shared_mutex ceph-common Boost::system)
++target_link_libraries(unittest_async_shared_mutex ceph-common boost_system)
+diff --git a/src/test/erasure-code/CMakeLists.txt b/src/test/erasure-code/CMakeLists.txt
+index 721f6c3675..1cd9635c77 100644
+--- a/src/test/erasure-code/CMakeLists.txt
++++ b/src/test/erasure-code/CMakeLists.txt
+@@ -2,15 +2,15 @@
+ add_executable(ceph_erasure_code_benchmark 
+   ${CMAKE_SOURCE_DIR}/src/erasure-code/ErasureCode.cc
+   ceph_erasure_code_benchmark.cc)
+-target_link_libraries(ceph_erasure_code_benchmark ceph-common Boost::program_options global ${CMAKE_DL_LIBS})
++target_link_libraries(ceph_erasure_code_benchmark ceph-common boost_program_options global ${CMAKE_DL_LIBS})
+ install(TARGETS ceph_erasure_code_benchmark
+   DESTINATION bin)
+ add_executable(ceph_erasure_code_non_regression ceph_erasure_code_non_regression.cc)
+-target_link_libraries(ceph_erasure_code_non_regression ceph-common Boost::program_options global ${CMAKE_DL_LIBS})
++target_link_libraries(ceph_erasure_code_non_regression ceph-common boost_program_options global ${CMAKE_DL_LIBS})
+ add_executable(ceph_erasure_code ceph_erasure_code.cc)
+-target_link_libraries(ceph_erasure_code ceph-common Boost::program_options global ${CMAKE_DL_LIBS})
++target_link_libraries(ceph_erasure_code ceph-common boost_program_options global ${CMAKE_DL_LIBS})
+ install(TARGETS ceph_erasure_code
+   DESTINATION bin)
+diff --git a/src/test/lazy-omap-stats/CMakeLists.txt b/src/test/lazy-omap-stats/CMakeLists.txt
+index fad71f135c..06a3d2d929 100644
+--- a/src/test/lazy-omap-stats/CMakeLists.txt
++++ b/src/test/lazy-omap-stats/CMakeLists.txt
+@@ -4,7 +4,7 @@ add_executable(ceph_test_lazy_omap_stats
+   main.cc
+   lazy_omap_stats_test.cc)
+ target_link_libraries(ceph_test_lazy_omap_stats
+-  librados ${UNITTEST_LIBS} Boost::system)
++  librados ${UNITTEST_LIBS} boost_system)
+ install(TARGETS
+   ceph_test_lazy_omap_stats
+   DESTINATION ${CMAKE_INSTALL_BINDIR})
+diff --git a/src/test/librados/CMakeLists.txt b/src/test/librados/CMakeLists.txt
+index 4fc53d2406..e6304394f8 100644
+--- a/src/test/librados/CMakeLists.txt
++++ b/src/test/librados/CMakeLists.txt
+@@ -62,7 +62,7 @@ add_executable(ceph_test_rados_api_asio asio.cc)
+ target_link_libraries(ceph_test_rados_api_asio global
+   librados ${UNITTEST_LIBS})
+ if(WITH_BOOST_CONTEXT)
+-  target_link_libraries(ceph_test_rados_api_asio Boost::coroutine Boost::context)
++  target_link_libraries(ceph_test_rados_api_asio boost_coroutine boost_context)
+ endif()
+ add_executable(ceph_test_rados_api_list
+@@ -132,7 +132,7 @@ add_executable(ceph_test_rados_api_tier_pp
+   tier_cxx.cc
+   $<TARGET_OBJECTS:unit-main>)
+ target_link_libraries(ceph_test_rados_api_tier_pp
+-  librados global ${UNITTEST_LIBS} Boost::system radostest-cxx)
++  librados global ${UNITTEST_LIBS} boost_system radostest-cxx)
+ add_executable(ceph_test_rados_api_snapshots
+   snapshots.cc)
+diff --git a/src/test/librbd/CMakeLists.txt b/src/test/librbd/CMakeLists.txt
+index 3c3e9db6c1..2c208c1a4f 100644
+--- a/src/test/librbd/CMakeLists.txt
++++ b/src/test/librbd/CMakeLists.txt
+@@ -27,7 +27,7 @@ target_link_libraries(rbd_test PRIVATE
+   radostest
+   radostest-cxx
+   librados
+-  Boost::thread
++  boost_thread
+   GMock::GMock
+   GTest::GTest)
+diff --git a/src/test/mon/CMakeLists.txt b/src/test/mon/CMakeLists.txt
+index b712e95be7..6225ff3320 100644
+--- a/src/test/mon/CMakeLists.txt
++++ b/src/test/mon/CMakeLists.txt
+@@ -44,7 +44,7 @@ target_link_libraries(unittest_mon_montypes mon global)
+ add_executable(ceph_test_mon_memory_target
+   test_mon_memory_target.cc
+   )
+-target_link_libraries(ceph_test_mon_memory_target ${UNITTEST_LIBS} Boost::system)
++target_link_libraries(ceph_test_mon_memory_target ${UNITTEST_LIBS} boost_system)
+ install(TARGETS ceph_test_mon_memory_target
+   DESTINATION ${CMAKE_INSTALL_BINDIR})
+diff --git a/src/test/rgw/CMakeLists.txt b/src/test/rgw/CMakeLists.txt
+index cde6348d57..e6ce738834 100644
+--- a/src/test/rgw/CMakeLists.txt
++++ b/src/test/rgw/CMakeLists.txt
+@@ -144,7 +144,7 @@ add_ceph_unittest(unittest_rgw_dmclock_scheduler)
+ target_link_libraries(unittest_rgw_dmclock_scheduler radosgw_a dmclock)
+ if(WITH_BOOST_CONTEXT)
+   target_compile_definitions(unittest_rgw_dmclock_scheduler PRIVATE BOOST_COROUTINES_NO_DEPRECATION_WARNING)
+-  target_link_libraries(unittest_rgw_dmclock_scheduler Boost::coroutine Boost::context)
++  target_link_libraries(unittest_rgw_dmclock_scheduler boost_coroutine boost_context)
+ endif()
+ if(WITH_RADOSGW_AMQP_ENDPOINT)
+diff --git a/src/tools/CMakeLists.txt b/src/tools/CMakeLists.txt
+index d31f3d2408..6945018b11 100644
+--- a/src/tools/CMakeLists.txt
++++ b/src/tools/CMakeLists.txt
+@@ -35,20 +35,20 @@ install(PROGRAMS
+ endif(WITH_TESTS)
+ add_executable(ceph-osdomap-tool ceph_osdomap_tool.cc)
+-target_link_libraries(ceph-osdomap-tool os global Boost::program_options)
++target_link_libraries(ceph-osdomap-tool os global boost_program_options)
+ install(TARGETS ceph-osdomap-tool DESTINATION bin)
+ add_executable(ceph-monstore-tool
+   ceph_monstore_tool.cc
+   ../mgr/mgr_commands.cc)
+-target_link_libraries(ceph-monstore-tool os global Boost::program_options)
++target_link_libraries(ceph-monstore-tool os global boost_program_options)
+ install(TARGETS ceph-monstore-tool DESTINATION bin)
+ add_executable(ceph-objectstore-tool
+   ceph_objectstore_tool.cc
+   rebuild_mondb.cc
+   RadosDump.cc)
+-target_link_libraries(ceph-objectstore-tool osd os global Boost::program_options ${CMAKE_DL_LIBS})
++target_link_libraries(ceph-objectstore-tool osd os global boost_program_options ${CMAKE_DL_LIBS})
+ if(WITH_FUSE)
+   target_link_libraries(ceph-objectstore-tool ${FUSE_LIBRARIES})
+ endif(WITH_FUSE)