app-vim/youcompleteme: remove last-rited pkg
authorMikle Kolyada <zlogene@gentoo.org>
Tue, 25 Feb 2020 10:05:03 +0000 (13:05 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Tue, 25 Feb 2020 10:05:32 +0000 (13:05 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
app-vim/youcompleteme/Manifest [deleted file]
app-vim/youcompleteme/metadata.xml [deleted file]
app-vim/youcompleteme/youcompleteme-20130910.ebuild [deleted file]
app-vim/youcompleteme/youcompleteme-99999999.ebuild [deleted file]

diff --git a/app-vim/youcompleteme/Manifest b/app-vim/youcompleteme/Manifest
deleted file mode 100644 (file)
index fd4d350..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST youcompleteme-20130910.tar.xz 2340104 BLAKE2B 1d50eae1e53d1acc3e9599ade6c5686602cf28997574dcf128b1ed1f812548c51e0c5ad45547ec12fc44d7391ce539c7cd8785ae823978ce18b870dd794f07a2 SHA512 c1022a27ced00e8ba8e9aa25029a0032805331cf0f80342aaaf9d7d4ec7780a098ffbd315068f19f6c98b00c4b4b43e59c7fa40070057e097ca40f6398b53b6b
diff --git a/app-vim/youcompleteme/metadata.xml b/app-vim/youcompleteme/metadata.xml
deleted file mode 100644 (file)
index 1b06697..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-       <maintainer type="project">
-               <email>vim@gentoo.org</email>
-               <name>Gentoo Vim Project</name>
-       </maintainer>
-       <use>
-               <flag name="clang">Enable semantic support for C-family languages using <pkg>sys-devel/clang</pkg></flag>
-       </use>
-</pkgmetadata>
diff --git a/app-vim/youcompleteme/youcompleteme-20130910.ebuild b/app-vim/youcompleteme/youcompleteme-20130910.ebuild
deleted file mode 100644 (file)
index 29e5f6c..0000000
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils multilib python-single-r1 cmake-utils vim-plugin
-
-if [[ ${PV} == 9999* ]] ; then
-       EGIT_REPO_URI="https://github.com/Valloric/YouCompleteMe.git"
-       inherit git-r3
-else
-       KEYWORDS="~amd64 ~x86"
-       SRC_URI="https://dev.gentoo.org/~radhermit/vim/${P}.tar.xz"
-fi
-
-DESCRIPTION="vim plugin: a code-completion engine for Vim"
-HOMEPAGE="https://valloric.github.io/YouCompleteMe/"
-
-LICENSE="GPL-3"
-IUSE="+clang test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="${PYTHON_DEPS}
-       clang? ( >=sys-devel/clang-3.3 )
-       || (
-               app-editors/vim[python,${PYTHON_SINGLE_USEDEP}]
-               app-editors/gvim[python,${PYTHON_SINGLE_USEDEP}]
-       )"
-DEPEND="${RDEPEND}
-       test? (
-               $(python_gen_cond_dep '
-                       >=dev-python/mock-1.0.1[${PYTHON_MULTI_USEDEP}]
-                       >=dev-python/nose-1.3.0[${PYTHON_MULTI_USEDEP}]
-               ')
-       )"
-
-CMAKE_IN_SOURCE_BUILD=1
-CMAKE_USE_DIR=${S}/cpp
-
-VIM_PLUGIN_HELPFILES="${PN}"
-
-src_prepare() {
-       if ! use test ; then
-               sed -i '/^add_subdirectory( tests )/d' cpp/ycm/CMakeLists.txt || die
-       fi
-}
-
-src_configure() {
-       local mycmakeargs=(
-               $(cmake-utils_use_use clang CLANG_COMPLETER)
-               $(cmake-utils_use_use clang SYSTEM_LIBCLANG)
-       )
-       cmake-utils_src_configure
-}
-
-src_test() {
-       # TODO: use system gtest
-       cd "${S}"/cpp || die
-       emake ycm_core_tests
-       cd ycm/tests || die
-       LD_LIBRARY_PATH="${EROOT}"/usr/$(get_libdir)/llvm \
-               "${S}"/cpp/ycm/tests/ycm_core_tests || die
-
-       cd "${S}"/python/ycm || die
-       nosetests --verbose || die
-}
-
-src_install() {
-       dodoc *.md
-       rm -r *.md *.sh COPYING.txt cpp || die
-       find python -name *test* -exec rm -rf {} + || die
-       rm python/libclang.so || die
-
-       vim-plugin_src_install
-
-       python_optimize "${ED}"
-       python_fix_shebang "${ED}"
-}
-
-pkg_postinst() {
-       vim-plugin_pkg_postinst
-
-       [[ -z ${REPLACING_VERSIONS} ]] && \
-               optfeature "better python autocompletion" dev-python/jedi
-}
diff --git a/app-vim/youcompleteme/youcompleteme-99999999.ebuild b/app-vim/youcompleteme/youcompleteme-99999999.ebuild
deleted file mode 100644 (file)
index 54e1ec4..0000000
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils multilib python-single-r1 cmake-utils vcs-clean vim-plugin
-
-if [[ ${PV} == 9999* ]] ; then
-       EGIT_REPO_URI="https://github.com/Valloric/YouCompleteMe.git"
-       inherit git-r3
-else
-       KEYWORDS="~amd64 ~x86"
-       SRC_URI="https://dev.gentoo.org/~radhermit/vim/${P}.tar.xz"
-fi
-
-DESCRIPTION="vim plugin: a code-completion engine for Vim"
-HOMEPAGE="https://valloric.github.io/YouCompleteMe/"
-
-LICENSE="GPL-3"
-IUSE="+clang test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-COMMON_DEPEND="
-       ${PYTHON_DEPS}
-       clang? ( >=sys-devel/clang-3.3 )
-       $(python_gen_cond_dep '
-               dev-libs/boost[python,threads,${PYTHON_MULTI_USEDEP}]
-       ')
-       || (
-               app-editors/vim[python,${PYTHON_SINGLE_USEDEP}]
-               app-editors/gvim[python,${PYTHON_SINGLE_USEDEP}]
-       )
-"
-RDEPEND="
-       ${COMMON_DEPEND}
-       $(python_gen_cond_dep '
-               dev-python/bottle[${PYTHON_MULTI_USEDEP}]
-               virtual/python-futures[${PYTHON_MULTI_USEDEP}]
-               dev-python/jedi[${PYTHON_MULTI_USEDEP}]
-               dev-python/requests[${PYTHON_MULTI_USEDEP}]
-               dev-python/sh[${PYTHON_MULTI_USEDEP}]
-               dev-python/waitress[${PYTHON_MULTI_USEDEP}]
-       ')
-"
-DEPEND="
-       ${COMMON_DEPEND}
-       test? (
-               $(python_gen_cond_dep '
-                       >=dev-python/mock-1.0.1[${PYTHON_MULTI_USEDEP}]
-                       >=dev-python/nose-1.3.0[${PYTHON_MULTI_USEDEP}]
-               ')
-               >=dev-cpp/gtest-1.8.0
-       )
-"
-
-CMAKE_IN_SOURCE_BUILD=1
-CMAKE_USE_DIR=${S}/third_party/ycmd/cpp
-
-VIM_PLUGIN_HELPFILES="${PN}"
-
-src_prepare() {
-       if ! use test; then
-               sed -i '/^add_subdirectory( tests )/d' third_party/ycmd/cpp/ycm/CMakeLists.txt || die
-       fi
-
-       for third_party_module in requests pythonfutures; do
-               if [[ -d "${third_party_module}" ]]; then
-                       rm -r "${S}"/third_party/${third_party_module} || die "Failed to remove third party module ${third_party_module}"
-               fi
-       done
-
-       # Argparse is included in python 2.7
-       for third_party_module in argparse bottle jedi waitress sh requests; do
-               if [[ -d "${third_party_module}" ]]; then
-                       rm -r "${S}"/third_party/ycmd/third_party/${third_party_module} || die "Failed to remove third party module ${third_party_module}"
-               fi
-       done
-}
-
-src_configure() {
-       local mycmakeargs=(
-               $(cmake-utils_use_use clang CLANG_COMPLETER)
-               $(cmake-utils_use_use clang SYSTEM_LIBCLANG)
-               -DUSE_SYSTEM_BOOST=ON
-               -DUSE_SYSTEM_GMOCK=ON
-       )
-       cmake-utils_src_configure
-}
-
-src_test() {
-       cd "${S}/third_party/ycmd/cpp/ycm/tests" || die
-       LD_LIBRARY_PATH="${EROOT}"/usr/$(get_libdir)/llvm \
-               ./ycm_core_tests || die
-
-       cd "${S}"/python/ycm || die
-
-       local dirs=( "${S}"/third_party/*/ "${S}"/third_party/ycmd/third_party/*/ )
-       local -x PYTHONPATH=${PYTHONPATH}:$(IFS=:; echo "${dirs[*]}")
-
-       nosetests --verbose || die
-}
-
-src_install() {
-       dodoc *.md third_party/ycmd/*.md
-       rm -r *.md *.sh COPYING.txt third_party/ycmd/cpp || die
-       rm -r third_party/ycmd/{*.md,*.sh} || die
-       find python -name *test* -exec rm -rf {} + || die
-       egit_clean
-       rm third_party/ycmd/libclang.so* || die
-
-       vim-plugin_src_install
-
-       python_optimize "${ED}"
-       python_fix_shebang "${ED}"
-}