net-print/cups-filters: Bump to version 1.25.5
authorLars Wendler <polynomial-c@gentoo.org>
Fri, 6 Sep 2019 18:06:20 +0000 (20:06 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Fri, 6 Sep 2019 18:06:20 +0000 (20:06 +0200)
Package-Manager: Portage-2.3.75, Repoman-2.3.17
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-print/cups-filters/Manifest
net-print/cups-filters/cups-filters-1.25.5.ebuild [new file with mode: 0644]

index 8c265e1201e56ee11132ed2e0f96091e125e580f..7673124610f1008a8a02feb1ba57d135655a335c 100644 (file)
@@ -2,3 +2,4 @@ DIST cups-filters-1.21.6.tar.xz 1474944 BLAKE2B a4c3418accb9d2bf46a366ec6004919d
 DIST cups-filters-1.22.6.tar.xz 1477584 BLAKE2B 7d833c3e97c510eabcc906bbd01d4d1ef2bf3106d963bdec7f735942e96a830c53ec2c03a4ef580d9fc01f19bae3962c1bd2a98d2af7f03f71988ae374366fee SHA512 6c1c46bd74f700b3ab0a46cb4b5b7ecc93000122e9deb20b43878d876cbe2ceeeb4a3c16ef6de00497b10447d04f2689a5d939d0d49212e7274cc51b4617c296
 DIST cups-filters-1.25.3.tar.xz 1448840 BLAKE2B d58d93995d1742ceea861896399687717b7791ef6208daaf50e6df715943ac7c5a8709ad93b5d0c66e412ae4832b1969b238f277bdefb1da61b00dd0cb984fc9 SHA512 df3c5fc9e4e0449943abbff19a537057f9def3a18504241581727ed6a39ecad30315d5593bdf31d04d51181dd402a418805185afa15c22dabf34e1e9eea90a81
 DIST cups-filters-1.25.4.tar.xz 1449676 BLAKE2B 1ba36c013d37d57ebf04a9395638bee8aa3935832ed5f0235f50fcfbc61e4002701dec15f7c45952975fc1e53e7f57fd93f86b9af153a732795745e21e38d329 SHA512 0386c4640249a0325257f9b10a0eee387bc6e8129bde734b6c35704719c0ad60624f9ad44c73cd199768373ffd331fc1b4b4c4c8641f5ec8792ddf8850da510a
+DIST cups-filters-1.25.5.tar.xz 1450264 BLAKE2B 126f32604ff4b2599154406177f8aeaf061f9624255177de968f88706a9138ed9fc8f170987bc25bb4c3801b33432c51c304d2b4a1bdc7249b7472d9cbaadca6 SHA512 4e7126f4c439cb7392484dd3531023da5a1c885c7a6c7377260e7cccc2f3f51e3d0aa879965ecdb2625217d6f9ee1ca9c860c4fc05a7959697cd269696f10f59
diff --git a/net-print/cups-filters/cups-filters-1.25.5.ebuild b/net-print/cups-filters/cups-filters-1.25.5.ebuild
new file mode 100644 (file)
index 0000000..cdc922f
--- /dev/null
@@ -0,0 +1,134 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit perl-module systemd flag-o-matic
+
+if [[ "${PV}" == "9999" ]] ; then
+       inherit autotools git-r3
+       EGIT_REPO_URI="https://github.com/OpenPrinting/cups-filters.git"
+else
+       SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~m68k-mint"
+fi
+DESCRIPTION="Cups filters"
+HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="dbus +foomatic ipp_autosetup jpeg ldap pclm pdf perl png +postscript static-libs test tiff zeroconf"
+
+RDEPEND="
+       >=app-text/poppler-0.32:=[cxx,jpeg?,lcms,tiff?,utils]
+       >=app-text/qpdf-8.3.0:=
+       dev-libs/glib:2
+       media-libs/fontconfig
+       media-libs/freetype:2
+       media-libs/lcms:2
+       >=net-print/cups-1.7.3
+       !<=net-print/cups-1.5.9999
+       sys-devel/bc
+       sys-libs/zlib
+       dbus? ( sys-apps/dbus )
+       foomatic? ( !net-print/foomatic-filters )
+       jpeg? ( virtual/jpeg:0 )
+       ldap? ( net-nds/openldap )
+       pdf? ( app-text/mupdf )
+       perl? ( dev-lang/perl:= )
+       png? ( media-libs/libpng:0= )
+       postscript? ( >=app-text/ghostscript-gpl-9.09[cups] )
+       tiff? ( media-libs/tiff:0 )
+       zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}
+       dev-util/gdbus-codegen
+       test? ( media-fonts/dejavu )
+"
+
+src_prepare() {
+       default
+       [[ "${PV}" == "9999" ]] && eautoreconf
+
+       # Bug #626800
+       append-cxxflags -std=c++11
+}
+
+src_configure() {
+       local myeconfargs=(
+               --enable-imagefilters
+               --localstatedir="${EPREFIX}"/var
+               --with-browseremoteprotocols=DNSSD,CUPS
+               --with-cups-rundir="${EPREFIX}"/run/cups
+               --with-fontdir="fonts/conf.avail"
+               --with-pdftops=pdftops
+               --with-rcdir=no
+               --without-php
+               $(use_enable dbus)
+               $(use_enable foomatic)
+               $(use_enable ipp_autosetup auto-setup-driverless)
+               $(use_enable ldap)
+               $(use_enable pclm)
+               $(use_enable pdf mutool)
+               $(use_enable postscript ghostscript)
+               $(use_enable static-libs static)
+               $(use_enable zeroconf avahi)
+               $(use_with jpeg)
+               $(use_with png)
+               $(use_with tiff)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+       default
+
+       if use perl; then
+               pushd "${S}/scripting/perl" > /dev/null
+               perl-module_src_configure
+               perl-module_src_compile
+               popd > /dev/null
+       fi
+}
+
+src_install() {
+       default
+
+       if use perl; then
+               pushd "${S}/scripting/perl" > /dev/null
+               perl-module_src_install
+               perl_delete_localpod
+               popd > /dev/null
+       fi
+
+       if use postscript; then
+               # workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
+               dosym gstoraster /usr/libexec/cups/filter/pstoraster
+               dosym gstopxl /usr/libexec/cups/filter/pstopxl
+       fi
+
+       find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+
+       cp "${FILESDIR}"/cups-browsed.init.d-r1 "${T}"/cups-browsed || die
+
+       if ! use zeroconf ; then
+               sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
+               sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
+       fi
+
+       doinitd "${T}"/cups-browsed
+       systemd_dounit "${S}/utils/cups-browsed.service"
+}
+
+src_test() {
+       emake check
+}
+
+pkg_postinst() {
+       if ! use foomatic ; then
+               ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
+               ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
+       fi
+}