dev-python/os-vif: cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 11 Feb 2020 18:43:32 +0000 (12:43 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 11 Feb 2020 19:06:16 +0000 (13:06 -0600)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/os-vif/Manifest
dev-python/os-vif/os-vif-1.9.1.ebuild [deleted file]

index b63ba5992926c6e2a652878bbbf2c716e7a02ba5..a90aaf77fae2c98375ede493dd35e44bb130faf2 100644 (file)
@@ -1,2 +1 @@
 DIST os_vif-1.15.2.tar.gz 88591 BLAKE2B 0a272332b238590f9a0cb5a457babe8a26b97196370c0e0f4c1e4d89e814e424dcc5f0e2786cfed3729bb5608434507966ab22d9c68b90e7deef0767381a8cb0 SHA512 36d7ff16fa5b7cecf738d9e867657ce7ff416a514cde2796306d2e21a1ae1985528dfcecc95498a24fcfc16687cfdbc898550520ac6e17d202ea554e8d8c7b1c
-DIST os_vif-1.9.1.tar.gz 63535 BLAKE2B b4c017b129c2540794f85292341a165761d00439d24727fe2f421c96a7e5d6e79e8572a217064e01e62bb137f136fcfd1d51ff089c48026de82d91a8b9a22386 SHA512 d7aeec1bd277a91a1f4fbda69e5408f5648ad49ffac17d1ca54148ec30c31bd64639151988355395166747df91cd89cbed1863a2668a5bce89a10d2aea55c288
diff --git a/dev-python/os-vif/os-vif-1.9.1.ebuild b/dev-python/os-vif/os-vif-1.9.1.ebuild
deleted file mode 100644 (file)
index f7b24d3..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="OpenStack Cinder brick library for managing local volume attaches"
-HOMEPAGE="https://github.com/openstack/os-vif"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/os_vif-${PV}.tar.gz"
-S="${WORKDIR}/os_vif-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE=""
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
-       !~dev-python/pbr-2.1.0"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       ${CDEPEND}"
-RDEPEND="
-       ${CDEPEND}
-       >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
-       >=dev-python/oslo-concurrency-3.20.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-log-3.30.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
-       >=dev-python/oslo-privsep-1.23.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-versionedobjects-1.28.0[${PYTHON_USEDEP}]
-       >=dev-python/pyroute2-0.4.21[${PYTHON_USEDEP}]
-       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-       >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
-       sed -i '/^hacking/d' test-requirements.txt || die
-       sed -i '/^pbr/d' requirements.txt || die  # pbr should be uncapped in stable/ocata
-       distutils-r1_python_prepare_all
-}