sys-apps/portage: Drop py2
authorMichał Górny <mgorny@gentoo.org>
Thu, 19 Mar 2020 08:52:09 +0000 (09:52 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 19 Mar 2020 09:41:00 +0000 (10:41 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-apps/portage/metadata.xml
sys-apps/portage/portage-2.3.69.ebuild
sys-apps/portage/portage-2.3.79.ebuild
sys-apps/portage/portage-2.3.84-r1.ebuild
sys-apps/portage/portage-2.3.89-r1.ebuild
sys-apps/portage/portage-2.3.92.ebuild
sys-apps/portage/portage-2.3.93.ebuild
sys-apps/portage/portage-2.3.94.ebuild
sys-apps/portage/portage-9999.ebuild

index bf8c5a54f96a669703f273d12203ae7922c32c56..9f4e43e394b5ab7d290668fc9536329302b180e4 100644 (file)
@@ -11,7 +11,6 @@
   </maintainer>
   <use>
     <flag name="apidoc">Build html API documentation with sphinx-apidoc.</flag>
-    <flag name="epydoc">Build html API documentation with epydoc (deprecated).</flag>
     <flag name="gentoo-dev">Enable features required for Gentoo ebuild development.</flag>
     <flag name="ipc">Use inter-process communication between portage and
         running ebuilds.
index 9079277e5ccb0cce79c95be9f976ba224bce1bf5..40994d2450994a92d819f0417d8c49e7585840a4 100644 (file)
@@ -4,11 +4,7 @@
 EAPI=5
 
 DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=(
-       pypy
-       python3_5 python3_6 python3_7
-       python2_7
-)
+PYTHON_COMPAT=( python3_5 python3_6 python3_7 )
 PYTHON_REQ_USE='bzip2(+),threads(+)'
 
 inherit distutils-r1 linux-info systemd prefix
@@ -19,14 +15,13 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
 LICENSE="GPL-2"
 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86"
 SLOT="0"
-IUSE="build doc epydoc gentoo-dev +ipc +native-extensions +rsync-verify selinux xattr"
+IUSE="build doc gentoo-dev +ipc +native-extensions +rsync-verify selinux xattr"
 
 DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
        >=app-arch/tar-1.27
        dev-lang/python-exec:2
        >=sys-apps/sed-4.0.5 sys-devel/patch
-       doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )
-       epydoc? ( >=dev-python/epydoc-2.0[$(python_gen_usedep 'python2*')] )"
+       doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )"
 # Require sandbox-2.2 for bug #288863.
 # For xattr, we can spawn getfattr and setfattr from sys-apps/attr, but that's
 # quite slow, so it's not considered in the dependencies as an alternative to
@@ -73,8 +68,6 @@ PDEPEND="
 # coreutils-6.4 rdep is for date format in emerge-webrsync #164532
 # NOTE: FEATURES=installsources requires debugedit and rsync
 
-REQUIRED_USE="epydoc? ( $(python_gen_useflags 'python2*') )"
-
 SRC_ARCHIVES="https://dev.gentoo.org/~zmedico/portage/archives"
 
 prefix_src_archives() {
@@ -97,7 +90,7 @@ pkg_pretend() {
 }
 
 pkg_setup() {
-       use epydoc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
+       :
 }
 
 python_prepare_all() {
@@ -182,7 +175,6 @@ python_prepare_all() {
 python_compile_all() {
        local targets=()
        use doc && targets+=( docbook )
-       use epydoc && targets+=( epydoc )
 
        if [[ ${targets[@]} ]]; then
                esetup.py "${targets[@]}"
@@ -215,10 +207,6 @@ python_install_all() {
                install_docbook
                --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
        )
-       use epydoc && targets+=(
-               install_epydoc
-               --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
-       )
 
        # install docs
        if [[ ${targets[@]} ]]; then
index 5b5f4e791f7abe2c5423141f7b83c96c6a4b9394..36088bf91f08b4d4ac346f3c38d118658e35af52 100644 (file)
@@ -4,11 +4,7 @@
 EAPI=5
 
 DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=(
-       pypy
-       python3_5 python3_6 python3_7 python3_8
-       python2_7
-)
+PYTHON_COMPAT=( python3_5 python3_6 python3_7 python3_8 )
 PYTHON_REQ_USE='bzip2(+),threads(+)'
 
 inherit distutils-r1 linux-info systemd prefix
@@ -19,14 +15,13 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
 LICENSE="GPL-2"
 KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~riscv s390 ~sh sparc x86"
 SLOT="0"
-IUSE="build doc epydoc gentoo-dev +ipc +native-extensions +rsync-verify selinux xattr"
+IUSE="build doc gentoo-dev +ipc +native-extensions +rsync-verify selinux xattr"
 
 DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
        >=app-arch/tar-1.27
        dev-lang/python-exec:2
        >=sys-apps/sed-4.0.5 sys-devel/patch
-       doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )
-       epydoc? ( >=dev-python/epydoc-2.0[$(python_gen_usedep 'python2*')] )"
+       doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )"
 # Require sandbox-2.2 for bug #288863.
 # For xattr, we can spawn getfattr and setfattr from sys-apps/attr, but that's
 # quite slow, so it's not considered in the dependencies as an alternative to
@@ -74,8 +69,6 @@ PDEPEND="
 # coreutils-6.4 rdep is for date format in emerge-webrsync #164532
 # NOTE: FEATURES=installsources requires debugedit and rsync
 
-REQUIRED_USE="epydoc? ( $(python_gen_useflags 'python2*') )"
-
 SRC_ARCHIVES="https://dev.gentoo.org/~zmedico/portage/archives"
 
 prefix_src_archives() {
@@ -98,7 +91,7 @@ pkg_pretend() {
 }
 
 pkg_setup() {
-       use epydoc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
+       :
 }
 
 python_prepare_all() {
@@ -183,7 +176,6 @@ python_prepare_all() {
 python_compile_all() {
        local targets=()
        use doc && targets+=( docbook )
-       use epydoc && targets+=( epydoc )
 
        if [[ ${targets[@]} ]]; then
                esetup.py "${targets[@]}"
@@ -216,10 +208,6 @@ python_install_all() {
                install_docbook
                --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
        )
-       use epydoc && targets+=(
-               install_epydoc
-               --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
-       )
 
        # install docs
        if [[ ${targets[@]} ]]; then
index 0e07eb5927e740a9e72e9617e6e13a5603e831dd..82cfc09d2ffd2057ec63419ed31c314a65e239e1 100644 (file)
@@ -4,11 +4,7 @@
 EAPI=5
 
 DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=(
-       pypy3
-       python3_6 python3_7 python3_8
-       python2_7
-)
+PYTHON_COMPAT=( pypy3 python3_5 python3_6 python3_7 python3_8 )
 PYTHON_REQ_USE='bzip2(+),threads(+)'
 
 inherit distutils-r1 linux-info systemd prefix
@@ -19,18 +15,13 @@ HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
 LICENSE="GPL-2"
 KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~riscv s390 ~sh sparc x86"
 SLOT="0"
-IUSE="build doc epydoc gentoo-dev +ipc +native-extensions +rsync-verify selinux xattr"
+IUSE="build doc gentoo-dev +ipc +native-extensions +rsync-verify selinux xattr"
 
 DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
        >=app-arch/tar-1.27
        dev-lang/python-exec:2
        >=sys-apps/sed-4.0.5 sys-devel/patch
-       doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )
-       epydoc? (
-               $(python_gen_cond_dep '
-                       >=dev-python/epydoc-2.0[${PYTHON_USEDEP}]
-               ' 'python2*')
-       )"
+       doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )"
 # Require sandbox-2.2 for bug #288863.
 # For xattr, we can spawn getfattr and setfattr from sys-apps/attr, but that's
 # quite slow, so it's not considered in the dependencies as an alternative to
@@ -78,8 +69,6 @@ PDEPEND="
 # coreutils-6.4 rdep is for date format in emerge-webrsync #164532
 # NOTE: FEATURES=installsources requires debugedit and rsync
 
-REQUIRED_USE="epydoc? ( $(python_gen_useflags 'python2*') )"
-
 SRC_ARCHIVES="https://dev.gentoo.org/~zmedico/portage/archives"
 
 prefix_src_archives() {
@@ -102,7 +91,7 @@ pkg_pretend() {
 }
 
 pkg_setup() {
-       use epydoc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
+       :
 }
 
 python_prepare_all() {
@@ -190,7 +179,6 @@ python_prepare_all() {
 python_compile_all() {
        local targets=()
        use doc && targets+=( docbook )
-       use epydoc && targets+=( epydoc )
 
        if [[ ${targets[@]} ]]; then
                esetup.py "${targets[@]}"
@@ -223,10 +211,6 @@ python_install_all() {
                install_docbook
                --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
        )
-       use epydoc && targets+=(
-               install_epydoc
-               --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
-       )
 
        # install docs
        if [[ ${targets[@]} ]]; then
index c4cd0f48891d00636b08183545b381db5dcd3b58..780cf80fb585bd25e6e17d95f23d5c954ec4ab87 100644 (file)
@@ -4,11 +4,7 @@
 EAPI=5
 
 DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=(
-       pypy3
-       python3_6 python3_7 python3_8
-       python2_7
-)
+PYTHON_COMPAT=( pypy3 python3_5 python3_6 python3_7 python3_8 )
 PYTHON_REQ_USE='bzip2(+),threads(+)'
 
 inherit distutils-r1 linux-info systemd prefix
index 0188237e0e1275c99d6d72e602514207885ef85d..bd25531263bd2b591988f6512fec2c554598605b 100644 (file)
@@ -4,11 +4,7 @@
 EAPI=5
 
 DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=(
-       pypy3
-       python3_6 python3_7 python3_8
-       python2_7
-)
+PYTHON_COMPAT=( pypy3 python3_5 python3_6 python3_7 python3_8 )
 PYTHON_REQ_USE='bzip2(+),threads(+)'
 
 inherit distutils-r1 linux-info systemd prefix
index 0188237e0e1275c99d6d72e602514207885ef85d..bd25531263bd2b591988f6512fec2c554598605b 100644 (file)
@@ -4,11 +4,7 @@
 EAPI=5
 
 DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=(
-       pypy3
-       python3_6 python3_7 python3_8
-       python2_7
-)
+PYTHON_COMPAT=( pypy3 python3_5 python3_6 python3_7 python3_8 )
 PYTHON_REQ_USE='bzip2(+),threads(+)'
 
 inherit distutils-r1 linux-info systemd prefix
index 0188237e0e1275c99d6d72e602514207885ef85d..bd25531263bd2b591988f6512fec2c554598605b 100644 (file)
@@ -4,11 +4,7 @@
 EAPI=5
 
 DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=(
-       pypy3
-       python3_6 python3_7 python3_8
-       python2_7
-)
+PYTHON_COMPAT=( pypy3 python3_5 python3_6 python3_7 python3_8 )
 PYTHON_REQ_USE='bzip2(+),threads(+)'
 
 inherit distutils-r1 linux-info systemd prefix
index 58aa5a833ab52ceca2364da54c8d4cc32e12180a..e510a7a02ab48a1a388c03bc272dad800fcdd5d5 100644 (file)
@@ -4,11 +4,7 @@
 EAPI=6
 
 DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=(
-       pypy3
-       python3_6 python3_7 python3_8
-       python2_7
-)
+PYTHON_COMPAT=( pypy3 python3_5 python3_6 python3_7 python3_8 )
 PYTHON_REQ_USE='bzip2(+),threads(+)'
 
 inherit distutils-r1 git-r3 linux-info systemd prefix