dev-util/spirv-tools: Don't treat warnings as errors
authorNick Sarnie <sarnex@gentoo.org>
Sun, 7 Oct 2018 20:00:51 +0000 (16:00 -0400)
committerNick Sarnie <sarnex@gentoo.org>
Sun, 7 Oct 2018 20:06:27 +0000 (16:06 -0400)
Fix suggested by Coacher

Fixes: https://bugs.gentoo.org/667988
Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Package-Manager: Portage-2.3.50, Repoman-2.3.11

dev-util/spirv-tools/spirv-tools-2018.4.ebuild
dev-util/spirv-tools/spirv-tools-2018.5.ebuild
dev-util/spirv-tools/spirv-tools-9999.ebuild

index 95d38ce604dd1fa13faa5a3ee186fcf36730be3a..abdb79a88358081b308f32ca6680b583cb44150b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -24,6 +24,7 @@ S="${WORKDIR}/SPIRV-Tools-${PV}"
 multilib_src_configure() {
        local mycmakeargs=(
                "-DSPIRV-Headers_SOURCE_DIR=/usr/"
+               "-DSPIRV_WERROR=OFF"
        )
 
        cmake-utils_src_configure
index 23339df56f9addc0b4670b3263b75689ed8e79c7..cabe3b5e9b76f04045022ef4a9682bf3bb9f4cc4 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -24,6 +24,7 @@ S="${WORKDIR}/SPIRV-Tools-${PV}"
 multilib_src_configure() {
        local mycmakeargs=(
                "-DSPIRV-Headers_SOURCE_DIR=/usr/"
+               "-DSPIRV_WERROR=OFF"
        )
 
        cmake-utils_src_configure
index 593054a38eb96aa1041a6384f53421c35ab6c5f2..9dd96e1985f018c7ea5ff05cf70227adbc8d635e 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -22,6 +22,7 @@ DEPEND=">=dev-util/spirv-headers-1.3.4_pre20180917"
 multilib_src_configure() {
        local mycmakeargs=(
                "-DSPIRV-Headers_SOURCE_DIR=/usr/"
+               "-DSPIRV_WERROR=OFF"
        )
 
        cmake-utils_src_configure