dev-python/future: DISTUTILS_USE_SETUPTOOLS=rdepend
authorMike Gilbert <floppym@gentoo.org>
Wed, 29 Apr 2020 04:05:30 +0000 (00:05 -0400)
committerMike Gilbert <floppym@gentoo.org>
Wed, 29 Apr 2020 04:05:30 +0000 (00:05 -0400)
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
dev-python/future/future-0.18.2.ebuild

index 5e88bab0088290e1565a3651505f9d9f41050db0..15d4b3fa213e9f3de0d68e7a73066928fbbd7feb 100644 (file)
@@ -2,8 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-
 PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
 
 inherit distutils-r1
 
@@ -16,19 +16,16 @@ SLOT="0"
 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
 IUSE="doc"
 
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
-       dev-python/sphinx-bootstrap-theme
-
 # TODO: make numpy unconditional when it supports py3.8
-BDEPEND+="
-       dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
        test? (
-               $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' \
-                       python{2_7,3_{5,6,7}})
+               $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' python{2_7,3_{5,6,7}})
        )
 "
 
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-bootstrap-theme
+
 PATCHES=(
        "${FILESDIR}"/${P}-tests.patch
 )