dev-libs/satyr: bump to 0.27
authorDennis Lamm <expeditioneer@gentoo.org>
Sun, 17 Feb 2019 20:00:46 +0000 (21:00 +0100)
committerDennis Lamm <expeditioneer@gentoo.org>
Sun, 17 Feb 2019 20:00:46 +0000 (21:00 +0100)
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-libs/satyr/Manifest
dev-libs/satyr/satyr-0.27.ebuild [new file with mode: 0644]

index cb6c8364e06c020ef9762c2ce1fc2d3da8459763..84736d4b19e7ce977f5bd63493500348be9f633a 100644 (file)
@@ -1 +1,2 @@
 DIST satyr-0.26.tar.gz 434820 BLAKE2B 4463c69e6ac2eb8237f599bfeed308265a906c6e3efa154b14eb6ee7acdc65580da9baf5ecb99e4efa4f8c00f7656ff2a747e607f2293b12a513ed680986fe08 SHA512 45dfc42e05e93fa0417c8c5d6811097cabaa0f4dcfb79df13d3840d789cfd41c84382ae84882ca120b1a3120987123a306656324cf39f306046a5d30547db656
+DIST satyr-0.27.tar.gz 435341 BLAKE2B ade40bc6a1c48e6fc0af7913ff94ed044c63fdb63b8d86ba010bebcfd2098831bc6c7361d116851aee88f49c640d1457dd8953becad60b6ff6dc32deec6c7942 SHA512 7b01cf16489644fbfbe2150477279a94c6fa9b3310edebc84b83bab58d1058df0be478ab6bf4c6910b4168122721dde10d573711abb983b0eb5ccda09cb80710
diff --git a/dev-libs/satyr/satyr-0.27.ebuild b/dev-libs/satyr/satyr-0.27.ebuild
new file mode 100644 (file)
index 0000000..2ff1248
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit autotools python-r1 toolchain-funcs
+
+DESCRIPTION="Satyr is a collection of low-level algorithms for program failure processing"
+HOMEPAGE="https://github.com/abrt/satyr"
+SRC_URI="https://github.com/abrt/${PN}/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/3"
+
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+       >=dev-libs/elfutils-0.158
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       default
+       ./gen-version || die # Needs to be run before full autoreconf
+       eautoreconf
+       use python && python_copy_sources
+}
+
+src_configure() {
+       local myargs=(
+               --localstatedir="${EPREFIX}/var"
+               --without-rpm
+               # Build breaks without and we aren't supporting Python2 anyway
+               --without-python2
+               $(usex python "--with-python3" "--without-python3")
+       )
+
+       econf "${myargs[@]}"
+}