Updated to use new gkrellm-plugin eclass
authorJim Ramsay <lack@gentoo.org>
Mon, 12 Mar 2007 14:30:06 +0000 (14:30 +0000)
committerJim Ramsay <lack@gentoo.org>
Mon, 12 Mar 2007 14:30:06 +0000 (14:30 +0000)
Package-Manager: portage-2.1.2-r10

x11-plugins/gkrellm-radio/ChangeLog
x11-plugins/gkrellm-radio/gkrellm-radio-2.0.3-r1.ebuild
x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild
x11-plugins/gkrellm-reminder/ChangeLog
x11-plugins/gkrellm-reminder/gkrellm-reminder-2.0.0.ebuild

index 77de080187106873a624ae55c7cb6f2fc1b0a340..72cf972a46a4dc1867ad56c498485a66c427787e 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for x11-plugins/gkrellm-radio
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-radio/ChangeLog,v 1.16 2007/02/21 21:32:31 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-radio/ChangeLog,v 1.17 2007/03/12 14:26:24 lack Exp $
+
+  12 Mar 2007; Jim Ramsay <lack@gentoo.org> gkrellm-radio-2.0.3-r1.ebuild,
+  gkrellm-radio-2.0.4.ebuild:
+  Updated to use new gkrellm-plugin eclass
 
   21 Feb 2007; Jim Ramsay <lack@gentoo.org> metadata.xml,
   -gkrellm-radio-0.3.3.ebuild:
index 3c236a3d2e3a0561532269c72528e73ce7b7c8c9..962ed49ca843ab9a0e021ae9e53b58aa02b7a92a 100644 (file)
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.3-r1.ebuild,v 1.7 2004/06/24 22:57:09 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.3-r1.ebuild,v 1.8 2007/03/12 14:26:24 lack Exp $
+
+inherit gkrellm-plugin
 
 IUSE="lirc"
 
@@ -9,21 +11,16 @@ DESCRIPTION="A minimalistic GKrellM2 plugin to control radio tuners."
 SRC_URI="http://gkrellm.luon.net/files/${P}.tar.gz"
 HOMEPAGE="http://gkrellm.luon.net/gkrellm-radio.phtml"
 
-DEPEND="=app-admin/gkrellm-2*
-       >=media-libs/imlib-1.9.14-r1
-       lirc? ( app-misc/lirc )"
+DEPEND="lirc? ( app-misc/lirc )"
 
 SLOT="2"
 LICENSE="GPL-2"
 KEYWORDS="x86 ppc sparc"
 
+PLUGIN_SO=radio.so
+
 src_compile() {
        use lirc && myconf="${myconf} WITH_LIRC=1"
        emake ${myconf} || die
 }
 
-src_install () {
-       exeinto /usr/lib/gkrellm2/plugins
-       doexe radio.so
-       dodoc README CHANGES
-}
index eb3c186f0c2483fb32c2c8d45422e4a45a177f39..f926f0921a9010800453e21b878ee6dee4d2014b 100644 (file)
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild,v 1.3 2004/09/02 18:22:39 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-radio/gkrellm-radio-2.0.4.ebuild,v 1.4 2007/03/12 14:26:24 lack Exp $
+
+inherit gkrellm-plugin
 
 IUSE="lirc"
 
@@ -9,21 +11,16 @@ DESCRIPTION="A minimalistic GKrellM2 plugin to control radio tuners."
 SRC_URI="http://gkrellm.luon.net/files/${P}.tar.gz"
 HOMEPAGE="http://gkrellm.luon.net/gkrellm-radio.phtml"
 
-DEPEND="=app-admin/gkrellm-2*
-       >=media-libs/imlib-1.9.14-r1
-       lirc? ( app-misc/lirc )"
+DEPEND="lirc? ( app-misc/lirc )"
 
 SLOT="2"
 LICENSE="GPL-2"
 KEYWORDS="~x86 ppc ~sparc"
 
+PLUGIN_SO=radio.so
+
 src_compile() {
        use lirc && myconf="${myconf} WITH_LIRC=1"
        emake ${myconf} || die
 }
 
-src_install () {
-       exeinto /usr/lib/gkrellm2/plugins
-       doexe radio.so
-       dodoc README CHANGES
-}
index 49f5be5d998002723d46241cb143342cead3cde1..69a684cdf8b6d7c316f97aa476d59a1e91ff09a8 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for x11-plugins/gkrellm-reminder
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-reminder/ChangeLog,v 1.14 2007/02/21 17:28:59 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-reminder/ChangeLog,v 1.15 2007/03/12 14:30:06 lack Exp $
+
+  12 Mar 2007; Jim Ramsay <lack@gentoo.org> gkrellm-reminder-2.0.0.ebuild:
+  Updated to use new gkrellm-plugin eclass
 
   21 Feb 2007; Jim Ramsay <lack@gentoo.org> +metadata.xml,
   -gkrellm-reminder-0.3.5.ebuild, gkrellm-reminder-2.0.0.ebuild:
index 6fe75216c270abf8ecb255b69a50fe1937a4fa6b..583f7657d7bb274261ef0a51e03648173bc6ce5d 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-reminder/gkrellm-reminder-2.0.0.ebuild,v 1.12 2007/02/21 17:28:59 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-reminder/gkrellm-reminder-2.0.0.ebuild,v 1.13 2007/03/12 14:30:05 lack Exp $
 
-inherit multilib
+inherit gkrellm-plugin
 
 IUSE=""
 DESCRIPTION="a Reminder Plugin for GKrellM2"
@@ -13,14 +13,5 @@ SLOT="2"
 LICENSE="GPL-2"
 KEYWORDS="x86 ppc sparc alpha amd64"
 
-DEPEND="=app-admin/gkrellm-2*"
+PLUGIN_SO=reminder.so
 
-src_compile() {
-       make || die
-}
-
-src_install () {
-       insinto /usr/$(get_libdir)/gkrellm2/plugins
-       doins reminder.so
-       dodoc README ChangeLog COPYING
-}