touchups
authorMike Frysinger <vapier@gentoo.org>
Wed, 7 Jun 2006 12:49:13 +0000 (12:49 +0000)
committerMike Frysinger <vapier@gentoo.org>
Wed, 7 Jun 2006 12:49:13 +0000 (12:49 +0000)
Package-Manager: portage-2.1_rc2-r3

sys-apps/watchdog/watchdog-5.2.5_p1.ebuild

index 3d1e2dbb453081afa992d1c4659a2e1c2c648b28..1f05ff6ac960d96b8475753a7cab200518199037 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/watchdog/watchdog-5.2.5_p1.ebuild,v 1.2 2006/05/26 12:18:38 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/watchdog/watchdog-5.2.5_p1.ebuild,v 1.3 2006/06/07 12:49:13 vapier Exp $
 
 inherit eutils
 
@@ -29,25 +29,13 @@ src_unpack() {
        epatch "${WORKDIR}"/${MY_P}-${PATCH_LEVEL}.diff
 }
 
-src_compile() {
-       econf || die "econf failed"
-       emake || die "emake failed"
-}
-
 src_install() {
        make DESTDIR="${D}" install || die "make install failed"
 
-       newconfd ${FILESDIR}/${P}-conf.d ${PN}
-       newinitd ${FILESDIR}/${P}-init.d ${PN}
+       newconfd "${FILESDIR}"/${P}-conf.d ${PN}
+       newinitd "${FILESDIR}"/${P}-init.d ${PN}
 
        dodoc AUTHORS README TODO
        docinto examples
        dodoc examples/*
 }
-
-pkg_postinst() {
-       einfo
-       einfo "To enable the start-up script run:"
-       einfo "  # rc-update add watchdog boot"
-       einfo
-}