net-libs/nDPI: Hack around PACKAGE* autoheader definitions
authorJeroen Roovers <jer@gentoo.org>
Tue, 28 Jan 2020 11:40:57 +0000 (12:40 +0100)
committerJeroen Roovers <jer@gentoo.org>
Tue, 28 Jan 2020 11:53:09 +0000 (12:53 +0100)
autogen.sh patches the autogenerated configure script to hide the
PACKAGE* variables from ndpi_config.h, and so should we.

Package-Manager: Portage-2.3.85, Repoman-2.3.20
Closes: https://bugs.gentoo.org/show_bug.cgi?id=704074
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-libs/nDPI/nDPI-3.0-r2.ebuild [new file with mode: 0644]

diff --git a/net-libs/nDPI/nDPI-3.0-r2.ebuild b/net-libs/nDPI/nDPI-3.0-r2.ebuild
new file mode 100644 (file)
index 0000000..50396b2
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools multilib
+
+DESCRIPTION="Open Source Deep Packet Inspection Software Toolkit"
+HOMEPAGE="https://www.ntop.org/"
+SRC_URI="https://github.com/ntop/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="
+       dev-libs/json-c:=
+       net-libs/libpcap
+"
+RDEPEND="
+       ${DEPEND}
+"
+
+src_prepare() {
+       # Taken from autogen.sh (bug #704074):
+       sed \
+               -e "s/@NDPI_MAJOR@/$(ver_cut 1)/g" \
+               -e "s/@NDPI_MINOR@/$(ver_cut 2)/g" \
+               -e "s/@NDPI_PATCH@/$(ver_cut 3)/g" \
+               -e "s/@NDPI_VERSION_SHORT@/${PV}/g" \
+               < "${S}/configure.seed" \
+               > "${S}/configure.ac" || die
+
+       sed -i \
+               -e "s%^libdir\s*=\s*\${prefix}/lib\s*$%libdir     = \${prefix}/$(get_libdir)%" \
+               src/lib/Makefile.in || die
+
+       default
+       eautoreconf
+
+       # Taken from autogen.sh (bug #704074):
+       sed -i \
+               -e "s/#define PACKAGE/#define NDPI_PACKAGE/g" \
+               -e "s/#define VERSION/#define NDPI_VERSION/g" \
+               configure || die
+}
+
+src_install() {
+       default
+       if ! use static-libs; then
+               rm "${D}"/usr/$(get_libdir)/lib${PN,,}.a || die
+       fi
+}