sys-apps/readahead-list: Fix gcc6 support, bug #594092 by Peter Levine, also stop...
authorPacho Ramos <pacho@gentoo.org>
Tue, 4 Apr 2017 11:57:04 +0000 (13:57 +0200)
committerPacho Ramos <pacho@gentoo.org>
Tue, 4 Apr 2017 12:05:09 +0000 (14:05 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

sys-apps/readahead-list/files/readahead-list-1.20060421.1016-gcc-4.3.patch
sys-apps/readahead-list/files/readahead-list-1.20060421.1016-gcc6.patch [new file with mode: 0644]
sys-apps/readahead-list/readahead-list-1.20060421.1016-r2.ebuild [new file with mode: 0644]

index 6264bbad95253e9f096697321c2a26741a252aa7..ccee025dcbf8e3907312e59c30b990cf26744e84 100644 (file)
@@ -1,5 +1,5 @@
---- src/filelist-order.cxx
-+++ src/filelist-order.cxx
+--- a/src/filelist-order.cxx
++++ b/src/filelist-order.cxx
 @@ -19,6 +19,7 @@
  #include <iostream>
  #include <fstream>
diff --git a/sys-apps/readahead-list/files/readahead-list-1.20060421.1016-gcc6.patch b/sys-apps/readahead-list/files/readahead-list-1.20060421.1016-gcc6.patch
new file mode 100644 (file)
index 0000000..a987e4a
--- /dev/null
@@ -0,0 +1,15 @@
+filelist-order.cxx:276:37: error: unable to find string literal operator ‘operator""fmt’ with ‘const char [3]’, ‘long unsigned int’ arguments
+
+https://bugs.gentoo.org/594092
+
+--- a/src/filelist-order.cxx
++++ b/src/filelist-order.cxx
+@@ -273,7 +273,7 @@ void printItem(PAIR_COMPLETE_TYPE p,vector <OrderField*> *ofa) {
+                                       continue;
+                               }
+                               OrderField of = *ofp;
+-#define case_entry(fmt,func) printf("%s"fmt,(first ? "" : " "),func_##func(mk)); break;
++#define case_entry(fmt,func) printf("%s" fmt,(first ? "" : " "),func_##func(mk)); break;
+                               switch(of.type) {
+                                       case ST_DEV: case_entry("%lld",ST_DEV);
+                                       case ST_INO: case_entry("%lld",ST_INO);
diff --git a/sys-apps/readahead-list/readahead-list-1.20060421.1016-r2.ebuild b/sys-apps/readahead-list/readahead-list-1.20060421.1016-r2.ebuild
new file mode 100644 (file)
index 0000000..80b37f7
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Preloads files into the page cache to accelerate program loading"
+HOMEPAGE="http://www.orbis-terrarum.net"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       virtual/os-headers
+"
+
+PATCHES=(
+       "${FILESDIR}/${P}-gcc-4.3.patch"
+       "${FILESDIR}/${P}-gcc6.patch"
+)
+
+src_configure() {
+       econf --sbindir=/sbin
+}
+
+src_install() {
+       default
+
+       # init scripts
+       #cd "${S}/contrib/init/gentoo/"
+       newinitd "${FILESDIR}"/init.d-readahead-list readahead-list
+       newinitd "${FILESDIR}"/init.d-readahead-list-early readahead-list-early
+       newconfd "${FILESDIR}"/conf.d-readahead-list readahead-list
+
+       # default config
+       insinto /etc/readahead-list
+       cd "${S}/contrib/data"
+       newins readahead.runlevel-default.list runlevel-default
+       newins readahead.runlevel-boot.list runlevel-boot
+       newins readahead._sbin_rc.list exec_sbin_rc
+
+       # docs
+       cd "${S}"
+       if use doc; then
+               docinto scripts
+               dodoc contrib/scripts/*
+       fi
+       # clean up a bit
+       find "${D}/usr/share/doc/${PF}/" -type f -name 'Makefile*' -exec rm -f \{\} \;
+}
+
+pkg_postinst() {
+       einfo "You should add readahead-list to your runlevels:"
+       einfo "  rc-update add readahead-list-early boot"
+       einfo "  rc-update add readahead-list boot"
+       einfo "Also consider customizing the lists in /etc/readahead-list"
+       einfo "for maximum performance gain."
+}