dev-perl/Archive-Tar-Stream: -r1 QA pass (EAPI,LICENSE,DEPS)
authorKent Fredric <kentnl@gentoo.org>
Tue, 28 Apr 2020 13:37:24 +0000 (01:37 +1200)
committerKent Fredric <kentnl@gentoo.org>
Tue, 28 Apr 2020 13:42:06 +0000 (01:42 +1200)
- Move to EAPI7
- Remove redundant and incorrect LICENSE ( things with license="perl"
  are correctly handled by perl-module.eclass defaults, and its || (
    Artistic-1 GPL-1+ )
- Remove unwanted tests
- Remove incorrect HOMEPAGE ( default provided by perl-module.eclass
  is more correct as the official authorship of a package changes over
  time, and the metacpan default URL thus maps correctly )

Package-Manager: Portage-2.3.97, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Archive-Tar-Stream/Archive-Tar-Stream-0.30.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Archive-Tar-Stream/Archive-Tar-Stream-0.30.0-r1.ebuild b/dev-perl/Archive-Tar-Stream/Archive-Tar-Stream-0.30.0-r1.ebuild
new file mode 100644 (file)
index 0000000..06d8f2b
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=CDRAKE
+DIST_VERSION=0.03
+inherit perl-module
+
+DESCRIPTION="pure perl IO-friendly tar file management"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       virtual/perl-File-Temp
+       virtual/perl-IO
+"
+BDEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       test? (
+               virtual/perl-Test-Simple
+       )
+"
+PERL_RM_FILES=(
+       "t/pod-coverage.t"
+       "t/pod.t"
+       "t/manifest.t"
+)