media-sound/pnmixer: version bump to 0.6_rc1
authorJulian Ospald <hasufell@gentoo.org>
Sun, 9 Aug 2015 18:18:12 +0000 (20:18 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Sun, 9 Aug 2015 18:18:54 +0000 (20:18 +0200)
media-sound/pnmixer/Manifest
media-sound/pnmixer/pnmixer-0.6_rc1.ebuild [new file with mode: 0644]

index 5d31624d3143ef72bbb5a6f2d536b2380a0ab2f9..9a97dd4979d81958a0c5d73f2d14970f28bcdfe1 100644 (file)
@@ -1,2 +1,3 @@
 DIST pnmixer-0.6_pre20111213.tar.xz 131328 SHA256 aa42180145aa56639440168935a8b16c576e6e49db0bbe2955b79a890437f013 SHA512 967a685593256f9f2e8ab2ef955a91a03c3710d96956087ac55301d5232e6f01897efbb064bd6dc1804836af1b66c038cb3d04203043462de5246e4f14dd37c4 WHIRLPOOL 1fe36a5ea212447212bbd9b6b4efee22e1f75fbb0f2c0548447c0987664d94524e306e2942f6e96c6f10cf6bf15abc35df6b7953d63ef8ec2241eef3d627c16d
 DIST pnmixer-0.6_pre20140924.tar.gz 263467 SHA256 8db9160fe5a41222e84ef19a38264f3633629013971f7fe549733e5644429558 SHA512 4ed5a5fb8cfa5a0f0757a30c78cb4b90fa8d1fa64234f18306941ef4382af66f49ecce2a833c1784e547b840bab36eab7d0c1f85cb89bde81c117472669ba283 WHIRLPOOL 54bd420e5bdfb76b155440f3f44f3e1e207ed116c3ff664429c0f8ced5945c6545daf0be8ffcede91ead1983882a6e1a18e61d8708f6a24719a0065e250a884a
+DIST pnmixer-0.6_rc1.tar.gz 211924 SHA256 93573056c50fdd6feb881e2c0e1538563996dc26c2fe52ce857bc28fdbc3c589 SHA512 cd617b473067f97b0e830c43d4ee1bc500f6ce953546dd2d062882e11f61c05354aaaa96688b958471f94064b68652715cddfd7fc9dca46b47a6296d0f591cc2 WHIRLPOOL fb3ae98b3274dccfbe0031051ddacddbb8cfd81483f6cd854ad565d506bde92475224a7131138dc44c0d750bc361d19fe914e05c5e6c3ae0e8d894ed2f4429a8
diff --git a/media-sound/pnmixer/pnmixer-0.6_rc1.ebuild b/media-sound/pnmixer/pnmixer-0.6_rc1.ebuild
new file mode 100644 (file)
index 0000000..3c3e658
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+WANT_LIBTOOL=none
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="Volume mixer for the system tray"
+HOMEPAGE="https://github.com/nicklan/pnmixer"
+SRC_URI="https://github.com/nicklan/pnmixer/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug libnotify"
+
+RDEPEND="dev-libs/glib:2
+       media-libs/alsa-lib
+       >=x11-libs/gtk+-3.6:3
+       x11-libs/libX11
+       libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDEPEND}
+       sys-devel/gettext
+       virtual/pkgconfig"
+
+src_prepare() {
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               $(use_with libnotify) \
+               $(use_enable debug) \
+               --enable-minimal-flags \
+               --with-gtk3
+}
+
+pkg_preinst() {
+       gnome2_icon_savelist
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}