app-leechcraft/lc-core: remove sqlite USE flag, fix qtsql dep
author0xd34df00d <0xd34df00d@gmail.com>
Sat, 4 Apr 2020 20:58:55 +0000 (16:58 -0400)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 9 Apr 2020 12:37:44 +0000 (15:37 +0300)
sqlite is needed unconditionally now.

Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Georg Rudoy <0xd34df00d@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-leechcraft/lc-core/lc-core-9999.ebuild

index 21417469730251cb852213605848fc8f739b5d0d..1de10d56658700d304b5d53d352d4ffd6f82f0db 100644 (file)
@@ -11,7 +11,7 @@ DESCRIPTION="Core of LeechCraft, the modular network client"
 
 SLOT="0"
 KEYWORDS=""
-IUSE="debug doc postgres +qwt +sqlite"
+IUSE="debug doc postgres +qwt"
 
 DEPEND="
        dev-libs/boost:=
@@ -22,7 +22,7 @@ DEPEND="
        dev-qt/qtgui:5
        dev-qt/qtnetwork:5[ssl]
        dev-qt/qtscript:5
-       dev-qt/qtsql:5[postgres?,sqlite?]
+       dev-qt/qtsql:5
        dev-qt/qtwebkit:5
        dev-qt/qtwidgets:5
        dev-qt/qtx11extras:5
@@ -30,6 +30,7 @@ DEPEND="
        qwt? ( x11-libs/qwt:6 )
 "
 RDEPEND="${DEPEND}
+       dev-qt/qtsql:5[postgres?,sqlite]
        dev-qt/qtsvg:5
        || (
                kde-frameworks/oxygen-icons
@@ -41,8 +42,6 @@ BDEPEND="
        doc? ( app-doc/doxygen )
 "
 
-REQUIRED_USE="|| ( postgres sqlite )"
-
 src_configure() {
        local mycmakeargs=(
                -DWITH_PLUGINS=False