dev-python/tenacity: initial commit
authorMatthew Thode <prometheanfire@gentoo.org>
Mon, 27 Feb 2017 01:43:34 +0000 (19:43 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 27 Feb 2017 02:15:27 +0000 (20:15 -0600)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/tenacity/Manifest [new file with mode: 0644]
dev-python/tenacity/metadata.xml [new file with mode: 0644]
dev-python/tenacity/tenacity-3.7.1.ebuild [new file with mode: 0644]

diff --git a/dev-python/tenacity/Manifest b/dev-python/tenacity/Manifest
new file mode 100644 (file)
index 0000000..98a7b9b
--- /dev/null
@@ -0,0 +1 @@
+DIST tenacity-3.7.1.tar.gz 22915 SHA256 86cae49f4334277164b97a1871828e9173d669b9bb223de44ba8c1cee787bbfa SHA512 83f277da3ee7beca4d564610a4ef46c33a87590214a41c0c36c9bb46920e5e8e7e8a8d130dcaac2802d058f7e995fbe01e13d5b7a65821e9a1e83072b78e3f00 WHIRLPOOL c8747efea73d5fd966cd448dc3b2d33341f0ed2a53287df2fe98b0a587522b984461be07159e5b0817b60650e3cfafb0a6e673d1dcd96b7c138782728c75df63
diff --git a/dev-python/tenacity/metadata.xml b/dev-python/tenacity/metadata.xml
new file mode 100644 (file)
index 0000000..b607cbf
--- /dev/null
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>prometheanfire@gentoo.org</email>
+               <name>Matthew Thode</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>openstack@gentoo.org</email>
+               <name>Openstack</name>
+       </maintainer>
+       <longdescription lang="en">
+       Tenacity is an Apache 2.0 licensed general-purpose retrying library, written in Python, to simplify the task of adding retry behavior to just about anything. It originates from a fork of Retrying.
+       </longdescription>
+       <upstream>
+               <remote-id type="pypi">tenacity</remote-id>
+               <remote-id type="github">jd/tenacity</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/tenacity/tenacity-3.7.1.ebuild b/dev-python/tenacity/tenacity-3.7.1.ebuild
new file mode 100644 (file)
index 0000000..05bfffd
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="General-purpose retrying library"
+HOMEPAGE="https://github.com/rholder/retrying"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+       >=dev-python/six-1.7.0[${PYTHON_USEDEP}]
+       virtual/python-futures[${PYTHON_USEDEP}]
+       >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
+       dev-python/debtcollector[${PYTHON_USEDEP}]
+"