sci-mathematics/dunshire: new revision supporting python-3.{7,8}.
authorMichael Orlitzky <mjo@gentoo.org>
Sun, 19 Apr 2020 22:13:32 +0000 (18:13 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Sun, 19 Apr 2020 23:16:12 +0000 (19:16 -0400)
Updated to EAPI=7 and added a missing dependency while I was at it.

Closes: https://bugs.gentoo.org/718502
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
sci-mathematics/dunshire/dunshire-0.1.1-r1.ebuild [moved from sci-mathematics/dunshire/dunshire-0.1.1.ebuild with 58% similarity]

similarity index 58%
rename from sci-mathematics/dunshire/dunshire-0.1.1.ebuild
rename to sci-mathematics/dunshire/dunshire-0.1.1-r1.ebuild
index 82de99fb080fc12b51b74fe5c22134057138a7d2..2824f031c3779aab0ac11f3a186f816a9b0d8f09 100644 (file)
@@ -1,14 +1,14 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
 
 inherit distutils-r1
 
 DESCRIPTION="Python library to solve linear games over symmetric cones"
-HOMEPAGE="http://michael.orlitzky.com/code/dunshire"
+HOMEPAGE="http://michael.orlitzky.com/code/dunshire/"
 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="AGPL-3+"
@@ -18,8 +18,15 @@ IUSE="doc test"
 RESTRICT="!test? ( test )"
 
 RDEPEND="dev-python/cvxopt[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# Tests run on the build host? Bug #693916. There's one doctest that
+# uses a numpy matrix, sorry. That will be fixed in the next release.
+# Otherwise numpy is not needed; the required interfaces are provided
+# through cvxopt.
+BDEPEND="test? (
+       ${RDEPEND}
+        dev-python/numpy[${PYTHON_USEDEP}]
+)"
 
 python_install_all() {
        use doc && local HTML_DOCS=( doc/build/html/. )