sys-libs/glibc: set correct cross-CC for sparc32
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 2 Apr 2020 07:01:38 +0000 (08:01 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 2 Apr 2020 07:03:31 +0000 (08:03 +0100)
Commit "sys-libs/glibc: Drop SPARC CHOST mangling"
exposed a old bug where we were setting CC=${CTARGET_OPT}.

But we don't have ${CTARGET_OPT}-gcc or anything else
and thus fallback to 'gcc' happens.

Always use CC=${CTARGET}.

Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-libs/glibc/glibc-2.29-r7.ebuild
sys-libs/glibc/glibc-2.30-r6.ebuild
sys-libs/glibc/glibc-2.31-r2.ebuild
sys-libs/glibc/glibc-9999.ebuild

index 1ffe9800d1dcd9fb1b2580d426e1ae42d2faf4f4..6492f3e4beecbc13e2f45827628afe96083cbc49 100644 (file)
@@ -446,7 +446,7 @@ setup_env() {
        # configure script checks CFLAGS for some targets (like mips).  Keep
        # around the original clean value to avoid appending multiple ABIs on
        # top of each other.
-       : ${__GLIBC_CC:=$(tc-getCC ${CTARGET_OPT:-${CTARGET}})}
+       : ${__GLIBC_CC:=$(tc-getCC ${CTARGET})}
        export __GLIBC_CC CC="${__GLIBC_CC} ${!VAR}"
        einfo " $(printf '%15s' 'Manual CC:')   ${CC}"
 }
index 00846478a13e48fcdb4ec0f2d789d0be51da4a1c..779353d0f84167ef096e0021616ea1688d4716f5 100644 (file)
@@ -472,7 +472,7 @@ setup_env() {
        # configure script checks CFLAGS for some targets (like mips).  Keep
        # around the original clean value to avoid appending multiple ABIs on
        # top of each other.
-       : ${__GLIBC_CC:=$(tc-getCC ${CTARGET_OPT:-${CTARGET}})}
+       : ${__GLIBC_CC:=$(tc-getCC ${CTARGET})}
        export __GLIBC_CC CC="${__GLIBC_CC} ${!VAR}"
        einfo " $(printf '%15s' 'Manual CC:')   ${CC}"
 }
index a46143ef0a5ded6ca911590b18dd52f23b0eb9b0..db866fbf1a24eb2de1282b333110567cf679e01f 100644 (file)
@@ -463,7 +463,7 @@ setup_env() {
        # configure script checks CFLAGS for some targets (like mips).  Keep
        # around the original clean value to avoid appending multiple ABIs on
        # top of each other.
-       : ${__GLIBC_CC:=$(tc-getCC ${CTARGET_OPT:-${CTARGET}})}
+       : ${__GLIBC_CC:=$(tc-getCC ${CTARGET})}
        export __GLIBC_CC CC="${__GLIBC_CC} ${!VAR}"
        einfo " $(printf '%15s' 'Manual CC:')   ${CC}"
 }
index 38268c5f93728dfacb51a8a3fafb1d293de89dce..ca7219535589c7b7342a91963319e8b215cefd7c 100644 (file)
@@ -462,7 +462,7 @@ setup_env() {
        # configure script checks CFLAGS for some targets (like mips).  Keep
        # around the original clean value to avoid appending multiple ABIs on
        # top of each other.
-       : ${__GLIBC_CC:=$(tc-getCC ${CTARGET_OPT:-${CTARGET}})}
+       : ${__GLIBC_CC:=$(tc-getCC ${CTARGET})}
        export __GLIBC_CC CC="${__GLIBC_CC} ${!VAR}"
        einfo " $(printf '%15s' 'Manual CC:')   ${CC}"
 }