dev-ruby/hiera-eyaml: cleanup masked slots
authorHans de Graaff <graaff@gentoo.org>
Sat, 18 May 2019 05:33:21 +0000 (07:33 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sat, 18 May 2019 05:33:21 +0000 (07:33 +0200)
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-ruby/hiera-eyaml/Manifest
dev-ruby/hiera-eyaml/hiera-eyaml-2.1.0-r2.ebuild [deleted file]

index 2118e3f1a357f76cfc3eb41d1c12ea731d56cf59..2d3e7439b05670bb3978b1ee347f45009026e4e4 100644 (file)
@@ -1,2 +1 @@
-DIST hiera-eyaml-2.1.0.tar.gz 46179 BLAKE2B a25eaf1e013af4add5c4628dab168daedfeb8763038f4e003d5e48b5e51ddc25dbbb8b01d024836163089106d0786d27af43113b3db950ecb302c3ec5a82d7a8 SHA512 b85de0de0cb4f4a7b381ec7e406e5b3858b1e93b5475830df6991fc679d1391a88dd988c0d266942e70fb4705ba47cb656fd732bd923f8290dd90a5bf6e4a5fb
 DIST hiera-eyaml-3.0.0.tar.gz 54416 BLAKE2B 75587799b228562ae89ab4e46fdd5d4a256f66403df0a2c0761aadec17fb3fa95c1207aee5a4663bcbd843c7d6e0594ce2c0edf6973184b64522a987d628b549 SHA512 805496478d0fe142ea1661345d92e5ad2ad4c18c98bb83c8f799031b784a997e1aee2a11b46600a8ddbe0b147072ea0f83fbfa100df5b5fc534d7489850d9827
diff --git a/dev-ruby/hiera-eyaml/hiera-eyaml-2.1.0-r2.ebuild b/dev-ruby/hiera-eyaml/hiera-eyaml-2.1.0-r2.ebuild
deleted file mode 100644 (file)
index ff6b41f..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGES.md PLUGINS.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Encrypted YAML backend for hiera"
-HOMEPAGE="https://github.com/TomPoulton/hiera-eyaml"
-SRC_URI="https://github.com/TomPoulton/hiera-eyaml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-ruby_add_rdepend ">=dev-ruby/highline-1.6.19"
-ruby_add_rdepend "dev-ruby/trollop:2"
-ruby_add_rdepend "!!dev-ruby/hiera-eyaml:3" # both install the /usr/bin/eyaml binary
-
-ruby_add_bdepend "test? ( dev-util/cucumber ~dev-util/aruba-0.6.2 <app-admin/puppet-5 dev-ruby/hiera-eyaml-plaintext )"
-
-all_ruby_prepare() {
-       # Fix highline dependency to be compatible with more versions.
-       sed -i -e '/highline/ s/~>/>=/' \
-               -e '/gem.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
-
-       sed -i -e 's:/tmp:'${T}':' \
-               features/sandbox/puppet/environments/local/modules/test/manifests/init.pp \
-               features/sandbox/puppet-hiera-merge/environments/local/modules/test/manifests/init.pp \
-               features/puppet.feature
-}
-
-each_ruby_prepare() {
-       # Run tests with the correct ruby interpreter
-       sed -i -e 's:I run `eyaml:I run `'${RUBY}' '${S}'/bin/eyaml:' features/*.feature || die
-
-}
-
-each_ruby_test() {
-       ${RUBY} -S cucumber --format progress features || die
-}