dev-perl/Graph-Easy: Add w/ version=0.760.0 re bug #718722
authorKent Fredric <kentnl@gentoo.org>
Thu, 30 Apr 2020 21:25:48 +0000 (09:25 +1200)
committerKent Fredric <kentnl@gentoo.org>
Thu, 30 Apr 2020 21:27:28 +0000 (09:27 +1200)
Closes: https://bugs.gentoo.org/718722
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Graph-Easy/Graph-Easy-0.760.0.ebuild [new file with mode: 0644]
dev-perl/Graph-Easy/Manifest [new file with mode: 0644]
dev-perl/Graph-Easy/metadata.xml [new file with mode: 0644]

diff --git a/dev-perl/Graph-Easy/Graph-Easy-0.760.0.ebuild b/dev-perl/Graph-Easy/Graph-Easy-0.760.0.ebuild
new file mode 100644 (file)
index 0000000..3edf636
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=0.76
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Convert or render graphs (as ASCII, HTML, SVG or via Graphviz)"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=virtual/perl-Scalar-List-Utils-1.130.0
+"
+DEPEND="
+       dev-perl/Module-Build
+"
+BDEPEND="${RDEPEND}
+       >=dev-perl/Module-Build-0.360.0
+       test? (
+               dev-perl/Test-Differences
+               >=virtual/perl-Test-Simple-0.620.0
+       )
+"
+PERL_RM_FILES=(
+       "t/style-trailing-space.t"
+       "t/pod.t"
+       "t/pod_cov.t"
+)
diff --git a/dev-perl/Graph-Easy/Manifest b/dev-perl/Graph-Easy/Manifest
new file mode 100644 (file)
index 0000000..ca55a2b
--- /dev/null
@@ -0,0 +1 @@
+DIST Graph-Easy-0.76.tar.gz 467184 BLAKE2B b6024a6f9e2e97d47806eb0b263af11e3e9b6b4fcb52da1107f81db51cae3d005391779e3d670daef7a8a6fd9da2cb969c6d206b5afb62f8c6b253ad882214b8 SHA512 c5f93252a047ccb0c02347f9f138217c1d52b10ba67db100de7d57a716b3da8d564ecbddedd795420eccc6fe4733bd9b3e64d1fda7d203b144c6112d6bfbe6d0
diff --git a/dev-perl/Graph-Easy/metadata.xml b/dev-perl/Graph-Easy/metadata.xml
new file mode 100644 (file)
index 0000000..979a887
--- /dev/null
@@ -0,0 +1,39 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="project">
+    <email>perl@gentoo.org</email>
+    <name>Gentoo Perl Project</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="cpan">Graph-Easy</remote-id>
+    <remote-id type="cpan-module">Graph::Easy</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::As_ascii</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::As_graphml</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::As_graphviz</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::As_txt</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::As_vcg</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Attributes</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Base</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Edge</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Edge::Cell</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Group</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Group::Anon</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Group::Cell</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Layout</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Layout::Chain</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Layout::Force</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Layout::Grid</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Layout::Path</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Layout::Repair</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Layout::Scout</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Node</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Node::Anon</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Node::Cell</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Node::Empty</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Parser</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Parser::Graphviz</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Parser::VCG</remote-id>
+    <remote-id type="cpan-module">Graph::Easy::Util</remote-id>
+  </upstream>
+</pkgmetadata>